1/16th, 1/18th, Mini & Micro RC Cars Discuss 1/16, 1/18, Minis, Micros & any RC Cars smaller than 1/10th scale in this forum

Official HPI Savage Flux XS thread...

Reply
Old 04-26-2012, 06:54 AM
  #2926
t9dragon
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Still running the stock motor and esc in both of our XS's....
t9dragon is offline  
Reply With Quote
Old 04-26-2012, 06:55 AM
  #2927
billymare
 
Join Date: Aug 2009
Location: Islip , NY
Posts: 381
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Looking to do a speed run...
Quote:
ORIGINAL: rologti


Quote:
ORIGINAL: billymare



But i am sooooo tempted

Go Go Go Go....Go for it!!!!!!!!!!!!......but video..PLEASE!!!!!...would love to see how does it runs with 4S...

Thinking in speed runs or bashing???

billymare is offline  
Reply With Quote
Old 04-26-2012, 06:55 AM
  #2928
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: Elcee

Thanks for the comment rologti

I know I've done something wrong, but can't figure out exactly what. Could you post a pic of how yours looks? (Assuming you're not at work)

I've got the steering servo in place, the little annodized arm is connected to the servo pointing straight up. There's a ball joint connected to that with a bar connecting it to the arm thats hitting the chassis

Not sure thatexplanation is helping anybody...
@work right now...here is 11:50AM...Uk is about 17:50 or 16:50...

But 99.9% sure that your problem is the same that I had

The servo saver has a shaft...by the side of the servo...that's your problem...

Have whatsApp, BB messenger or something like that??..PM me and we talk
rologti is offline  
Reply With Quote
Old 04-26-2012, 06:58 AM
  #2929
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: t9dragon

Still running the stock motor and esc in both of our XS's....
The only living case I know....sure you have some special prototypes...
rologti is offline  
Reply With Quote
Old 04-26-2012, 07:06 AM
  #2930
t9dragon
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: rologti


Quote:
ORIGINAL: t9dragon

Still running the stock motor and esc in both of our XS's....
The only living case I know....sure you have some special prototypes...
I am not sure... LOL...

But I have two ESC's ready to go if either one decides to go and puff smoke.

t9dragon is offline  
Reply With Quote
Old 04-26-2012, 07:48 AM
  #2931
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Yea my stock esc went up, i should be getting it back this week. but i am purchasing the castle 1410 3800kv sct system as a backup. a little more power never hurt anyone
cumminspower5.9 is offline  
Reply With Quote
Old 04-26-2012, 11:29 AM
  #2932
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Not sure if anybody noticed when they first got their xs, but after taking the motor wires out from the esc, the A wire was in the C in the esc, B was in B, and C was in A. if you put it all matching, it doesn;t work. wierd.
cumminspower5.9 is offline  
Reply With Quote
Old 04-26-2012, 11:31 AM
  #2933
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: cumminspower5.9

Not sure if anybody noticed when they first got their xs, but after taking the motor wires out from the esc, the A wire was in the C in the esc, B was in B, and C was in A. if you put it all matching, it doesn;t work. wierd.

I have the SS so I don't know....but the ESC should be programmed in "reverse" mode...could this be the reason???
rologti is offline  
Reply With Quote
Old 04-27-2012, 05:49 AM
  #2934
Gangster_Elmo
 
Join Date: Aug 2011
Location: , WA
Posts: 21
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: rologti

The only living case I know....sure you have some special prototypes...
Mine is still going strong on stock ESC as well. I guess all the good ones got sent to the Pacific NW.

Gangster_Elmo is offline  
Reply With Quote
Old 04-27-2012, 06:07 AM
  #2935
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...



Well, HPI has failed again. Yesterday, after 6 weeks, i finally recieved a package in which it was believed to be my ESC. Turns out, they sent me the bulkhead/esc mount parts! But no frickin esc. It even says on the paper inside (shipping order) that it was shipped. what the hell is going on over there. is it something in the California air?? I'm calling them today to complain about it, and i'm telling them to have it to me by Wednesday of next week at the latest. I did purchase a Castle 1410 system, but it is on backorder as well. So if anyone wants a NEW Flux Vapor Pro ESC, PM me. Remember these go for $130 on average. PM me if you want it and for how much.

cumminspower5.9 is offline  
Reply With Quote
Old 04-27-2012, 06:57 AM
  #2936
fastgreen350
 
Join Date: Mar 2012
Location: La Barge, WY
Posts: 64
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

When u call tell them u want a q base for the inconvenience.
fastgreen350 is offline  
Reply With Quote
Old 04-27-2012, 07:02 AM
  #2937
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...



Haha well I just called them and they said the Flux Vapor ESC is still on backorder. So they sent me the mount first and the esc should be shipped to me in the next week or two. This sucks. Why not get a massive load of these esc if you know people are using the warranty for replacement? doesn't make any sense. So I should have that in about 2 weeks or so, and my castle sct system is on backorder and amainhobbies expects them to be in may 5th. this sucks []

cumminspower5.9 is offline  
Reply With Quote
Old 04-27-2012, 07:40 AM
  #2938
Foxy
Moderator
Thread Starter
 
Foxy's Avatar
 
Join Date: Mar 2005
Location: Kingston UK, but living in Athens, GREECE
Posts: 18,082
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: cumminspower5.9

Not sure if anybody noticed when they first got their xs, but after taking the motor wires out from the esc, the A wire was in the C in the esc, B was in B, and C was in A. if you put it all matching, it doesn;t work. wierd.
Normal.

Depends which ESC is used. Some go one way, others go the other, and the way to resolve this is to swap the middle and either outside wire, which is often done during manufacture on RTRs.
Foxy is offline  
Reply With Quote
Old 04-27-2012, 08:01 AM
  #2939
iTz Nicholas72
 
Join Date: Feb 2010
Location: Asheville, NC
Posts: 122
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

On the fence about selling my Savage XS SS. It's been problem after problem but for the few minutes I've been able to drive it's been a blast. Really considering selling it as a roller and getting an Axial Exo Terra since those from what I've seen/heard are actually built using quality parts.
iTz Nicholas72 is offline  
Reply With Quote
Old 04-27-2012, 08:24 AM
  #2940
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: iTz Nicholas72

On the fence about selling my Savage XS SS. It's been problem after problem but for the few minutes I've been able to drive it's been a blast. Really considering selling it as a roller and getting an Axial Exo Terra since those from what I've seen/heard are actually built using quality parts.
I also have the SS...true there are somethings that doesn't fit right.....and there are some parts that should be improved/changed...for example mine has a faulty shock...

But I'm sure you have just bad luck...give it another oportunity....it's really fun

BTW...I have 4 dogs...and my wife usually take a walk with them....since she is pregnant I usually go with her....yesterday I went with her and the XS...the greyhound (one of the four dogs) get crazy with the XS...some really nice races...in short races the XS win....long races...I still don't know...hahaha
rologti is offline  
Reply With Quote
Old 04-27-2012, 08:29 AM
  #2941
Elcee
 
Join Date: Mar 2012
Location: , UNITED KINGDOM
Posts: 12
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

iTz Nicholas; I thought your build went quite well and being SS wouldn't be plagued by the ESC demons.  What problems have you been experiencing?

Thanks to rologti my SS should be hitting the streets as soon as I can get my greasy mitts on some EC5 connectors.  Can't for the live of me work out why Deans are more popular than EC5.  Is it just familiarity?
Elcee is offline  
Reply With Quote
Old 04-27-2012, 08:46 AM
  #2942
fastgreen350
 
Join Date: Mar 2012
Location: La Barge, WY
Posts: 64
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Wierd that they are on backorder, I just got mine a few days ago. Something isnt adding up here with HPI maybe the new batch they sent out is defective and they held them all back or something. I told them I wanted a Qbase and they said that was on backorder, kinda makes u wonder how they are still producing the cars with these on. Ifinall got my MMP back from CAstle and it was cutting out under quick accelation so I called and I had to order a 20$ BEC to make a 130$ ESCwork doent make sence either, but what ya gonna do seems like everyones quality sux these days.



Quote:
ORIGINAL: cumminspower5.9



Haha well I just called them and they said the Flux Vapor ESC is still on backorder. So they sent me the mount first and the esc should be shipped to me in the next week or two. This sucks. Why not get a massive load of these esc if you know people are using the warranty for replacement? doesn't make any sense. So I should have that in about 2 weeks or so, and my castle sct system is on backorder and amainhobbies expects them to be in may 5th. this sucks []

fastgreen350 is offline  
Reply With Quote
Old 04-27-2012, 08:59 AM
  #2943
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

So if anybody wants a factory new Flux Vapor Pro esc, just PM me and i'll let you know when I get it.
cumminspower5.9 is offline  
Reply With Quote
Old 04-27-2012, 06:39 PM
  #2944
llkoolskillet
 
Join Date: May 2009
Location: Colorado Springs, CO
Posts: 1,008
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

I got the XS rtr and for the life of me I cant get this esc crap sorted out. I run it only on 2s and ive killed the Vapor. Then I install the MMP and on the second pack it went up in smoke. Less than 5min on the second pack too. The thermal cut off engages all the time and the wires, motor and esc a really hot. So hot infact that it turned black electrical tape white.

I ran the stock vapor esc today on 3s and it lasted less than 5min. The red light came on and stayed on, there was still power to the steering servo, but nothing else. Before is died the truck would jerk and vibrate then quit.

So now I have to send in the vapor esc to HPI and MMP to castle. Ive been reading this thread and have noticed that the SCT MMP might be a solution, as well as gearing down. another option is the X car HK 4000kv sensored motor paried with the MMP on 3s.

The mods I have now are

Proline Trenchers mounted on Desparados
Hot Racing rear hubs
Traxxas wheelie bar
Hot racing springs
ST racing wheelie king extended drive cups w/ custom spacers
Blitz 12mm hex w/ 2mm pins

I run Turingy 5000mAh 40c 2s and 3s batteries

Does anyone have any ideas to solve this over heating issue?
Attached Thumbnails
Click image for larger version

Name:	Yw67187.jpg
Views:	132
Size:	87.0 KB
ID:	1755761   Click image for larger version

Name:	Dy78352.jpg
Views:	104
Size:	90.7 KB
ID:	1755762   Click image for larger version

Name:	Qv53898.jpg
Views:	117
Size:	68.6 KB
ID:	1755763   Click image for larger version

Name:	Yr47836.jpg
Views:	99
Size:	69.2 KB
ID:	1755764   Click image for larger version

Name:	Oz31458.jpg
Views:	92
Size:	42.1 KB
ID:	1755765   Click image for larger version

Name:	Qh65513.jpg
Views:	102
Size:	76.3 KB
ID:	1755766   Click image for larger version

Name:	Ig11173.jpg
Views:	125
Size:	74.4 KB
ID:	1755767  
llkoolskillet is offline  
Reply With Quote
Old 04-28-2012, 06:20 AM
  #2945
fastgreen350
 
Join Date: Mar 2012
Location: La Barge, WY
Posts: 64
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Did u gear it down with that bigger tire on there?  I had some problems with my MMP also they sent me a new one and now it glitched and cuts out,  It sdue to the MMPs weak bec though, ordered the external bec and it works like a champ.  Also you might have a motor issue, no need to get the ect mmp if you already have one just order a 1410 motor with the correct sized shaft and u should be ok.
fastgreen350 is offline  
Reply With Quote
Old 04-28-2012, 06:58 AM
  #2946
llkoolskillet
 
Join Date: May 2009
Location: Colorado Springs, CO
Posts: 1,008
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

No I havent geared down yet, im about to do so actually. I have 24,26,28,30 tooth pinions what should i out in there now? Im thinking about the 30t

This external BEC where can I find one? Hobby King?

SO yesterday, I ran it on 3s and less than 5min of runnin the red light stayed on and wouldnt move or anything. This morning I plugged a 2s battery in and everything works just fine, so I tried the same 3s and it works too. IDK im so confused as to what the issue is here. One day the esc works, then next its dies and doesnt do anything. Then its back to working again.
llkoolskillet is offline  
Reply With Quote
Old 04-28-2012, 11:12 AM
  #2947
gdiddy13
 
Join Date: Dec 2011
Location: , OH
Posts: 56
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

PROJECT XS!

Ok, I don't really have anything, but I'm looking for a project and I thought my XS might be fun. I have seen the upgraded motors, esc's etc. I have upgraded several parts. But what I haven't seen done is something like was done over on Ultimaterc, the Chimera project.

So I guess I'm looking for some ideas on what to do, to kinda make this thing a little different. I would like to be able to do a bit more of some crawling, though most would say then why buy the XS? But I'm just throwing out ideas. I really want to give this thing some more ground clearance. Does anyone know if any other Savage parts fit ? 

Let me know what you think
gdiddy13 is offline  
Reply With Quote
Old 04-28-2012, 12:51 PM
  #2948
iTz Nicholas72
 
Join Date: Feb 2010
Location: Asheville, NC
Posts: 122
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Quote:
ORIGINAL: Elcee

iTz Nicholas; I thought your build went quite well and being SS wouldn't be plagued by the ESC demons. What problems have you been experiencing?

Thanks to rologti my SS should be hitting the streets as soon as I can get my greasy mitts on some EC5 connectors. Can't for the live of me work out why Deans are more popular than EC5. Is it just familiarity?
The shimming that the diffs, suspension, and that I broke a shock eyelet within 5 minutes of getting it running.

It's not that it's a bad kit I just don't really like the Savage XS overall because it's size is somewhat awkward and I want something that can be bashed and raced.
iTz Nicholas72 is offline  
Reply With Quote
Old 04-28-2012, 12:52 PM
  #2949
iTz Nicholas72
 
Join Date: Feb 2010
Location: Asheville, NC
Posts: 122
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...







Here are some of the pictures. Got it nice and cleaned up.
iTz Nicholas72 is offline  
Reply With Quote
Old 04-28-2012, 01:01 PM
  #2950
fastgreen350
 
Join Date: Mar 2012
Location: La Barge, WY
Posts: 64
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Castle creations has the BEC on their site, u can find it on ebay also.  I finally got mine going again and wouldnt u know it I stripped the pinion gear on the motor, I had the motor in the correct spot on the clocking, but I guess a lack of lubrication ate it up.  So now I have cleaned out the transmission case of all the metal and plan on loading it up with a good bit of grease this time!  Hopefully this will end some of the major problems and I can get some serious bashing on. 
fastgreen350 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:46 PM.