Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 119 of 143 FirstFirst ... 1969109117118119120121129 ... LastLast
Results 2,951 to 2,975 of 3568

  1. #2951

    Join Date
    Sep 2010
    Location
    London, ON, CANADA
    Posts
    143
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Been running my xs since sept when they first came out, I ran about 20 packs through the stock esc but I was aware of the issues so i swapped it out for a mamba max not the pro version added my own fan and I have about 40 packs on that one never gets over 120 even on 3s. Kept the stock motor for about 30 packs then put in a 1410 3800 runs much cooler then stock never over 160 and I am running a 32t pinion on the 1410.

    Oh and I should say I bought both the mamba max and the 3800 used on rc tech. I think the newer castle esc's seem to be failing more then the older ones.
    Flux HP/Truggy Flux/Flux XS/Mini 8ight/Custom Mini Monster Baja

  2. #2952

    Join Date
    Apr 2012
    Location
    Crystal LakeIllinois
    Posts
    9
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Hey everyone! I'm new here, just read through this entire thread, what a journey lol. Anyway, I just got my XS a couple of weeks ago and wanted to chime in and say that I've run around 5 or 6 packs of 3s and the same amount of 2s through it and the ESC has been fine so far. It did randomly get "de-programmed" once, and we had to use the Castle Link to get it set up again, that was weird. 

    As far as bashing goes, like most people here have mentioned, it's a blast to bash, but I have noticed that I tend to break things 90% more often with the 3s than with the 2s. The 3s speed is addictive though  

    Anyway, I look forward to following this thread and upgrading the XS when the time comes. As of right now, I've replaced the stock servo with the Traxxas 2075 and the improvement was very noticeable and welcome. 

  3. #2953

    Join Date
    Apr 2012
    Location
    RDC, BRAZIL
    Posts
    33
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    TodayI tookasavagexs,was walkingin good...with the batteryI boughtthesedays,itis notloadedor anything.

    Out of nowherestopped walking,half a minutethen walkedagain,and stoppedagain.

    TheESCwill lightgreen and yellowcontinuously, whichcan be?Battery oresc?
    Notyettried callingagain, I thinkI shoulddo thatprocedurereset theesc?

    I tried toreset theesc, I playedfor a few secondsand stopped

  4. #2954

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: gdiddy13

    PROJECT XS!

    Ok, I don't really have anything, but I'm looking for a project and I thought my XS might be fun. I have seen the upgraded motors, esc's etc. I have upgraded several parts. But what I haven't seen done is something like was done over on Ultimaterc, the Chimera project.

    So I guess I'm looking for some ideas on what to do, to kinda make this thing a little different. I would like to be able to do a bit more of some crawling, though most would say then why buy the XS? But I'm just throwing out ideas. I really want to give this thing some more ground clearance. Does anyone know if any other Savage parts fit ?*

    Let me know what you think
    Savage parts will not fit the XS. If you want to crawl get a crawler or maybe a Summitt.

  5. #2955

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: iTz Nicholas72
    Here are some of the pictures from my for sale ad. Got it nice and cleaned up.
    Why are you selling your XS?

  6. #2956
    Community Moderators Foxy's Avatar
    Join Date
    Mar 2005
    Location
    Kingston UK, but living in Athens, GREECE
    Posts
    17,994
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: Thiagooo

    * Today*I took*a*savage*xs,*was walking*in good*...*with the battery*I bought*these*days,*itis not*loaded*or anything.

    Out of nowhere*stopped walking,*half a minute*then walked*again,*and stopped*again.

    The*ESC*will light*green and yellow*continuously, which*can be?*Battery or*esc?
    Not*yet*tried calling*again, I think*I should*do that*procedure*reset the*esc?

    I tried to*reset the*esc, I played*for a few seconds*and stopped
    That sounds like its thermalling (getting too hot). Does it work after it cools?
    Down with the crew known to pump up the bass...
    We rock the joint at a cool, steady pace.
    Foxy
    RCU Community Moderator

  7. #2957

    Join Date
    Feb 2010
    Location
    Asheville, NC
    Posts
    122
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    HPI Savage XS SS - Toro SC120 ESC, Toro 3200Kv 4P Motor, TowerPro MG995 Servo
    Losi XXX-SCT - Titan 12T (stock class racer)

  8. #2958

    Join Date
    Aug 2011
    Location
    Marysville, WA
    Posts
    31

    RE: Official HPI Savage Flux XS thread...

    Talked to a guy at Hobbytown USA. He said the new Vapor ESCs HPI is sending out are supposed to be improved. Not sure. Still have not received mine yet. Anybody blow a replacement Vapor? I was going to get the MMP but after reading a few entries here (it smoking up too) maybe I'll keep looking. Could the stock motor be the culprit here? Hobbyking ESC is thrown around a lot. Maybe that one? Thx

  9. #2959
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,585
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Yea I hope its better than the origional esc. I was recommended the castle 1410 (sct 3800kv system) i got the motor esc combo but its on backorder everywhere so i might just run that when i get it instead of the flux system.
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5

  10. #2960

    Join Date
    Mar 2012
    Location
    La Barge, WY
    Posts
    64
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    I have one of the new vapor pros and it was crap straight out of the box. I applied power to it and all the lights are dim on it and wouldn't power on, I called hpi and threw a fit and am supposed to be getting a q base esc from them now. Don't know what they have going on over there just plain sad. My mmp is holding up good in there now though and this truck is freekin awesome it's a tank beat the heck out of it and it takes it all.


  11. #2961

    Join Date
    Aug 2011
    Location
    Marysville, WA
    Posts
    31

    RE: Official HPI Savage Flux XS thread...

    Hmm too bad about the replacment esc. The XSis great and deserves so much better in the way of ESC. What is the Q-Base esc? Thx

  12. #2962

    Join Date
    Apr 2012
    Location
    RDC, BRAZIL
    Posts
    33
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: Foxy


    ORIGINAL: Thiagooo

    TodayI tookasavagexs,was walkingin good...with the batteryI boughtthesedays,itis notloadedor anything.

    Out of nowherestopped walking,half a minutethen walkedagain,and stoppedagain.

    TheESCwill lightgreen and yellowcontinuously, whichcan be?Battery oresc?
    Notyettried callingagain, I thinkI shoulddo thatprocedurereset theesc?

    I tried toreset theesc, I playedfor a few secondsand stopped
    That sounds like its thermalling (getting too hot). Does it work after it cools?
    problem solved. It was the battery.


    However playing today, the engine made ​​a noise but not running!

    I opened the engine and notice that the pinion is out of place. It should be up to 5mm, near the top.

    And this way:


    I managed to remove the pinion, and screw the pinion. However, how do I put back in position and prevent it from moving up or down? Locking thread? Thank you.







  13. #2963

    Join Date
    Mar 2012
    Location
    La Barge, WY
    Posts
    64
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    The q base is a hpi version of the mmp basically. Less tuning options on it though

    ORIGINAL: 8thScaleRoostertail

    Hmm too bad about the replacment esc. The XSis great and deserves so much better in the way of ESC. What is the Q-Base esc? Thx

  14. #2964
    Community Moderators Foxy's Avatar
    Join Date
    Mar 2005
    Location
    Kingston UK, but living in Athens, GREECE
    Posts
    17,994
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    ORIGINAL: fastgreen350

    The q base is a hpi version of the mmp basically. *Less tuning options on it though
    *
    ORIGINAL: 8thScaleRoostertail

    Hmm too bad about the replacment esc. The XS*is great and deserves so much better in the way of ESC. What is the Q-Base esc? Thx
    I don't believe it is a version of the MMP, I think it's an updated Mamba Max or Sidewinder Sv2. If it were an MMP it would not be having any issues whatsoever with the little flux. I have a full size savage flux (2350) which was perfectly fine pulling a truck more than double the weight on more than twice the power. If it is an MMP, it's a totally gimped one.
    Down with the crew known to pump up the bass...
    We rock the joint at a cool, steady pace.
    Foxy
    RCU Community Moderator

  15. #2965

    Join Date
    Mar 2012
    Location
    La Barge, WY
    Posts
    64
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Ok than if u have the 2350 than u should have a qbase esc. The qbase is from what research I have done a deprogrammed mmp in a hpi case. It is supposed to be a decent esc I thought way better than the vapor pro which is a sidewinder sv2 with a fan on it basically.
    ORIGINAL: Foxy

    ORIGINAL: fastgreen350

    The q base is a hpi version of the mmp basically. Less tuning options on it though

    ORIGINAL: 8thScaleRoostertail

    Hmm too bad about the replacment esc. The XSis great and deserves so much better in the way of ESC. What is the Q-Base esc? Thx
    I don't believe it is a version of the MMP, I think it's an updated Mamba Max or Sidewinder Sv2. If it were an MMP it would not be having any issues whatsoever with the little flux. I have a full size savage flux (2350) which was perfectly fine pulling a truck more than double the weight on more than twice the power. If it is an MMP, it's a totally gimped one.

  16. #2966

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: Thiagooo


    ORIGINAL: Foxy


    ORIGINAL: Thiagooo

    * Today*I took*a*savage*xs,*was walking*in good*...*with the battery*I bought*these*days,*itis not*loaded*or anything.

    Out of nowhere*stopped walking,*half a minute*then walked*again,*and stopped*again.

    The*ESC*will light*green and yellow*continuously, which*can be?*Battery or*esc?
    Not*yet*tried calling*again, I think*I should*do that*procedure*reset the*esc?

    I tried to*reset the*esc, I played*for a few seconds*and stopped
    That sounds like its thermalling (getting too hot). Does it work after it cools?
    problem solved. It was the battery.


    However playing today, the engine made ​​a noise but not running!

    I opened the engine and notice that the pinion is out of place. It should be up to 5mm, near the top.

    And this way:


    I managed to remove the pinion, and screw the pinion. However, how do I put back in position and prevent it from moving up or down? Locking thread? Thank you.






    Use blue loctite on the set screw on the pinion gear.

  17. #2967

    Join Date
    Apr 2012
    Location
    RDC, BRAZIL
    Posts
    33
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    OMG.I usedblue,but theallen wrenchandthatdustedcannottighten the screw,the screwisnowon the pinionbutthe pinionis outof the engine.

    ORIGINAL: t9dragon


    ORIGINAL: Thiagooo


    ORIGINAL: Foxy


    ORIGINAL: Thiagooo

    TodayI tookasavagexs,was walkingin good...with the batteryI boughtthesedays,itis notloadedor anything.

    Out of nowherestopped walking,half a minutethen walkedagain,and stoppedagain.

    TheESCwill lightgreen and yellowcontinuously, whichcan be?Battery oresc?
    Notyettried callingagain, I thinkI shoulddo thatprocedurereset theesc?

    I tried toreset theesc, I playedfor a few secondsand stopped
    That sounds like its thermalling (getting too hot). Does it work after it cools?
    problem solved. It was the battery.


    However playing today, the engine made ​​a noise but not running!

    I opened the engine and notice that the pinion is out of place. It should be up to 5mm, near the top.

    And this way:


    I managed to remove the pinion, and screw the pinion. However, how do I put back in position and prevent it from moving up or down? Locking thread? Thank you.






    Use blue loctite on the set screw on the pinion gear.

  18. #2968

    Join Date
    Dec 2011
    Location
    Helena, MT
    Posts
    8
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Got quiet after that post. Let me see if I can go over it all as I'm not sure where you are having issues.

    On the moter there is a round pin (shaft) that sticks out with flat area towards the end. The Pinion needs to be pulled up to this area where you can only see a couple milimeters of the shaft (someone better than me could give the exact amount). Position the gear so that the set screw will screw down on this flat area. Before you tighten the screw make sure you apply the blue loctice to it.

    Idid have an issue with the included allen wrench not being up to the task of removing or tightning that screw and I did end up purchasing some decent tools to work on it.

  19. #2969

    Join Date
    Mar 2012
    Location
    La Barge, WY
    Posts
    64
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Well ok guys I finally got my xs running well. So I decided to put my 3s in and see how fast it goes. I taped my GPS to the bottom the safest place I could think of, ran it down the hwy got to top speed and then it veers off course and hits a marker post on the side of the road. I thought it was all over after I saw it cart wheeling into the ditch, I drove down to it and it was fine I mean I nailed that post and it didnt break anything!!

    So back to topic my buddy was in the passenger seat and cut the gps off the bottom of the truck, and I asked him how fast it said, he laughed and said 66mph I said BS and took it and sure enough it was 66. I dont see how they are gettin 65 out of the box though, cause I stuck the factory tire back on and did it again and it only went 56mph. I was pretty happy to see it get that fast finally but it sure is a hand full without swaybars, wonder how much that will help.

    I will be running again here after I get my replacement parts ,that I broke launching it off of a 5 ft skate ramp at the park in town, and I will get my buddy to vid it that way I have some proof for yall. So thus far I dont believe I have seen anyone else on here get that fast yet so keep us posted on ur top speed runs!!

  20. #2970

    Join Date
    Apr 2012
    Location
    Springville, UT
    Posts
    6
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Hi.

    New to the forum, and new to the XS.  The fan on my ESC has died on my 2 week old XS while it was running today.  It didn't overheat(temps in the low 60's), so I didn't notice until it hit the lipo cutoff.  Anybody have a quick/easy solution, or a link to a replacement fan? 

    Has anyone run this setup in their XS?: http://www3.towerhobbies.com/cgi-bin...&I=LXBLBZ&P=ML


    FYI,
    I have the Traxxass shock eyelets coming, because I keep snapping the stock parts.  I also have CVD driveshafts and drive cups coming.  I've already noticed wear, and have had dogbones pop out 5-6 times.




  21. #2971

    Join Date
    Mar 2012
    Location
    La Barge, WY
    Posts
    64
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    U can put a much more racing fan on there.  U can carefully peel the sticker off the esc then open the case.   The fan just sits in there , push it out and install the new fan.  When u do this the case won't close all the way but when u put it back into the esc mount it holds it together really good.  Just make sure u keep the esc sticker somewhere safe, that way f it does eventually go out put the stock fan in and the sticker back on so they will warranty it.

  22. #2972

    Join Date
    Apr 2012
    Location
    Crystal LakeIllinois
    Posts
    9
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    Did a quick search in this thread but it came back with 0 results. 

    Is anyone running the XS with NIMH packs with any success? Mine will run for a few seconds and then it just stops running. Sometimes it will pick up again and run for a little while, but nothing more than 40 seconds or so. The manual says it's OK to use NiMH, but I've not had good results. 

  23. #2973

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: joseb

    Did a quick search in this thread but it came back with 0 results.*

    Is anyone running the XS with NIMH packs with any success? Mine will run for a few seconds and then it just stops running. Sometimes it will pick up again and run for a little while, but nothing more than 40 seconds or so. The manual says it's OK to use NiMH, but I've not had good results.*
    You will probably need to reset the ESC for NIMH batteries. What NIMH are you using?

  24. #2974

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...


    ORIGINAL: NewBlackDak

    Hi.

    New to the forum, and new to the XS.* The fan on my ESC has died on my 2 week old XS while it was running today.* It didn't overheat(temps in the low 60's), so I didn't notice until it hit the lipo cutoff.* Anybody have a quick/easy solution, or a link to a replacement fan?*

    Has anyone run this setup in their XS?: http://www3.towerhobbies.com/cgi-bin...&I=LXBLBZ&P=ML


    FYI,
    I have the Traxxass shock eyelets coming, because I keep snapping the stock parts.* I also have CVD driveshafts and drive cups coming.* I've already noticed wear, and have had dogbones pop out 5-6 times.



    For the issue of popping out axles you can stick a small peice of foam in the drive cup and that should elimnate the issue.

  25. #2975

    Join Date
    Apr 2012
    Location
    Crystal LakeIllinois
    Posts
    9
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Official HPI Savage Flux XS thread...

    I'm using 4600mah 6-cell Venom NiMH flat pack for now. In the Castle Link software it suggests setting the cut-off to 4 V for a 6-cell pack, is this a good setting, or do you recommend something different?


    **Edit** I changed the cut-off to 4 V as per the recommendations in the software and I see no change in behavior. With a full charged 6-cell pack, I am getting just a clicking noise and no movement at all. This is what happened before, except previously it would run for a few seconds and then do this for a few seconds.

    [youtube]http://www.youtube.com/watch?v=TIxziNZHSlY&hd=1[/youtube]
    ORIGINAL: t9dragon


    ORIGINAL: joseb

    Did a quick search in this thread but it came back with 0 results.
    Is anyone running the XS with NIMH packs with any success? Mine will run for a few seconds and then it just stops running. Sometimes it will pick up again and run for a little while, but nothing more than 40 seconds or so. The manual says it's OK to use NiMH, but I've not had good results.
    You will probably need to reset the ESC for NIMH batteries. What NIMH are you using?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 07:59 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.