1/16th, 1/18th, Mini & Micro RC Cars Discuss 1/16, 1/18, Minis, Micros & any RC Cars smaller than 1/10th scale in this forum

Official HPI Savage Flux XS thread...

Reply
Old 05-30-2012, 10:10 AM
  #3026
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Hope they arrive OK...

Hope you could enjoy your XS soon....

BTW:

For backup I bought almost everything at HobbyKing....until now, no problems with their products...and most of the times...the buckup ends like defenitive...

For what I have read...(please don't kill me for this, I have just read it in several forums)...motors..chose USA brands...ESC..choose china brands...until now...no problem with my "made in China" Turnigy ESC (150Amps, working on 6S on a Hyper ST brushless converted)

I love my Mamba Max Pro...but for the price I could have 3 of the others....
rologti is offline  
Reply With Quote
Old 05-30-2012, 10:36 AM
  #3027
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

well my SV2 and vapor pro are under warranty for a year. if a year from the purchase date of my flux, if the vapor pro still sucks (god that would just be sad) and they dont cover it after a year, i will just want my money back and buy off brand
cumminspower5.9 is offline  
Reply With Quote
Old 05-31-2012, 02:43 PM
  #3028
Thiagooo
 
Join Date: Apr 2012
Location: RDC, BRAZIL
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

is this normal? this clearance wheels? It has something to do to improve this? Thank you.
Thiagooo is offline  
Reply With Quote
Old 06-01-2012, 03:56 AM
  #3029
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Well, finally got my Vapor Pro yesterday. Put it in and put the truck back together. the mounting is different than the first, so i just used double back sticky tape andscrewed down the fan protector to keep it on the mount.All works fine for now. I'll probably get more running in this weekend. My passenger rear wheel has some serious toe/camber angle on it and it wobbles like a mother, so im going to see if i can shim it to straighten it out.
cumminspower5.9 is offline  
Reply With Quote
Old 06-04-2012, 04:00 AM
  #3030
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Well the replacement esc has been a success so far. put about 4 runs on it so far and no issues. i would have put on more runs but it was raining all day sunday and i dont run my rc's in water at all so i lost some runs there. but im glad to be running the flux again
cumminspower5.9 is offline  
Reply With Quote
Old 06-07-2012, 03:57 AM
  #3031
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Well I had a package at the house yesterday and I opened it up an guess what? another flux Vapor pro esc! thats two that HPI sent me! Thats what happens when people dont talk within the company lol. i think im just going to save it for a backup or use it on another project. But its crazy, they sent me two!!
cumminspower5.9 is offline  
Reply With Quote
Old 06-07-2012, 07:30 AM
  #3032
t9dragon
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: cumminspower5.9

Well I had a package at the house yesterday and I opened it up an guess what? another flux Vapor pro esc! thats two that HPI sent me! Thats what happens when people dont talk within the company lol. i think im just going to save it for a backup or use it on another project. But its crazy, they sent me two!!
Nice...
t9dragon is offline  
Reply With Quote
Old 06-07-2012, 04:08 PM
  #3033
fastgreen350
 
Join Date: Mar 2012
Location: La Barge, WY
Posts: 64
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Funny they sent me two Q base esc's also, just spun it on ebay though, figured as long as I had to wait for a replacement I might as well get something out of it.  Just goes to show how good HPI customer service is, they feel soooo bad they give ya two,lol
fastgreen350 is offline  
Reply With Quote
Old 06-08-2012, 03:52 AM
  #3034
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Lol either that or they screwed up and didn't mark that one was already shipped to us. Oh well, saved us money and time for a replacement when the replacement one goes.
cumminspower5.9 is offline  
Reply With Quote
Old 06-10-2012, 07:03 PM
  #3035
CarGuy7a
 
Join Date: Nov 2008
Location: , KY
Posts: 496
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Hey fellas. I just finished my XS SS build this weekend and test drove it today and I need a little help. I put a Castle Sidewinder 4600 combo in it and I'm having some major heat issues. This is the old SW 2 pole 4600 system. I've never overheated the motor so I know that's not an issue. I'm running the 60T spur with the 24 tooth pinion (the lowest gearing setup possible provided with the kit) and my motor is hitting 180°F in 5 minutes run time on 2s lipo in short grass. Are there any companies out there that make a motor mount with slots rather than just holes in it so you can run whatever pinion you want. I need to gear this thing way down in the 15 or 16 tooth pinion range to keep my temps in check. I also have a castle motor fan that came with my SCT Race Pro system I bought for another build that I'm not using but I'd like to get the temps down further before I go putting on fans. Any help is appreciated.

Here's my pics. And yes I know my right side tires are backwards. I didn't put them on right after I taped the tires and started gluing. It was late when I did it


CarGuy7a is offline  
Reply With Quote
Old 06-11-2012, 08:18 AM
  #3036
t9dragon
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: CarGuy7a

Hey fellas. I just finished my XS SS build this weekend and test drove it today and I need a little help. I put a Castle Sidewinder 4600 combo in it and I'm having some major heat issues. This is the old SW 2 pole 4600 system. I've never overheated the motor so I know that's not an issue. I'm running the 60T spur with the 24 tooth pinion (the lowest gearing setup possible provided with the kit) and my motor is hitting 180°F in 5 minutes run time on 2s lipo in short grass. Are there any companies out there that make a motor mount with slots rather than just holes in it so you can run whatever pinion you want. I need to gear this thing way down in the 15 or 16 tooth pinion range to keep my temps in check. I also have a castle motor fan that came with my SCT Race Pro system I bought for another build that I'm not using but I'd like to get the temps down further before I go putting on fans. Any help is appreciated.

Here's my pics. And yes I know my right side tires are backwards. I didn't put them on right after I taped the tires and started gluing. It was late when I did it


HPI makes an aftermarket motor mount that allows you to use different gearing.
t9dragon is offline  
Reply With Quote
Old 06-11-2012, 11:20 AM
  #3037
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Has anyone experimented with shimming or modifying the rear upright to fix the camber/toe issue? I've shimmed the a-arms to remove the slop but the uprights still have a lot of play in them.
cumminspower5.9 is offline  
Reply With Quote
Old 06-11-2012, 11:44 AM
  #3038
Thiagooo
 
Join Date: Apr 2012
Location: RDC, BRAZIL
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Sometimes when I'm running with my savage, she stops suddenly.
This occurs after about 15 or 20 minutes or more. It depends. I'll look the same esc and all lights blinking
What can this be? what's the problem?
[youtube]www.youtube.com/watch?v=4k5RKOeljOY[/youtube]
[youtube]4k5RKOeljOY[/youtube]

OMG, this forum is crazy. I can not put the video

http://www.youtube.com/watch?v=4k5RKOeljOY

Thiagooo is offline  
Reply With Quote
Old 06-11-2012, 12:29 PM
  #3039
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: CarGuy7a

Hey fellas. I just finished my XS SS build this weekend and test drove it today and I need a little help. I put a Castle Sidewinder 4600 combo in it and I'm having some major heat issues. This is the old SW 2 pole 4600 system. I've never overheated the motor so I know that's not an issue. I'm running the 60T spur with the 24 tooth pinion (the lowest gearing setup possible provided with the kit) and my motor is hitting 180°F in 5 minutes run time on 2s lipo in short grass. Are there any companies out there that make a motor mount with slots rather than just holes in it so you can run whatever pinion you want. I need to gear this thing way down in the 15 or 16 tooth pinion range to keep my temps in check. I also have a castle motor fan that came with my SCT Race Pro system I bought for another build that I'm not using but I'd like to get the temps down further before I go putting on fans. Any help is appreciated.

Here's my pics. And yes I know my right side tires are backwards. I didn't put them on right after I taped the tires and started gluing. It was late when I did it


HR makes a motor mount....

http://www.ebay.com/itm/HPI-Mini-Sav...item5d33df6638

It also cames with some heat deflectors (¿? is that written in the correct way?)
rologti is offline  
Reply With Quote
Old 06-11-2012, 09:24 PM
  #3040
CarGuy7a
 
Join Date: Nov 2008
Location: , KY
Posts: 496
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

I've seen the Hot Racing motor mount but it looks like the same configuration as the stock plate only with added heat sinks. But does it allow you run a smaller pinion than a 24 tooth?

T9Dragon. Do you have a link to the one made by HPI I can't seem to find it anywhere. I looked on their site but the only optional parts it shows for it is a 4300kv motor, wheelie bar, and a 2.4ghz controller, no motor mount. If all else fails I could just take the pencil grinder to the stock one and slot out one side so I can run absolutely any pinion I want.
CarGuy7a is offline  
Reply With Quote
Old 06-13-2012, 04:54 AM
  #3041
Thiagooo
 
Join Date: Apr 2012
Location: RDC, BRAZIL
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Actually the ESC cooler is not working anymore. Had not noticed that. 

The wire used for it is the last channel on the receiver? It may be a problem in welding? 
it is possible to open this esc and change the cooler?

Or do I try to do an air duct with a hose? hahaha
Thiagooo is offline  
Reply With Quote
Old 06-13-2012, 06:01 AM
  #3042
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: Thiagooo

Actually the ESC cooler is not working anymore. Had not noticed that.

The wire used for it is the last channel on the receiver? It may be a problem in welding?
it is possible to open this esc and change the cooler?

Or do I try to do an air duct with a hose? hahaha
LOL Ram Air! The wires on the cooling fan to the connector are pretty flimsy. Im not sure how you would be able to fabricate a tube to cool the esc efficiently. you would have to be hauling to keep air flow moving to it.
cumminspower5.9 is offline  
Reply With Quote
Old 06-13-2012, 08:01 AM
  #3043
rologti
 
Join Date: Oct 2007
Location: Santiago, CHILE
Posts: 139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: cumminspower5.9


Quote:
ORIGINAL: Thiagooo

Actually the ESC cooler is not working anymore. Had not noticed that.

The wire used for it is the last channel on the receiver? It may be a problem in welding?
it is possible to open this esc and change the cooler?

Or do I try to do an air duct with a hose? hahaha
LOL Ram Air! The wires on the cooling fan to the connector are pretty flimsy. Im not sure how you would be able to fabricate a tube to cool the esc efficiently. you would have to be hauling to keep air flow moving to it.
HAHAHAHA...ram air...

I think you have the mamba max pro....or the vapor??...I'm almost sure that you can change the cooling fan...

http://www.ebay.com/itm/Castle-Creat...item53ed621c46

Cheers
rologti is offline  
Reply With Quote
Old 06-13-2012, 11:02 AM
  #3044
Thiagooo
 
Join Date: Apr 2012
Location: RDC, BRAZIL
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

Quote:
ORIGINAL: rologti


Quote:
ORIGINAL: cumminspower5.9


Quote:
ORIGINAL: Thiagooo

Actually the ESC cooler is not working anymore. Had not noticed that.

The wire used for it is the last channel on the receiver? It may be a problem in welding?
it is possible to open this esc and change the cooler?

Or do I try to do an air duct with a hose? hahaha
LOL Ram Air! The wires on the cooling fan to the connector are pretty flimsy. Im not sure how you would be able to fabricate a tube to cool the esc efficiently. you would have to be hauling to keep air flow moving to it.
HAHAHAHA...ram air...

I think you have the mamba max pro....or the vapor??...I'm almost sure that you can change the cooling fan...

http://www.ebay.com/itm/Castle-Creat...item53ed621c46

Cheers
I managed to open it. I removed the fan. My esc is vaporpro. This cooler fits? is 25x25x7?

Thiagooo is offline  
Reply With Quote
Old 06-14-2012, 05:18 PM
  #3045
NewBlackDak
 
Join Date: Apr 2012
Location: Springville, UT
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

It's 25x25x7. The stock fan doesn't have the normal tiny fan connector. It has a standard servo lead. Look on pg 118.

Does anybody have a fix for the slipper nut backing off? No amount of blue locktite or losilock will keep mine in place. I'm afraid to put the red on it. Is there is a lock nut that can be used?
NewBlackDak is offline  
Reply With Quote
Old 06-15-2012, 03:05 AM
  #3046
Thiagooo
 
Join Date: Apr 2012
Location: RDC, BRAZIL
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: NewBlackDak

It's 25x25x7. The stock fan doesn't have the normal tiny fan connector. It has a standard servo lead. Look on pg 118.

Does anybody have a fix for the slipper nut backing off? No amount of blue locktite or losilock will keep mine in place. I'm afraid to put the red on it. Is there is a lock nut that can be used?
Thanks,
already bought one of these, was the only one I found in my country.
And I opened the esc, I forgot that I'd lose the warranty.

Thiagooo is offline  
Reply With Quote
Old 06-15-2012, 04:13 AM
  #3047
cumminspower5.9
 
cumminspower5.9's Avatar
 
Join Date: Aug 2011
Location: horseheads, NY
Posts: 2,643
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: NewBlackDak

It's 25x25x7. The stock fan doesn't have the normal tiny fan connector. It has a standard servo lead. Look on pg 118.

Does anybody have a fix for the slipper nut backing off? No amount of blue locktite or losilock will keep mine in place. I'm afraid to put the red on it. Is there is a lock nut that can be used?
There is no reason it should be coming off even with loctite on the threads. Check your threads for cross threading and dirt/grime. If you can find the right size one, I would use a lock nut and possibly a lock washer.
cumminspower5.9 is offline  
Reply With Quote
Old 06-17-2012, 04:44 PM
  #3048
NewBlackDak
 
Join Date: Apr 2012
Location: Springville, UT
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: cumminspower5.9


Quote:
ORIGINAL: NewBlackDak

It's 25x25x7. The stock fan doesn't have the normal tiny fan connector. It has a standard servo lead. Look on pg 118.

Does anybody have a fix for the slipper nut backing off? No amount of blue locktite or losilock will keep mine in place. I'm afraid to put the red on it. Is there is a lock nut that can be used?
There is no reason it should be coming off even with loctite on the threads. Check your threads for cross threading and dirt/grime. If you can find the right size one, I would use a lock nut and possibly a lock washer.
I know it shouldn't, but it does it about half way through the second pack every time. Right now it has new clutch pads, new drive cups and new slipper nut/spring.

NewBlackDak is offline  
Reply With Quote
Old 06-18-2012, 12:05 PM
  #3049
echthelion
 
echthelion's Avatar
 
Join Date: Feb 2011
Location: ontario, OR
Posts: 474
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...

looking at geting a new servo for my savage xs im torn betweentwo. the hitec 645mg or the savox 0253mg

http://www.ebay.com/itm/190689525390...84.m1423.l2649 savox


http://www.ebay.com/itm/200777029355...84.m1423.l2649 hitec


looking for some friendly advice
echthelion is offline  
Reply With Quote
Old 06-20-2012, 08:16 AM
  #3050
gdiddy13
 
Join Date: Dec 2011
Location: , OH
Posts: 56
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Official HPI Savage Flux XS thread...


Quote:
ORIGINAL: cumminspower5.9


Quote:
ORIGINAL: rc theman

Does anyone else have bad steering slop? Ive tryed almost everything but it's still there
In the end, just glue the damn things lol

When you say glue it, where exactly do you mean. Probablyl dumb question
gdiddy13 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:28 PM.