Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 141 of 143 FirstFirst ... 4191131139140141142143 LastLast
Results 3,501 to 3,525 of 3568

  1. #3501

    Join Date
    Mar 2004
    Location
    Bethel, MN
    Posts
    207
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by suburban_hooligan View Post
    what battery are you running? my SS did that on a 3200mah 20c. when i tried a 3300mah 25c the almost went away. and when i put a 6200mah 50c in it, it solved the problem
    Where did you buy the 6200 50C? Did it fit in the XS alright?

  2. #3502
    suburban_hooligan's Avatar
    Join Date
    Feb 2010
    Location
    So Cal, CA
    Posts
    930
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by jsflagstad View Post
    Good to know, Thanks. Good lord, with the punch this thing has on 20c it should be unreal with 35c+ packs!
    ever seen a truck do a burnout and a wheelie at the same time? that's what mine did when i put the 50c pack in it. blew my mind.
    ↑↑↓↓←→←→BA

  3. #3503
    suburban_hooligan's Avatar
    Join Date
    Feb 2010
    Location
    So Cal, CA
    Posts
    930
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by jsflagstad View Post
    Where did you buy the 6200 50C? Did it fit in the XS alright?
    http://www3.towerhobbies.com/cgi-bin/wti0001p?&I=LXASTZ
    it fits great. i did have to test it a few times to learn how to run the battery wires out. but once i had that figured out, it goes in and out easily.
    ↑↑↓↓←→←→BA

  4. #3504
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,558
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by jsflagstad View Post
    Good to know, Thanks. Good lord, with the punch this thing has on 20c it should be unreal with 35c+ packs!
    I was able to rip standing backflips on a 25c lipo
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5

  5. #3505
    pythonfan's Avatar
    Join Date
    Nov 2004
    Location
    inverness, FL
    Posts
    5,029
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by suburban_hooligan View Post
    http://www3.towerhobbies.com/cgi-bin/wti0001p?&I=LXASTZ
    it fits great. i did have to test it a few times to learn how to run the battery wires out. but once i had that figured out, it goes in and out easily.
    In case anyone wants a hobbyking version of the above here you go(Also even higher C): http://www.hobbyking.com/hobbyking/s...dProduct=33216

    To fit the above in the savage you would have to make or buy low profile plugs (Credit T9):



    Quote Originally Posted by cumminspower5.9 View Post
    I was able to rip standing backflips on a 25c lipo
    This but with a 30c pack/s.
    Last edited by pythonfan; 02-25-2014 at 02:48 AM.
    pt.1 http://uk.youtube.com/watch?v=Rids9ycMW2k
    pt.2 http://uk.youtube.com/watch?v=vCTWvrJc-RE

  6. #3506
    pythonfan's Avatar
    Join Date
    Nov 2004
    Location
    inverness, FL
    Posts
    5,029
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    A few new pics after 5 battery packs, thing is tougher then people made it out to be. I lost front wheel drive, set screw came out or is loose haven't looked yet, and a wire on the motor became un-solderd but i did the soldering so my own fault for that.

    These are the wheels and tires from a the losi 1/18th rock crawler, and surprisingly hook up amazing in soft sugar sand and leaves. They might be small and cookie cutter'ish but my goodness does it handle now. Stock tires it couldn't track straight to save it's life.


    pt.1 http://uk.youtube.com/watch?v=Rids9ycMW2k
    pt.2 http://uk.youtube.com/watch?v=vCTWvrJc-RE

  7. #3507
    mudfrog's Avatar
    Join Date
    Nov 2011
    Location
    Troutville, VA
    Posts
    54
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by jason1980 View Post
    I am running alu knuckles. less free play. How did you attach the fan to the motor? got any pictures to show how you did it?
    The Heatsink wraps around the motor to hold it in place. I picked the fan and heatsink up off of ebay for like $18 or so.
    Savage X - Losi 454
    Savage XS Flux RTR
    Axial AX10 Ridgecrest

  8. #3508
    mudfrog's Avatar
    Join Date
    Nov 2011
    Location
    Troutville, VA
    Posts
    54
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Forgot to post up on the aluminum knuckles after I installed them.

    Savage X - Losi 454
    Savage XS Flux RTR
    Axial AX10 Ridgecrest

  9. #3509
    mudfrog's Avatar
    Join Date
    Nov 2011
    Location
    Troutville, VA
    Posts
    54
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by cumminspower5.9 View Post
    The C-rating on the pack is what you need to be concerned about. With this truck, 30c is lowest. It is a light truck, but 25c lipos are for 2wd Traxxas vehicles which are really light and don't draw a lot of amps. If the battery cannot supply the amps the motor/esc are drawing, it will stutter.
    I run 25C packs and it has tons of punch. It will do a standing back flip no problem.
    Savage X - Losi 454
    Savage XS Flux RTR
    Axial AX10 Ridgecrest

  10. #3510
    Just finally got my Savage Flux back from HPI after just purchasing it new and having it delivered with issues...... At first glance its everything (good) they say about it.... I was very disappointed in the new "Futaba" transmitter the TF-11, and when I unpacked the item the first time, it ran for a few seconds the stopped. I checked everything over and decided to call HPI, i was hung up on by the first person who says they are normally in the air department and not the surface department, then the next guy (very nice) went through the hole thing over the phone and told me to send it in. I did, and they fixed it and sent it back. The repair ticket says the wire was off from the motor to the ESC(absolutely not) and that was the issue. Either way i have the truck back and its working now so thats a plus. The radio sucks and the shocks arent the "Golden" ive heard from URC at all, but over all for the $200 RTR oh wait it was $300 and i had to purchase batteries.... Fun truck but after all the issues not sure i made the right choice.. My issues I'm sure arent the norm and probably just represent my experience and nothing more but, I'm not a fan of this product so far.... I havent had an issue with my batteries not fitting and I havent tried a 3s due to the breaking parts issue I hear so much about but I think its fast enough the way it is. Here's hoping my ESC dont burn like i have heard some doing! Just my opinion and you should form yours from the true experts but just had to post something.

  11. #3511
    new to electric...does the robinson slipper clutch fit the savage flux xs..or a higher grade of transmission gear available for xs..thanks for any help

  12. #3512
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,558
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    In my opinion after having the truck and running all stock with 2s and 3s lipo, anything aftermarket isn't necessary. HPI has always hade bulletproof transmissions, and this is one of them. What were your goals as far as an aftermarket slipper?
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5

  13. #3513
    Hi , i just received today my savage , and i only have two 3s lipos to use during 10 days (in a week or so i will get 2 x 2s 4500 mah 35c).

    I have read in the hpi web that for 3s you have to change the spur gear and pinion , and looking in the pdf manual it seems , at least for me (i am new in rc cars),that is a bit difficult to change them. Perhaps once i have the car in the table is easier to see what to do.

    But my doubt is if for a week or 10 days of 3s use only it is worth to change the pinion and spur knowing that then i will use 2s lipos.

    And as i never drive a rc car , i will not speed up too much xd.

  14. #3514
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,558
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    I never changed any gears in my XS, whether I was running a 2s or a 3s lipo. The gear changing is o keep temps down on the motor. If you run full throttle for a whole pack or even two packs, you might have heat trouble. 3s lipo is insane power, so I doubt you will need to go full throttle.
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5

  15. #3515
    Quote Originally Posted by cumminspower5.9 View Post
    I never changed any gears in my XS, whether I was running a 2s or a 3s lipo. The gear changing is o keep temps down on the motor. If you run full throttle for a whole pack or even two packs, you might have heat trouble. 3s lipo is insane power, so I doubt you will need to go full throttle.
    Thanks , i have received the car 2 h ago. I am charging a 3s 3500 mah battery with my imax b3 (i have to buy a b6 , this ones charges a battery in 6 or 10 hours as it doesn't let you to charge at more than 800 mA) , and then i will setup all things and learn to drive it xd

  16. #3516

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    It looks like we might be able to finally go XS bashing.... But with only of our XS's still having tranny issues with the other one.... To bad I can't find a complete tranny for sale.

  17. #3517
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,558
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Sometimes I kind of miss my XS. The blistering top speed and neck snapping backflips. But on the other hand, I'm glad I sold it to get my Ofna. More solid platform. I still stop by to help others lol
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5

  18. #3518

    Join Date
    Mar 2004
    Location
    Bethel, MN
    Posts
    207
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Hello guys, I'm back again. See my video in post 3494 with my XS doing the "Jerky" thing when starting out. We finally got some nice weather here and I got out to do some bashing. I still have the same batteries 2s and 3s 4000 mah 20c's. A few had thought that the fact that the 20c batteries we my issue but it would hurt to run with them and just deal with the jerky starts until I get some new batteries. Today it was still jerky and then it would just go dead after maybe 5 mins of running and the pack still had plenty of charge in it. If I unhooked the battery and hooked it back up, it would run for bit longer and then go dead again. Any ideas? Is my ESC going? Or, is it just that these 20c batteries just not right? On a side note, I saw a Savage XS package deal with these batteries and that's why I chose them. I don't remember the truck doing this jerky deal on the first few packs, and it certainly didn't go dead when the pack was still fairly charged.

    Thanks,

    JSF

  19. #3519

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Quote Originally Posted by jsflagstad View Post
    Hello guys, I'm back again. See my video in post 3494 with my XS doing the "Jerky" thing when starting out. We finally got some nice weather here and I got out to do some bashing. I still have the same batteries 2s and 3s 4000 mah 20c's. A few had thought that the fact that the 20c batteries we my issue but it would hurt to run with them and just deal with the jerky starts until I get some new batteries. Today it was still jerky and then it would just go dead after maybe 5 mins of running and the pack still had plenty of charge in it. If I unhooked the battery and hooked it back up, it would run for bit longer and then go dead again. Any ideas? Is my ESC going? Or, is it just that these 20c batteries just not right? On a side note, I saw a Savage XS package deal with these batteries and that's why I chose them. I don't remember the truck doing this jerky deal on the first few packs, and it certainly didn't go dead when the pack was still fairly charged.

    Thanks,

    JSF
    What brand of batteries? Do you balance them?

  20. #3520

    Join Date
    Mar 2004
    Location
    Bethel, MN
    Posts
    207
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Both are Venom batteries and Yes I always balance. Is there any place to buy batteries (affordable) besides hobby king? Love their site but I'm WAY tired of wrestling with their shopping cart / check out system.

  21. #3521

    Join Date
    Apr 2004
    Location
    PDX, OR
    Posts
    7,866
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    I buy my lipos from a LHS... I think it is your lipos, 20c just isn't cutting it..

  22. #3522

    Join Date
    Mar 2004
    Location
    Bethel, MN
    Posts
    207
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    I went to my LHS and bought an $80 2s 30c 5200 mah pack and gave it a try. It made it better, but it still does the hesitation and it gets worse as the battery is drawn down again. I think I'll give all the onboard connections a once over and see if that helps. Maybe even apply a little dielectric grease?

    JSF

  23. #3523
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,558
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    I would hook the ESC up to the computer if you have the adapter, and check all the setting or do an update on it.
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5

  24. #3524

    Join Date
    Mar 2004
    Location
    Bethel, MN
    Posts
    207
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    I just ordered one, it'll be here tomorrow. Where is the best place to get the latest file update?

  25. #3525
    cumminspower5.9's Avatar
    Join Date
    Aug 2011
    Location
    horseheads, NY
    Posts
    2,558
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    You can go to the Castle website and get the free download for the program. When you plug in the esc to the computer, it might mention there is an update.
    -Aerodynamics and turbos are for people who can't build motors.

    Ofna LX2e-4s
    Axial SCX10 Jeep
    T-Maxx 2.5


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:27 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.