Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1
    Ttam Says Blarg's Avatar
    Join Date
    Feb 2008
    Location
    Lake Arrowhead, CA
    Posts
    5,811
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Super Brain 960

    I seem to have a problem with this charger false peaking. I dont know what it is but it is usually done charging my dtx 4200 mah in about 20 mins...... and my traxxas power series 1's are done in about 10. The only thing I did was take the tamiya connector off and put on deans
    "Insanity is doing the same thing, over and over again, but expecting different results."
    Slash 1/16 - DB-01 - TT-01 - RC18B and a Super Cub!

  2. #2

    Join Date
    Feb 2007
    Location
    Owensboro, KY
    Posts
    5,527
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Super Brain 960

    I have a couple of those, but dont use them much anymore since I have a 977 charger.
    They do like to false peak alot. The charger when it gets hot it will automatically shut off.
    Does your make wierd noises when you charge that pack? 3700mah is all that charger will handle.
    My 977 I've been having little issue with these past 6 months. since it cools iteself to charge my 5000 packs.
    Losi DT/Losi XX-4/Tamiya TA05/SC10/Tamiya 501x \"WCE\"/Yokomo YR4 M2/F-150/Blackfoot Xtreme

  3. #3
    mechanizeddeath's Avatar
    Join Date
    Nov 2007
    Location
    Grand Rapids, MI
    Posts
    3,791
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Super Brain 960

    Old thread, but I thought I'd mention that mine also false peaks on occasion and makes odd noises when charging, especially with high amp rates and/or large capacity batteries.

    Still my favorite charger though, and if it false peaks I just wait a minute or two and try again. It usually works fine the 2nd time.
    Brat (RIP) | Mini-Z MR-015 | TB-02 | DF-03 | Grasshopper | Turbo Vee | M-04M | XMODS | Levant | Lunch Box | Pede | Blade MCX


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:54 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.