Airtronics Support Forum Ask any questions you may have about Airtronics radios and product here and get answers direct from the Airtronics Team.

SD-10G Service Bulletin

Reply
Old 11-17-2010, 04:39 PM
  #1
MikeGreenshields
Thread Starter
 
Join Date: Mar 2005
Location: Fountain Valley, CA
Posts: 380
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default SD-10G Service Bulletin

SD-10G Owners

We have available an update to the RF board.

For details and directions on how to get this free update, please follow the link below
http://www.airtronics.net/SD10GSB-11-17-2010

MikeGreenshields is offline  
Reply With Quote
Old 11-18-2010, 11:21 PM
  #2
Rod_Hart
 
Join Date: Sep 2003
Location: colorado springs, CO
Posts: 127
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Mike,


My SD-10g is one of the transmitters on the list. I will be sending it back soon. Are there any other updates that I should have done while the radio if back for service. I have had it since last fall.

Thanks

Rod
Rod_Hart is online now  
Reply With Quote
Old 11-19-2010, 01:40 PM
  #3
MikeGreenshields
Thread Starter
 
Join Date: Mar 2005
Location: Fountain Valley, CA
Posts: 380
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Our service tech will check the radio for proper operation while he has it. If you have any concerns, make a note of them when you send in the radio.

Mike
MikeGreenshields is offline  
Reply With Quote
Old 11-22-2010, 07:21 AM
  #4
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Thanks for the update.
My number is 3905022012.
Does any body know why I cant program my Blade-400 with this SD-10G? I spent hours trying to set this model up and have had no luck. I once I set the swash up the elevator is reverse.
I'de hate to think I just trashed the DX-6 and have to TX for my Blade.
cap21r is offline  
Reply With Quote
Old 11-22-2010, 01:12 PM
  #5
MikeGreenshields
Thread Starter
 
Join Date: Mar 2005
Location: Fountain Valley, CA
Posts: 380
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

I'll have one of the heli team guys get you answers on your heli setup ASAP.
MikeGreenshields is offline  
Reply With Quote
Old 11-22-2010, 01:16 PM
  #6
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Just reverse the elevator function in the SWH Menu.  Select SWH and reverse the sign of the EL Value in the menu.  For example if the value is now 50 make it a -50.

Terry
TMooreATX is offline  
Reply With Quote
Old 11-22-2010, 04:55 PM
  #7
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Thanks
Is there any other setting to change or add out side of basic?
cap21r is offline  
Reply With Quote
Old 11-22-2010, 05:43 PM
  #8
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

How can I set up trainer mode and stunt mode?
It seems un stable as I just had it up. The tail seems to be hunting and supper touchy compared to the way I had it set up on the DX6.
The Blade-400 has a remote gain but I seen no changes when I + and - the program.

I need a setup for dummy book.
cap21r is offline  
Reply With Quote
Old 11-22-2010, 06:16 PM
  #9
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

How can I set up trainer mode and stunt mode?
It seems un stable as I just had it up. The tail seems to be hunting and supper touchy compared to the way I had it set up on the DX6.
The Blade-400 has a remote gain but I seen no changes when I + and - the program.

I need a setup for dummy book.
cap21r is offline  
Reply With Quote
Old 11-22-2010, 11:41 PM
  #10
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

What channel is the gyro gain plugged into?
TMooreATX is offline  
Reply With Quote
Old 11-23-2010, 12:38 AM
  #11
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

The gyro is plugged into#5.
the guess I'm missing a step in setting up.
I reduced the EPA as my controls had started to bottom out. I reduced elevator,ailerons and Pitch so one servo wouldn't over take the other. What should be a safe travel setting as I'm not a 3-D yet. I'm limited. I was thing about -2 degrees and+9 for pitch. Your thoughts will be helpful.
cap21r is offline  
Reply With Quote
Old 11-23-2010, 05:51 PM
  #12
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Set the machine up for -10 to +10 with ZERO at the half stick point.  Adust the gyro gain so that the tail doesn't hunt or pulse, a sure sign of too much gain.  Watch these videos on the radio for more information:   http://www.helifreak.com/showthread.php?t=167016
TMooreATX is offline  
Reply With Quote
Old 11-23-2010, 07:34 PM
  #13
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Thanks,
I'm ready to trash this thing.
I just can't get this tunned in.
I may need to repair the DX6 and use it.
I cant open the vids on the link you sent me.
cap21r is offline  
Reply With Quote
Old 11-24-2010, 01:54 AM
  #14
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Don't give up, the radio isn't the issue, it's the setup.  Get the setup right and the radio will amaze you.  The videos are standard Windows Media player videos, you may have to update Media Player but that should be no biggie.

Terry





TMooreATX is offline  
Reply With Quote
Old 11-24-2010, 10:23 AM
  #15
MikeRuth
 
MikeRuth's Avatar
 
Join Date: Mar 2006
Location: Tarzana, CA
Posts: 410
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Never give up, I mentioned earlier on RCG that I to had some difficulty with it at first. Ultimately I took my time, read the manual, a couple times and then started working with it. Now that I am familiar with the flow of the system and menus it is a breeze and as mentioned before an awsome radio.

I'm so glad I choose this over the other manufactures out there.

MIke R
MikeRuth is offline  
Reply With Quote
Old 11-24-2010, 10:04 PM
  #16
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

All seems OK just looking at the movement but when Im running near 50% and give fwd stick she jumps up as if the pitch was mixed with the elevator.
I'm long out of ideas and all out of new parts.
I did look through the HF vids and seen a lot of info but nothing on setting up the swash plate for as starting points
I'm a show man not a tell me.
My swash plate is set Elev -100 Ail 50 and Pitch 50.
when I look the the DX-6 setup its like 75 65 65?
agian thanks for your time in helping me.
cap21r is offline  
Reply With Quote
Old 11-25-2010, 10:30 AM
  #17
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Anything in the DX 6 won't apply to the SD10G. As you can imagine, it will be hard to show you on the NET that's why I thought the videos were applicable. If you want to see a setup go here:http://video.helifreak.com/?subpath=...ervo_setup.wmv


What is the overall pitch of the machine in the collective range? Cut the SWH values in half and use the EPA for pitch, aileron and elevator in the Surface menu to set the overall pitch and cyclic ranges on the helicopter as a starting point.

Terry
TMooreATX is offline  
Reply With Quote
Old 11-25-2010, 10:44 AM
  #18
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Thanks for all the tips.
When I'm running on the ground about 45-40% and push the elevator fwd the heli jumps into the air and then falls down.
Should I have so mutch pitch input on the elevator input?
My over all pitch end to end is 10 degrees.
cap21r is offline  
Reply With Quote
Old 11-25-2010, 06:44 PM
  #19
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Please post all the numbers in the SWH Menu.
TMooreATX is offline  
Reply With Quote
Old 11-25-2010, 07:14 PM
  #20
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Well I just changed the SWASH setting to 80 5 5 and I had no pitch change whith FWD elevator.
I'm not sure how correct this but I could now hover with this Heli. Its dark now and the La state birds are out in force so I packed in up tonight.
I increased the EXPO to near 40% untill I get the hang of the new setting.
I these numbers don't sound good let me know.
Should I have to back the % off the Ailerons and Pitch inorder to stop the travel mix with the elevator?
I'm new to heli's and not sure.
cap21r is offline  
Reply With Quote
Old 11-25-2010, 07:38 PM
  #21
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Please post what is in the Surface menu/ SWH setting.  There should be a total of 9 numbers with 3 columns across and 3 rows down.

Terry
TMooreATX is offline  
Reply With Quote
Old 11-27-2010, 08:46 PM
  #22
rodon
 
Join Date: Sep 2004
Location: Hockessin, DE
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

way to hijack a thread...
rodon is offline  
Reply With Quote
Old 11-27-2010, 11:54 PM
  #23
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Just trying to help a fellow modeler.
TMooreATX is offline  
Reply With Quote
Old 11-28-2010, 07:33 PM
  #24
cap21r
 
Join Date: Nov 2003
Location: Morgan City, LA
Posts: 74
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

Well I finaly have the Blade back in the air. All is well and flying better with the

SD-10G

I put the new Jr-270 3-D Micro Gyro in last night and flew all day.



My final SWAP plate setting is below.

________Elev___Aileron___Pitch

Elev.____90% ___________90%

Aileron _-40%__-60%____90%

Pitch___-40%___ 60%____90%

I can do a bit more tuning with the new Gyro but for now it's steady. The Gyro setting now is -40% with hands free hovering.

Thanks for all the input and maybe this will help the next Heli pilot.
cap21r is offline  
Reply With Quote
Old 11-28-2010, 09:01 PM
  #25
TMooreATX
 
Join Date: Apr 2003
Location: Cookeville, TN
Posts: 233
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SD-10G Service Bulletin

This is part of the reason that you are having problems. The numbers aren't right. The SWH menu isn't like Swash AFR on any JR or Futaba radio. This menu item controls the direction and mixing plus overall travel volume for each individual function unlike Swash AFR which just controls the overall travel volume and direction for the function. For instance if you look on the left column the AI and PI number should be half of the EL numbers because this is a 120 degree swashplate and there is no correctionneededfor any bad swashplate habits at the moment.

Might I suggest this:
50 - 50
-25 -25 50
-25 50 50

Once you have these numbers set I would then go up to the EPA numbers for EL, AI and PI and make sure that you understand that the EPA values are for the actual function and they there will be an EPA value for the EL, AI and PIfunction in two directions and you can see it toggle with the appropriate stick between the two valuers. The EPA values can be adjusted from their default values of 100 in each direction for the total pitch, aileron and elevator throws.

Terry
TMooreATX is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:44 PM.