Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 1 of 2 12 LastLast
Results 1 to 25 of 39

  1. #1

    Join Date
    Mar 2005
    Location
    Fountain Valley, CA
    Posts
    377
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    SD-10G Service Bulletin

    SD-10G Owners

    We have available an update to the RF board.

    For details and directions on how to get this free update, please follow the link below
    http://www.airtronics.net/SD10GSB-11-17-2010

    Mike Greenshields - Product Manager
    Airtronics - Global Hobby Distributors

  2. #2

    Join Date
    Sep 2003
    Location
    colorado springs, CO
    Posts
    106
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Mike,


    My SD-10g is one of the transmitters on the list. I will be sending it back soon. Are there any other updates that I should have done while the radio if back for service. I have had it since last fall.

    Thanks

    Rod

  3. #3

    Join Date
    Mar 2005
    Location
    Fountain Valley, CA
    Posts
    377
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Our service tech will check the radio for proper operation while he has it. If you have any concerns, make a note of them when you send in the radio.

    Mike
    Mike Greenshields - Product Manager
    Airtronics - Global Hobby Distributors

  4. #4

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Thanks for the update.
    My number is 3905022012.
    Does any body know why I cant program my Blade-400 with this SD-10G? I spent hours trying to set this model up and have had no luck. I once I set the swash up the elevator is reverse.
    I'de hate to think I just trashed the DX-6 and have to TX for my Blade.

  5. #5

    Join Date
    Mar 2005
    Location
    Fountain Valley, CA
    Posts
    377
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    I'll have one of the heli team guys get you answers on your heli setup ASAP.
    Mike Greenshields - Product Manager
    Airtronics - Global Hobby Distributors

  6. #6

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Just reverse the elevator function in the SWH Menu.  Select SWH and reverse the sign of the EL Value in the menu.  For example if the value is now 50 make it a -50.

    Terry

  7. #7

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Thanks
    Is there any other setting to change or add out side of basic?

  8. #8

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    How can I set up trainer mode and stunt mode?
    It seems un stable as I just had it up. The tail seems to be hunting and supper touchy compared to the way I had it set up on the DX6.
    The Blade-400 has a remote gain but I seen no changes when I + and - the program.

    I need a setup for dummy book.

  9. #9

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    How can I set up trainer mode and stunt mode?
    It seems un stable as I just had it up. The tail seems to be hunting and supper touchy compared to the way I had it set up on the DX6.
    The Blade-400 has a remote gain but I seen no changes when I + and - the program.

    I need a setup for dummy book.

  10. #10

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    What channel is the gyro gain plugged into?

  11. #11

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    The gyro is plugged into#5.
    the guess I'm missing a step in setting up.
    I reduced the EPA as my controls had started to bottom out. I reduced elevator,ailerons and Pitch so one servo wouldn't over take the other. What should be a safe travel setting as I'm not a 3-D yet. I'm limited. I was thing about -2 degrees and+9 for pitch. Your thoughts will be helpful.

  12. #12

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Set the machine up for -10 to +10 with ZERO at the half stick point.  Adust the gyro gain so that the tail doesn't hunt or pulse, a sure sign of too much gain.  Watch these videos on the radio for more information:   http://www.helifreak.com/showthread.php?t=167016

  13. #13

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Thanks,
    I'm ready to trash this thing.
    I just can't get this tunned in.
    I may need to repair the DX6 and use it.
    I cant open the vids on the link you sent me.

  14. #14

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Don't give up, the radio isn't the issue, it's the setup.  Get the setup right and the radio will amaze you.  The videos are standard Windows Media player videos, you may have to update Media Player but that should be no biggie.

    Terry






  15. #15
    MikeRuth's Avatar
    Join Date
    Mar 2006
    Location
    Tarzana, CA
    Posts
    409
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Never give up, I mentioned earlier on RCG that I to had some difficulty with it at first. Ultimately I took my time, read the manual, a couple times and then started working with it. Now that I am familiar with the flow of the system and menus it is a breeze and as mentioned before an awsome radio.

    I'm so glad I choose this over the other manufactures out there.

    MIke R

  16. #16

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    All seems OK just looking at the movement but when Im running near 50% and give fwd stick she jumps up as if the pitch was mixed with the elevator.
    I'm long out of ideas and all out of new parts.
    I did look through the HF vids and seen a lot of info but nothing on setting up the swash plate for as starting points
    I'm a show man not a tell me.
    My swash plate is set Elev -100 Ail 50 and Pitch 50.
    when I look the the DX-6 setup its like 75 65 65?
    agian thanks for your time in helping me.

  17. #17

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Anything in the DX 6 won't apply to the SD10G. As you can imagine, it will be hard to show you on the NET that's why I thought the videos were applicable. If you want to see a setup go here:http://video.helifreak.com/?subpath=...ervo_setup.wmv


    What is the overall pitch of the machine in the collective range? Cut the SWH values in half and use the EPA for pitch, aileron and elevator in the Surface menu to set the overall pitch and cyclic ranges on the helicopter as a starting point.

    Terry

  18. #18

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Thanks for all the tips.
    When I'm running on the ground about 45-40% and push the elevator fwd the heli jumps into the air and then falls down.
    Should I have so mutch pitch input on the elevator input?
    My over all pitch end to end is 10 degrees.

  19. #19

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Please post all the numbers in the SWH Menu.

  20. #20

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Well I just changed the SWASH setting to 80 5 5 and I had no pitch change whith FWD elevator.
    I'm not sure how correct this but I could now hover with this Heli. Its dark now and the La state birds are out in force so I packed in up tonight.
    I increased the EXPO to near 40% untill I get the hang of the new setting.
    I these numbers don't sound good let me know.
    Should I have to back the % off the Ailerons and Pitch inorder to stop the travel mix with the elevator?
    I'm new to heli's and not sure.

  21. #21

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Please post what is in the Surface menu/ SWH setting.  There should be a total of 9 numbers with 3 columns across and 3 rows down.

    Terry

  22. #22

    Join Date
    Sep 2004
    Location
    Hockessin, DE
    Posts
    3
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    way to hijack a thread...

  23. #23

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Just trying to help a fellow modeler.

  24. #24

    Join Date
    Nov 2003
    Location
    Morgan City, LA
    Posts
    73
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    Well I finaly have the Blade back in the air. All is well and flying better with the

    SD-10G

    I put the new Jr-270 3-D Micro Gyro in last night and flew all day.



    My final SWAP plate setting is below.

    ________Elev___Aileron___Pitch

    Elev.____90% ___________90%

    Aileron _-40%__-60%____90%

    Pitch___-40%___ 60%____90%

    I can do a bit more tuning with the new Gyro but for now it's steady. The Gyro setting now is -40% with hands free hovering.

    Thanks for all the input and maybe this will help the next Heli pilot.

  25. #25

    Join Date
    Apr 2003
    Location
    Cookeville, TN
    Posts
    233
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD-10G Service Bulletin

    This is part of the reason that you are having problems. The numbers aren't right. The SWH menu isn't like Swash AFR on any JR or Futaba radio. This menu item controls the direction and mixing plus overall travel volume for each individual function unlike Swash AFR which just controls the overall travel volume and direction for the function. For instance if you look on the left column the AI and PI number should be half of the EL numbers because this is a 120 degree swashplate and there is no correctionneededfor any bad swashplate habits at the moment.

    Might I suggest this:
    50 - 50
    -25 -25 50
    -25 50 50

    Once you have these numbers set I would then go up to the EPA numbers for EL, AI and PI and make sure that you understand that the EPA values are for the actual function and they there will be an EPA value for the EL, AI and PIfunction in two directions and you can see it toggle with the appropriate stick between the two valuers. The EPA values can be adjusted from their default values of 100 in each direction for the total pitch, aileron and elevator throws.

    Terry


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:05 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.