Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

  1. #1

    Join Date
    Mar 2003
    Location
    Leesburg, VA
    Posts
    89
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    SD10G Battery charger issue - again

    Keep reading various postings on the SD10G battery charger and the "new" charger....

    I have the original SD10G battery. I cycled it a few times when I first got it but now I use ethe original wall charger it came with and it seems to work fine. I dont want the aggrevation of removing the battery when I charge it and switching to LiPo seems to be more trouble than it's worth.

    Could somebody clarify the charger/battery problem and corrections.

    Thanks.


  2. #2
    Jetdesign's Avatar
    Join Date
    May 2008
    Location
    Mason, OH
    Posts
    7,020
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD10G Battery charger issue - again

    I think the issue was just that the battery needed to be cycled a few times. I charged my stock battery with my computer charger a couple of times, then used the stock charger. Never had an issue, but I decided to switch to lipo for extended flying time (i.e. weekend contests).
    Joe Marri
    Enjoying all things aviation.

  3. #3
    MikeRuth's Avatar
    Join Date
    Mar 2006
    Location
    Tarzana, CA
    Posts
    409
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD10G Battery charger issue - again


    ORIGINAL: coupar

    Keep reading various postings on the SD10G battery charger and the ''new'' charger....

    I have the original SD10G battery. I cycled it a few times when I first got it but now I use ethe original wall charger it came with and it seems to work fine. I dont want the aggrevation of removing the battery when I charge it and switching to LiPo seems to be more trouble than it's worth.

    Could somebody clarify the charger/battery problem and corrections.

    Thanks.

    I can not clarify with exactness but I can say I bought mine in October of 2010 and I had to cycle thepack several times(maybe 5) to get what I felt was a reasonable run time off of it. I used a third party charger that had a NiMH program in it to perform the cycling.

    There was an issue with the charger it's self, although I do not beleive it was related to not being able to charge but how the lights functioned.

    Ultimately it dosen't matter which charger or pack you got, the best senario is to cycle it preferably on a charger designed to handle NIMH batteries a few times.
    There after theres no reason not to use the included charger as per the manuals instructions.
    I have changed out to Lipo as well but I still use the NIMH battery once in a while as I see no reason to let it waste away.

    MIke R


  4. #4

    Join Date
    Mar 2005
    Location
    Fountain Valley, CA
    Posts
    377
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD10G Battery charger issue - again

    Which charger are you using?
    Mike Greenshields - Product Manager
    Airtronics - Global Hobby Distributors

  5. #5

    Join Date
    Mar 2003
    Location
    Leesburg, VA
    Posts
    89
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: SD10G Battery charger issue - again

    The one that came with the system....about 14 months ago.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:45 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.