Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 1 of 4 123 ... LastLast
Results 1 to 25 of 83

  1. #1

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    SD-10G When i set up the flap and aileron mixing everything is fine until i need to push the control surface to max deflection 150% (needed for 3D). When i set the aileron to 150% under SURFACES and then go to C-mix to set end points on the flap i can get it to max end point but it does not move in tandom with the aileron servo. Once at max deflection when i start to back it off the aileron servos moves as soon as the sticks moves but the flap servo does not move until i get to about the 100% point.. I tried mixing other channels and they all do the same thing. HELP Is this a clitch?


    So to get my four aileron servos to work i set the sd10 to glide but and got the throttle to stick on 1 but have no trim funtion on stick 1 now. WHATTODO..

    oh this is a 37% 120cc bird.


  2. #2

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw



    Any experts on the gliders side know how to mod the motor functions


  3. #3
    MikeRuth's Avatar
    Join Date
    Mar 2006
    Location
    Tarzana, CA
    Posts
    409
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    your going to have to explain what you want to get any help.

    MIke R

  4. #4
    Thud_Driver's Avatar
    Join Date
    Dec 2001
    Location
    Victorville, CA,
    Posts
    1,492
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    Ok, just guessing and I don't usually do 4 servos for ailerons, so I thought I'd try it out.

    So, I set the Aerotemplate to 2 ailerons and 2 flaps. Set both aileron servos to 150% epa's and left the flaps as is. Set 2 C-mixes. LA+ to LF and RA+ to RF, both with points 1 & 9 set to +/-150%. Set FL1 and FL2 switches to null and both C-Mixes to On.

    Works, all 4 channels go to +/- 150% at full aileron deflections and the trims work too. Did not try D/R's so I don't know that answer and I didn't try Flaperons.

    So, I'd guess we need more details.

    Update, I looked closer and indeed the flaps aren't in sync with the ailerons.

    Ok, I see what's going on. If you look at the graph on the C-mix. With 150% epa's on the master channel, the master stick input (ail) to the C-mixstops at 100% epa, giving the 150% output on the slave (as set or whatever is set), but still leaves the ail stick well short of the stop - the portion between 100% epa and 150% epa. Effectively, any master channel epa over 100% will not cause a response on the slave channel, the slave channel will have maxed out at that point. As the graphic is drawn, you get +/- 100% on the master against +/- 150% on the slave. But, at anything less than or = 100% epa on the master and the C-mix has balanced output.

    So, I'm not a glider guy either, but I tried it there. Set Glider template to 2 ail and 2 flaps. Disconnect stick from flaps in VR menu and assign stick to MTor motor. Set aileron to +/-150% epa's and set flap epa's to +/- 0%. In Mixing,go toAI to Fl1 and set 100%for LA>LFand RA>RF. In Sw menu set AI to FL1 to On. This seems to work perfect.

  5. #5

    Join Date
    Mar 2008
    Location
    warren, OH
    Posts
    148
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    you mite have go to vr assign turn off the flaps.

  6. #6

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw


    ORIGINAL: Thud_Driver

    Ok, just guessing and I don't usually do 4 servos for ailerons, so I thought I'd try it out.

    So, I set the Aerotemplate to 2 ailerons and 2 flaps. Set both aileron servos to 150% epa's and left the flaps as is. Set 2 C-mixes. LA+ to LF and RA+ to RF, both with points 1 & 9 set to +/-150%. Set FL1 and FL2 switches to null and both C-Mixes to On.

    Works, all 4 channels go to +/- 150% at full aileron deflections and the trims work too. Did not try D/R's so I don't know that answer and I didn't try Flaperons.

    So, I'd guess we need more details.

    Update, I looked closer and indeed the flaps aren't in sync with the ailerons.

    Ok, I see what's going on. If you look at the graph on the C-mix. With 150% epa's on the master channel, the master stick input (ail) to the C-mixstops at 100% epa, giving the 150% output on the slave (as set or whatever is set), but still leaves the ail stick well short of the stop - the portion between 100% epa and 150% epa. Effectively, any master channel epa over 100% will not cause a response on the slave channel, the slave channel will have maxed out at that point. As the graphic is drawn, you get +/- 100% on the master against +/- 150% on the slave. But, at anything less than or = 100% epa on the master and the C-mix has balanced output.

    So, I'm not a glider guy either, but I tried it there. Set Glider template to 2 ail and 2 flaps. Disconnect stick from flaps in VR menu and assign stick to MTor motor. Set aileron to +/-150% epa's and set flap epa's to +/- 0%. In Mixing,go toAI to Fl1 and set 100%for LA>LFand RA>RF. In Sw menu set AI to FL1 to On. This seems to work perfect.

    hey thud driver Thanks for confirming what i saw. Yep played with it for three hours in AERO mode and then went to GLIDE. Ailerons perfect, then went on to get the throttle to work right.Got itto work but did not like the fact that i lost "Throttle cut" ended up going back to the hitec programmer and AERO settings along with making sure all my linkage was matched as best i could(control horn linkage to hinge center line, linkage length...). Surface control horns only have three positions to adjust linkage to hinge line so i got it closer and the fought with programing servo throw until i got it to synic up. perfect now but what a pain going back and forth between the progrmmer and receiver. Nice to have throttle cut back. 120 cc is a little freaky when you can not turn it off. Thanks again for confirming what i saw.

  7. #7
    Thud_Driver's Avatar
    Join Date
    Dec 2001
    Location
    Victorville, CA,
    Posts
    1,492
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    Throttle Cut is just a C-Mix away......

  8. #8

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw



    Step by step please. Always nice to learn.

    Thanks in advance.


  9. #9

    Join Date
    Mar 2008
    Location
    warren, OH
    Posts
    148
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    i have a manual that walks you different setups send me pm with email and ill send it to you.

  10. #10
    Thud_Driver's Avatar
    Join Date
    Dec 2001
    Location
    Victorville, CA,
    Posts
    1,492
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    Throttle Cut basically disconnects the throttle stick and fixes the chanel output at your selected setting.

    You can do this with one mix for the lower half of the throttle range if that's all you need or 2 mixes for the full range.

    Sw Assign - assignyour preferred cut offswitch to a C-Mix and ( if desired) the same switch to another C-Mix.

    Surface - set the throttle L Limit (not EPA ) to the desired throttle cut position, i.e.; 125%. The mixes I propose will over drive the throttle channel on the low end and this guarantees you get the cut off setting without breaking your servo, linkage or throttle.

    C-Mix 1 - set master to TH & slaveto TH,then set point 1, 5 and 9 allto -150% that covers slightly more than the lower half of the throttle range.

    If you want to cover the entire throttle range, set a second C-Mix to the same settings and the same switch.

    Just a way to do it, but it's mix intensive and you may need all you can get if you were on the glider side since you might have to build some other mixes that are standard on the Aero side.


  11. #11

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw


    ORIGINAL: Thud_Driver

    Throttle Cut basically disconnects the throttle stick and fixes the chanel output at your selected setting.

    You can do this with one mix for the lower half of the throttle range if that's all you need or 2 mixes for the full range.

    Sw Assign - assignyour preferred cut offswitch to a C-Mix and ( if desired) the same switch to another C-Mix.

    Surface - set the throttle L Limit (not EPA ) to the desired throttle cut position, i.e.; 125%. The mixes I propose will over drive the throttle channel on the low end and this guarantees you get the cut off setting without breaking your servo, linkage or throttle.

    C-Mix 1 - set master to TH & slaveto TH,then set point 1, 5 and 9 allto -150% that covers slightly more than the lower half of the throttle range.

    If you want to cover the entire throttle range, set a second C-Mix to the same settings and the same switch.

    Just a way to do it, but it's mix intensive and you may need all you can get if you were on the glider side since you might have to build some other mixes that are standard on the Aero side.

    Cool thanks. i will file this one away. Happy new year

  12. #12

    Join Date
    Mar 2004
    Location
    Lynden, WA
    Posts
    326
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    uhmmm maybe i missed something with all the fancy mixes.....I simply re- assigned 1 extra channel to each the right and left ailerons and all works great? the way i am reading this is 2 servos on a single surface, if incorrect i am sorry.

  13. #13
    Thud_Driver's Avatar
    Join Date
    Dec 2001
    Location
    Victorville, CA,
    Posts
    1,492
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    You can certainly do that but then you can't set the centers and epa's independently for the two servos on each surface.  If you can get the servos and linkages to match exactly mechanically, then that's great but that's not always possible.

  14. #14

    Join Date
    Mar 2004
    Location
    Lynden, WA
    Posts
    326
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    they all 4 adjust independently fine on mine. I just cant reset sub trim for both on one aileron at the same time. did the same with dual rudder and that is how i set it up.
    maybe a glitch in mine?

  15. #15
    Thud_Driver's Avatar
    Join Date
    Dec 2001
    Location
    Victorville, CA,
    Posts
    1,492
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    I guess I assumed you simply went into the CH Assign menu and changed two channels to ailerons or rudder.  If you did it via template or C-Mix then every thing is independently adjustable.

  16. #16

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw


    ORIGINAL: nute12

    they all 4 adjust independently fine on mine. I just cant reset sub trim for both on one aileron at the same time. did the same with dual rudder and that is how i set it up.
    maybe a glitch in mine?

    You have my attention. Can you provide details.

    As a test i set ch 2 to left ail, 7 to left ail, 5 to right ail and 8 to right ail. Oh in model type, standard wing, two ail, 1 flap, 2x elv. Doing so did not allow me to set centers and EPA seperatly.,

  17. #17

    Join Date
    Mar 2004
    Location
    Lynden, WA
    Posts
    326
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    here are the instructions i followed. good luck
    John



    Select SYSTEM. Press ENTER. Scroll to TYPE (#05). Press ENTER.
    Use the Navigation Pad with the YES/+ and NO/- keys to make the following assignments.
    Wing >Normal, Ail >2, Flap >2, Tail >2xEL, TH >1. Press the END key.
    Scroll down to CHANNEL ASSIGN (#12). Press ENTER.
    Using the Navigation Pad with the YES/+ and NO/- keys make the following channel assignments.
    01 >LE, 02 >LA, 03 >TH, 04 >RU, 05 >GE, 06 >RA, 07 >RE, 08 >LF, 09 >A1, 10 >RF.
    Press the END key.
    Scroll down to SWITCH ASSIGN (#13). Press ENTER.
    Make the following assignments:
    Zero out all AUX channels and Flight Modes. Set the following as indicated.
    FLAP 1 >ON>OR -;
    C-MIX 1 >ON >OR >-; C-MIX 2 >ON >OR >-; C-MIX 3 >ON >OR >-;
    Press END key twice.
    Select F-MODE. Press ENTER. Scroll down to C-MIX (#18).
    Use Navigation Pad, YES/+ and NO/- keys to make display read:
    C-MIX >1 C-MIX >2
    COMMON >COM COMMON >COM
    MASTER >LA+ MASTER >RA+
    SLAVE >LF SLAVE >RF
    POINT >1 RATE >–100% POINT >1 RATE >-100%
    POINT >9 RATE >+100% POINT >9 RATE >+100%
    C-MIX >3
    COMMON >COM
    MASTER >RU
    SLAVE >AUX 1
    POINT >1 RATE >-100%
    POINT >9 RATE >+100% Press the END key once.
    Scroll Down to VR ASSIGN (#19). Press ENTER. Set as follows:
    COMMON >COM
    FLAP 1 >-
    AUX 1 >-
    AUX 2 >-
    AUX3 >-
    AUX 4 >- Press END key three times.
    - 2 –
    Select SURFACE MENU. Press ENTER.
    Set LF CENTER to –50% and RF CENTER to –50% to neutralize the servos. Press the END key.
    Set EPA to +50% for LF and RF. It will indicate 1 50 to show Flap 1 is set at 50%
    NOTE: All of the above values are trial values. Fine-tune and set up servo centers, throws, reversing and EPA’s as follows:
    Aileron Channels #2 and #6. EPA, Reverse, and Center set in SURFACE Menu.
    Elevator Channels #1 and #7, EPA, Reverse, and Center set in SURFACE Menu.
    Left Flap and Right Flap Aileron Channels #8 and #10, Reverse and Center set in SURFACE Menu.
    Left Flap and Right Flap Aileron Channels #8 and #10 Servo Throws set in C-MIXERS #1 and #2.
    Rudder, Channel #9 Servo throw set in C-MIXER #3.
    Jack R.

  18. #18

    Join Date
    Mar 2004
    Location
    Lynden, WA
    Posts
    326
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    the slave channel endpoints can be increased in the c-mix boxes. value of 100 is just shown for initial programming. they will go 150 either way.

    see the first post kinda garbled on copy, here is the pdf:

    http://rcheliguy.dyndns.org/global/a...r%20Servos.pdf

  19. #19

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    Did you try it and did you set your "C" mixes to 150%

    This is what i used and what Thuddriver discussed. Try to take all your surfaces to 150% and watch surface move as you move sticks. They do not move together.

  20. #20

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    nute12 did you push the end point limits? What did you see? Maybe you have a dif software upgrade then we do.


  21. #21

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    Got an answer from AIrtronics today.  They confirmed the issue with C-mix,   So bummed.  Having a hard time getting my head around this not working. It is such a basic function.  Starting to get pissed thinking about all the money i have invested in receivers. i really need this to work for giant scale.  
    I asked who we can write a letter too about getting a software fix for it.

    If we have too maybe we post on forums and demand they fix it if we get the cold shoulder.  For now i am going to have faith they do the right thing.  I cant be the only one seeing this being a prob.

  22. #22

    Join Date
    Mar 2004
    Location
    Lynden, WA
    Posts
    326
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    I now see it, sorry for being argumentative. I was wrong. was not over 100% throws before. I just got mine a month back and had not had the time for tweaking all the throws. Didnt even try till i seen this thread and thought..... hah he is confused (guess i was) .... this sucks. main reason for my upgrade is i wanted every servo to have it's own channel. no gizmos added to make em synch. Maybe Mike G can get em to look at a update for us. I wrapped a bunch of money up in 6 more rx's also. this is a huge fail for the giant scale market with this radio.

  23. #23

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw


    ORIGINAL: nute12

    I now see it, sorry for being argumentative. I was wrong. was not over 100% throws before. I just got mine a month back and had not had the time for tweaking all the throws. Didnt even try till i seen this thread and thought..... hah he is confused (guess i was) .... this sucks. main reason for my upgrade is i wanted every servo to have it's own channel. no gizmos added to make em synch. Maybe Mike G can get em to look at a update for us. I wrapped a bunch of money up in 6 more rx's also. this is a huge fail for the giant scale market with this radio.
    No harm. Knew it was you not me LOL. Just kidding (hope you can take a joke)
    Ya i wanted to get away from match boxes too. The servos take a lot of amps /draw and each should be on its own ch now a days. More so running HV. Yep so bummed. Been a Airtronics supporter for years. Not sure what to do. Maybe go spend money i dont have on a Power Box or SMart Fly system that alows me to plug the servos into sep channels and set end points. On the next airframe. I was lucky to get my AJ slick 104 to work using my servo programmer.

    Or maybe buy Futaba. Cant believe i just said that.

    Feel like someone just peed in my cerial.


  24. #24

    Join Date
    Nov 2009
    Location
    garden grove , CA
    Posts
    98
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    They got back to me and said they are sending it up the line. Lets cross our fingers.

  25. #25
    Thud_Driver's Avatar
    Join Date
    Dec 2001
    Location
    Victorville, CA,
    Posts
    1,492
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: sd-10g 2 servos per aileron surface c-mix does not work right past 100% throw

    Sounds like now would be a really good time to get an update out and fix this and all the other things people have asked for.


Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:44 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.