Airtronics Support Forum Ask any questions you may have about Airtronics radios and product here and get answers direct from the Airtronics Team.

Finish wearing off my SD-10G

Reply
Old 10-29-2012, 06:59 PM
  #1
Mike Wiz
Thread Starter
 
Join Date: Jan 2002
Location: Fenton, MI
Posts: 941
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Finish wearing off my SD-10G

I'm out flying at a contest this past weekend and I noticed the finish wearing off my SD-10G case. The chrome finish is coming off on the sides and its showing white plastic. Is this typical? It seems I once saw where someone else mentioned something like that. Is this covered under warenty? Can I get a new case for the radio if not?

Mike
Mike Wiz is offline  
Reply With Quote
Old 10-30-2012, 01:12 AM
  #2
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

When did you get your Tx? Some of the early chrome surfaces had a tendency to react chemically with hand sweet.


Attached Thumbnails
Click image for larger version

Name:	Fd92243.jpg
Views:	41
Size:	78.3 KB
ID:	1816156  
Pippin is offline  
Reply With Quote
Old 10-30-2012, 06:52 AM
  #3
Mike Wiz
Thread Starter
 
Join Date: Jan 2002
Location: Fenton, MI
Posts: 941
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Actually, I notices that the finish all over the thing is beginning to look funky. I have a feeling I'm going to have the finish flaking off all over before all is said and done. When did I buy it? Maybe a year after their were first released... I'm not too sure. It has the antenna that goes up and it was one of the radios that were recalled.

I've never had a radio where the finish wore off. I flew a JR 10X for nearly 12 years and it didn't wear like this.
Mike Wiz is offline  
Reply With Quote
Old 10-30-2012, 07:54 AM
  #4
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Looks like you got an older 2009 model. There were few radios from the same lot with similar problems. I would contact Airtronics.

Btw, the JR10x body is magnesium-alloy. It's different.

Pippin is offline  
Reply With Quote
Old 10-30-2012, 11:53 AM
  #5
Mike Wiz
Thread Starter
 
Join Date: Jan 2002
Location: Fenton, MI
Posts: 941
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

I sort of thought that's what this forum was all about? I'll contact Airtronics directly.

Thanks

Mike
Mike Wiz is offline  
Reply With Quote
Old 11-04-2012, 04:47 PM
  #6
grotto2
 
grotto2's Avatar
 
Join Date: Feb 2003
Location: Palm Bay, FL
Posts: 923
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Do let us know what you find out, Mike.
Mine must be from the same batch, as your chrome flaking description matches mine exactly.
It's a shame as it's such a class radio otherwise.
grotto2 is offline  
Reply With Quote
Old 11-05-2012, 02:21 PM
  #7
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Could you do me a favour and open your radios. Inside the case you will find the date of manufacture stamped into the plastic.


I think, the problem is only related the first batch produced in 2009:

http://img5.blogs.yahoo.co.jp/ybi/1/...568_24541086_0

In these cases, Sanwa in Japan replaced the affected radios.
Attached Thumbnails
Click image for larger version

Name:	Bz78741.jpg
Views:	65
Size:	153.6 KB
ID:	1817905  
Pippin is offline  
Reply With Quote
Old 11-05-2012, 02:47 PM
  #8
MikeRuth
 
MikeRuth's Avatar
 
Join Date: Mar 2006
Location: Tarzana, CA
Posts: 410
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Pippin, what's with the image and red outline?.
I'll. Open and check mine later today.
Thx
Mike R
MikeRuth is offline  
Reply With Quote
Old 11-06-2012, 12:48 AM
  #9
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

I outlined the area where you will find the date of manufacture.

If you have an older radio with the extendible antenna, the older none-adjustable sliders, matt chrome surface around the gimbals and matt chrome buttons, yours might be produced in 2009.

Btw,
I've got two MY 2009 radios and both started to show corrosion (green rust) around the charger plug quite early. Also, my first one got white spots like the radios in the link I provided above.
It looks like something went wrong during the production process/chrome-plating of some of the very early SD-10s. Or my hand sweat is like acid rain.

As I tried to show, even car manufactures like BMW do have problems with chrome-plating.

I do not know whether your radio is already out of warranty. If you need to replace the case of your radio, I would upgrade the whole thing to the newer standard (new sliders and case).
Pippin is offline  
Reply With Quote
Old 11-06-2012, 01:09 AM
  #10
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

This is an early model:
http://i240.photobucket.com/albums/f...ratcheS012.jpg
http://www.helifreak.com/showthread.php?t=291569

and this the newer one:
http://www.rcuniverse.com/market/item.cfm?itemId=878441
http://static.rcgroups.net/forums/at...2-IMG_2004.jpg

I forgot, the newer model has the spring loaded switch one the left hand side whereas the older model has it one the right hand side. Because of this, the newer model comes with a different software version.
Pippin is offline  
Reply With Quote
Old 11-06-2012, 05:27 AM
  #11
grotto2
 
grotto2's Avatar
 
Join Date: Feb 2003
Location: Palm Bay, FL
Posts: 923
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Okay. I see it on mine, a couple of molded-in clock hands.
The first one points bettween 3 and 4 and the second points at 09.
I presume that puts mine in the batch.
grotto2 is offline  
Reply With Quote
Old 11-06-2012, 02:38 PM
  #12
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Yes, yours must be one of the first radios produced.
Pippin is offline  
Reply With Quote
Old 11-08-2012, 05:03 AM
  #13
EddieDean
 
Join Date: Sep 2003
Location: Port Charlotte, FL
Posts: 66
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

My SD-10G is shows some flaking as well.
EddieDean is offline  
Reply With Quote
Old 11-08-2012, 08:55 AM
  #14
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Do you have the first or second generation SD-10G?

Can you check date of manufacture for us?
Pippin is offline  
Reply With Quote
Old 11-08-2012, 08:56 PM
  #15
EddieDean
 
Join Date: Sep 2003
Location: Port Charlotte, FL
Posts: 66
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

My SD-10G shows a date of 4/09
EddieDean is offline  
Reply With Quote
Old 11-20-2012, 11:46 AM
  #16
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Does your SD-10G look as bad as this Futaba radio?
http://www.rcheliresource.com/wp-con...8/p1060788.jpg
Pippin is offline  
Reply With Quote
Old 11-20-2012, 10:08 PM
  #17
EddieDean
 
Join Date: Sep 2003
Location: Port Charlotte, FL
Posts: 66
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Thankfully no.
EddieDean is offline  
Reply With Quote
Old 02-02-2013, 06:31 PM
  #18
GMPheli
 
Join Date: Dec 2001
Location: West Bridgewater, MA
Posts: 152
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

So has anyone contacted Airtronics about this, and if so what was the outcome? My SD-10G is doing the same thing. I checked the date of manufacture, and it is 12 09. But I have the spring loaded switch on the left side so that means I have a newer one?
GMPheli is offline  
Reply With Quote
Old 02-02-2013, 06:37 PM
  #19
MikeRuth
 
MikeRuth's Avatar
 
Join Date: Mar 2006
Location: Tarzana, CA
Posts: 410
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

From what I have read, you can send it in for a general service and case replacement for $50.00.

Personally I'm going to paint mine myself. I do agree it stinks this is happening.
MikeRuth is offline  
Reply With Quote
Old 02-02-2013, 06:53 PM
  #20
GMPheli
 
Join Date: Dec 2001
Location: West Bridgewater, MA
Posts: 152
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Looks to be quite a job to change it out. Transmitter will have to be gutted. It's a shame as I really like the transmitter.
GMPheli is offline  
Reply With Quote
Old 02-02-2013, 06:57 PM
  #21
MikeRuth
 
MikeRuth's Avatar
 
Join Date: Mar 2006
Location: Tarzana, CA
Posts: 410
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

It's not too bad, I've had mine torwn down a bit when I installed the extra be pot and switch. I figure it should b a day project plus time for the paint to cure well.

There's a few more post on ex groups about this too.
MikeRuth is offline  
Reply With Quote
Old 02-03-2013, 06:28 PM
  #22
GMPheli
 
Join Date: Dec 2001
Location: West Bridgewater, MA
Posts: 152
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

I have a lot of projects going on right now. I just might wait for the Super version to come out and use the black case
GMPheli is offline  
Reply With Quote
Old 02-22-2013, 02:12 AM
  #23
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

GMPheli,
does your Tx have a shiny surface around the gimbals or rather mattfinished?
Pippin is offline  
Reply With Quote
Old 02-22-2013, 02:14 AM
  #24
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Mattfinished
http://images.rcuniverse.com/forum/u...89/Ki18428.jpg
Pippin is offline  
Reply With Quote
Old 02-22-2013, 02:16 AM
  #25
Pippin
 
Join Date: Mar 2004
Location: College Park, MD
Posts: 671
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Finish wearing off my SD-10G

Shiny surface around gimbals:
http://images.rcuniverse.com/market/...183-3-4059.jpg
Pippin is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:59 PM.