Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

Thread: Rd6000


  1. #1

    Rd6000

    I have an Airtronics RD6000 6 channel radio with 2 receiver packs. After installing new batteries ( NIMH ) and charging, the transmitter turns on but, the receiver does not. It will only bump 1 or 2 of the servos when turning on the switch on the receiver. I know the polarity is correct since I had purchased a new receiver pack and had used it to run this radio prior to this problem. This radio, although never used to fly anything ( building a Great Planes P51 and have a 2nd receiver in a Kalt Baron 30 ) is essentially new although it is problably 6-7 years old. At times when trying to fly the heli the radio would operate, at other times nothing. The transmitter always turns on but hit or miss on the receiver. With 2 receivers I you would think at least 1 would work consistently. Now, neither receiver reacts to the signal from the transmitter. What can I do?
    Last edited by jmscck64; 10-13-2013 at 07:00 PM. Reason: more info

  2. #2

    Join Date
    Aug 2009
    Location
    St. Cloud, FL
    Posts
    438
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Hi, have you checked to see if the transmitter is transmitting in the correct fashion for the receivers?? I.E. PCM, PPM, positive or negative shift?? also, might seem like a silly question, but are the Rx's on the same Frequency as the Tx?? sometimes, even if some of these things are wrong, the Servos will get a "Bump" just from the act of turning on the Rx. or even from turning on the Tx while the Rx is on, even if it is transmitting on a different freq, Modulation, or Shift.

    Craig.
    Ultra Sport Brotherhood #10
    Revver Bro #263
    Tiger Club #26

  3. #3
    Thanks for the reply. These are the Airtronics recevers I've had since I got this radio, one came with the radio and the 2nd is Airtronics 92777/ 72 Mhz FM, a flight pack I bought a little later. Both have worked in the past but neither works anymore. Batteries fully charged ( I have 2 receiver battery packs) and the transmitter turns on but the receivers do not. In the past, this radio would work sometimes and sometimes it wouldn't. Never been able to confidently use it to fly the heli. Bought the receiver pack to put in the P-51 from Top flite ( not Great planes as I said in my original post) and have not finished that . I have 3 of the older VG6DR 6 channel radios that I've never had any problems with, but this one has been a real let-down. Sorry now that I bought it.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:28 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.