Airtronics Support Forum Ask any questions you may have about Airtronics radios and product here and get answers direct from the Airtronics Team.

Rd6000

Reply
Old 10-13-2013, 04:54 PM
  #1
jmscck64
Thread Starter
 
Join Date: Oct 2013
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Rd6000

I have an Airtronics RD6000 6 channel radio with 2 receiver packs. After installing new batteries ( NIMH ) and charging, the transmitter turns on but, the receiver does not. It will only bump 1 or 2 of the servos when turning on the switch on the receiver. I know the polarity is correct since I had purchased a new receiver pack and had used it to run this radio prior to this problem. This radio, although never used to fly anything ( building a Great Planes P51 and have a 2nd receiver in a Kalt Baron 30 ) is essentially new although it is problably 6-7 years old. At times when trying to fly the heli the radio would operate, at other times nothing. The transmitter always turns on but hit or miss on the receiver. With 2 receivers I you would think at least 1 would work consistently. Now, neither receiver reacts to the signal from the transmitter. What can I do?

Last edited by jmscck64; 10-13-2013 at 05:00 PM. Reason: more info
jmscck64 is offline  
Reply With Quote
Old 10-13-2013, 06:03 PM
  #2
SeaJay
 
Join Date: Aug 2009
Location: St. Cloud, FL
Posts: 556
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Hi, have you checked to see if the transmitter is transmitting in the correct fashion for the receivers?? I.E. PCM, PPM, positive or negative shift?? also, might seem like a silly question, but are the Rx's on the same Frequency as the Tx?? sometimes, even if some of these things are wrong, the Servos will get a "Bump" just from the act of turning on the Rx. or even from turning on the Tx while the Rx is on, even if it is transmitting on a different freq, Modulation, or Shift.

Craig.
SeaJay is offline  
Reply With Quote
Old 10-14-2013, 09:41 AM
  #3
jmscck64
Thread Starter
 
Join Date: Oct 2013
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks for the reply. These are the Airtronics recevers I've had since I got this radio, one came with the radio and the 2nd is Airtronics 92777/ 72 Mhz FM, a flight pack I bought a little later. Both have worked in the past but neither works anymore. Batteries fully charged ( I have 2 receiver battery packs) and the transmitter turns on but the receivers do not. In the past, this radio would work sometimes and sometimes it wouldn't. Never been able to confidently use it to fly the heli. Bought the receiver pack to put in the P-51 from Top flite ( not Great planes as I said in my original post) and have not finished that . I have 3 of the older VG6DR 6 channel radios that I've never had any problems with, but this one has been a real let-down. Sorry now that I bought it.
jmscck64 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:58 PM.