Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Aug 2011
    Location
    Aiken, SC
    Posts
    5
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Thunder 1220 charger problem

    Hello,

    When I hook my Thunder 1220 charger up to my 500w power supply it runs through the normal setup which shows its connected to the 500w power supply, but then I get an ERROR car batt. empty message. Whats up with it?

    Thanks

  2. #2

    Join Date
    Jul 2010
    Location
    Aberdeen, UNITED KINGDOM
    Posts
    1,002
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Thunder 1220 charger problem

    Have you used the 500w supply before? If not does it have a setting for output voltage, it might be set too low.


    Hello, the IMAX b6 quattro fits the bill?

  3. #3

    Join Date
    Aug 2011
    Location
    Aiken, SC
    Posts
    5
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Thunder 1220 charger problem

    Turned out to be the power supply. Adjusted the output & still didn't work. Plugged into my 350w power supply & worked fine. It was new out of the box. Sending it back for replacement. Thanks for responding!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 01:46 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.