Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1
    Demonic_Dragon's Avatar
    Join Date
    Apr 2007
    Location
    Lebanon, PA
    Posts
    9
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Brand new Tornado S30 and never ran.

    Well it did run somewhat.

    The problem that I am having that my rc is sputtering fuel out and the other problem is the pull starter. Every time I get it to run for a few seconds, it snags on the pull cord in even further and stops the engine immediately. I've just purchased this and this is the first time running it. I was still in the tuning phase so I never got the chance to play with it because of the issues.

    My guess is that I have to tear apart the pull starter and see what's causing it to snag while it's running. It especially sucks when the pullstarter is not covered by the warranty. The only thing that has a warranty is the engine.

    I have a Redcat racing Tornado S30 that has a .18 SH engine in it.

    Any tips and suggestions would be helpful and thanks if you do so.

    I am just really annoyed that I blew $200 for this RC and never got to run it. Pre-assembled units should be more forgiving to some extent and not let any crap jobs go through. I wish I could get away with that stuff at my work. lol

  2. #2

    Join Date
    Jun 2009
    Location
    Elgin, IL
    Posts
    568
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Brand new Tornado S30 and never ran.

    Just wait till you start stripping spur gears; you will really be annoyed.
    I have the same car; it started out okay but once i started stripping the gears it continues to happen.
    Even if you set the gear mesh right sooner or later it will happen again unless you upgrade your clutchbell to an HPI.
    It would be nice if redcat would investigate this issue and make some kind of upgrade to rid this problem.
    Sorry if I cannot offer some advise; I am new to this hobby.
    I would probably take the pull start off the engine and see if you can fix it.
    If you dont already know there are videos on youtube on how to fix this problem just type in "alishanmao" in the search box and this guy has a video on how to do this just look for it.
    I always tell the truth. Even when I lie. Al Pacino (Scarface 1983)

  3. #3

    Join Date
    Sep 2009
    Location
    verdun, QC, CANADA
    Posts
    10
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Brand new Tornado S30 and never ran.

    i have a tornado S30 too i had to change the pull start cause it was broken the RC shop where i go in Montreal told me that it was a cheaply manufactured pull start and i was lucky to been able to start the engine with that thing so i got my self a nice electric starter no more pulling like crazy i havent had any proble3ms so far with the spur gear but the front dog bone keept falling off for the first time i used it found out it was missing a rubber O-ring in one of the 2 cupplings that hold the dog bone i stuck a small piece or rubber in the cuppling fixed the issue .

    so far Redcat Racing offers a good ( but cheap in all the ways of the term ) merchandise its great for beginners but nothing is better than HPI or TRAXXAS but still for the price its not a rip off .


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:04 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.