CEN Racing This forum is to discuss all CEN Racing products.

Cen GST 7.7 slipping somewhere

Reply

Old 06-13-2014, 06:19 PM
  #1  
centervalley
Junior Member
Thread Starter
 
Join Date: Jun 2014
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Cen GST 7.7 slipping somewhere

Hello: new to this forum so hello to all. The problem the when the gas is hit hard the engines revs but the truck does not move at speed that matches rev's, something slipping. Where do I start, I have just put in new clutch and bell with no help. Thanks ahead of time for all help.
centervalley is offline  
Reply With Quote
Old 06-15-2014, 11:44 PM
  #2  
savage dust bunny
Member
 
savage dust bunny's Avatar
 
Join Date: Jan 2013
Location: Copenhagen, DENMARK
Posts: 53
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Since you've you've just put in a new clutch and bell, make sure the actual installation was done correctly. If you didn't have this problem before you replaced these parts, then that's most probably where your issue is.

Next up if you've already tried this - check if the screws holding the outdrive cups from the diffs are still in and tightened - these can come loose. Tighten them down and remember to use locktite on all screws going into metal. Next up is checking if your diffs are finished...

Let us know what you ended up having to fix/tighten.
savage dust bunny is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service