The Clubhouse If it doesn't fit in any other category and is about general RC stuff then post it here at the Clubhouse.

JR delta wing elevon problem

Reply
Old 10-01-2010, 02:07 PM
  #1
workingcinderellaman
Thread Starter
 
Join Date: Mar 2008
Location: fruit heights, UT
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default JR delta wing elevon problem

I have a JR 9303 radio that I'm trying to get to work with a delta wing (Stryker). I recently upgraded it to 2.4 ghz with a Spectrum module. I have a Spectrum park flyer Rx in the Stryker and I can't get the ailerons to work right. I set up the radio to the delta wing configuration and the elevons work with the elevator but are reversed with the ailerons. There's no instruction on fixing this problem in the owner's manual. Does anyone have any suggestions on how to fix this?
workingcinderellaman is offline  
Reply With Quote
Old 10-01-2010, 02:56 PM
  #2
red head
 
Join Date: Feb 2005
Location: Zephyrhills, FL
Posts: 2,029
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: JR delta wing elevon problem

Call Horrizon support. Try this number 1 800 338 4639 . ENJOY !!! RED
red head is offline  
Reply With Quote
Old 10-05-2010, 11:13 PM
  #3
molokaiboy
 
Join Date: Feb 2007
Location: Kihei, HI
Posts: 184
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: JR delta wing elevon problem

Idon't have that TX, but I believe it's similar to the X9303 and DX7. Try putting the left ail/ele into the Aileron slot on your rx and the right ail/ele into the Elevator slot on your rx. You may have to reverse one or both servos in your tx.

Aloha,
Les
molokaiboy is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:08 PM.