The Clubhouse If it doesn't fit in any other category and is about general RC stuff then post it here at the Clubhouse.

Need help identifying what I bought

Reply
Old 08-24-2010, 07:51 PM
  #1
Toph
Thread Starter
 
Join Date: Aug 2010
Location: , VA
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Need help identifying what I bought

Okay, first off let me say that I'm pretty much a complete noob in the world of RC. I had a Nitro car about 10 years ago when I was in college, but haven't done anything with them since then. I know a little bit about the basics; cars, servos, transmitters, etc but I'm sure a lot has changed in the last decade.

Anyway, I went to the local Goodwill this afternoon and saw an RC car on the shelf. Looked like an electric 1/10 car my buddy had back in college and much like the nitro I had as well. I figured that I could probably get a good deal on it since it was at a second hand type shop and they probably had no idea what it was. I searched but could never find the transmitter for it. It did have the plastic unpainted body with it though. A Mini Cooper shell that had been taped on the windows ready for paint. The car looks like it has never been run. Still has the little rubber bits on the tires and has absolutely no dirt or wear on it at all. I don't know if this was bought and never used or built and lost. I don't see any markings for manufacter on the car so I don't know who even made it. I'll give all the specifics that I can get off the battery, receiver, servo, etc.

Can anyone please help me figure out what I have, what it might be worth, and what it would take to get it going.

The receiver is blue and is an Airtronics 2 channel by Sanwa and the numbers on it are 92723 75. The band is AM and there is also a B21 going vertical on it.

The orange thing in the middle (servo?) says Explorer Sport Mega FET High Frequency ESC NOVAK. It has two purple heat sinks on it.

The battery is a Trinity Amp Max 1400 Plus SR and looks new.

The on/off switch going to the orange Explorer (servo?) is loose but can easily be mounted back on. Other than that, all the wires seem to be in good condition and I can't find any breaks on anything on the car.

The frame is black and has no identifying marks except the number 239 on the side of the chassis and it also says "front wheel drive" on one spot.

The tires are Tamiya 42214-39244 and look like they have never touched the ground.

The car has four wheel independent suspension and all the shocks and springs work well.

Here are some pictures that I took of the car. Please somebody help me figure out what I have. I'm guessing Iwould need a transmitter and a battery charger to get going. Other than that, the car looks complete.









Toph is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:16 AM.