Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

Thread: power issue?


  1. #1

    Join Date
    Jul 2008
    Location
    Cambridge, UNITED KINGDOM
    Posts
    28
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    power issue?

    thought i had a power problem with my battery but i tested it and everything is ok.
    today i setup as normal and had a fly about for anout 3 mins, low level.

    power cut, i was only about 5 inchs off the ground so no damage.

    no leds on. iv cchanged the fuse too.

    i turned it all off and back, all ok. but when i apply throttle the power cuts and leds go out, then the leds return on after about 5 sec's.

    it does this every time. tested battery again - all was ok.

    what could be the prob?
    \"The first 80% takes 20% of your effort,
    and the last 20% takes 80% of your effort\"

  2. #2

    Join Date
    Jan 2005
    Location
    Lagunilla, , COSTA RICA
    Posts
    356
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: power issue?

    Happened to me once and it was some kind of electronic mess with the circuit board, I had to send it to Spectrolutions.....the circuit board is very tricky even without crashes, that was one of the things that made me quit to the DF.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:41 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.