RCU Forums

RCU Forums (http://www.rcuniverse.com/forum/)
-   Draganfly Innovations Products (http://www.rcuniverse.com/forum/draganfly-innovations-products-403/)
-   -   Motor Not Spinning Up - Newbie (http://www.rcuniverse.com/forum/draganfly-innovations-products-403/8230763-motor-not-spinning-up-newbie.html)

rjparth 12-10-2008 12:08 AM

Motor Not Spinning Up - Newbie
 
Hey guys, brand new to the RC and the SAVS. I just bought a used unit and I'm trying to go over it carefully and make sure things are right. I've resisted the urge to try to fly it. I did, however, go through the startup process while holding the helicopter to prevent it from going anywhere. Two of the motors spin up immediately (opposite one another). The other two are dormant until about 1/4 to 1/3 throttle at which point one spins up. The other will not spin up at all even at full throttle. I'm aware of the magnet issue from the manual, but I'm not sure what to look for. Can someone post a picture of what I should be looking for? Also, what's the proper way to check the contacts with the multimeter? I'm worried that probing it while armed may result in an unintended spin-up.

va3mw 12-10-2008 12:24 AM

RE: Motor Not Spinning Up - Newbie
 
They usually test fly them before they ship them. Are all your trims set to center (except throttle)?

Make sure the connector on the bottom of the board is fully connected.

As for the magnets, look in the slots and if the magnet has slide down, you'll see it through the window in the motor. There are 2 slots/motor.

Hope that helps.

rjparth 12-10-2008 10:09 AM

RE: Motor Not Spinning Up - Newbie
 
1 Attachment(s)
Thanks for the quick response. This is a used unit sold "as is" so I'm not quite certain what sort of life it's had. The seller claimed only 2 flights, but I have a feeling they were rough based on the condition of the rotor blades (scuffed up).

Today we're back to only the side motor-rotor assemblies working. I have the trim controls zeroed, right control stick centered and followed the start-up sequence. Regardless of control positions after the start-up sequence, only the side motors will run. I am getting 0 DC volts to the front and back motors. I get variable voltage at the side motors depending on control stick positions (as expected). I do have continuity between the solder points on all motors and their respective wire-ends at the main harness (so I know there are not any broken wires). All of the pins appear fine on the main wire harness PCB connector.

Any other options besides a bad PCB / PCB component?

rjparth 12-11-2008 11:58 PM

RE: Motor Not Spinning Up - Newbie
 
Just in case someone else stumbles upon this post with the same problem...

I fixed it. The problem was that this used DF had apparently seen its fair share of rough landings (read: crashes). The dome was cracked which should have been my first clue. The rotor blades it came with were chewed up near the motor which should have been my second clue. I found that this happens when the DF flips over and the blades collapse inward on the pinion. Anyway, the problem was that the motor controller IC's on one side had broken solder joints. It seems that one side of the PCB has the controllers for the side motors and the other side has the controllers for the front and back motors. A hard landing on one side apparently took out my front and back motors. I noticed this while probing out the components with a multimeter. Without pressure on the IC's pins I got no reading for ohms, but as soon as I pushed a bit I got the same reading as the other controller chips. I re-soldered them and all 4 motors worked.

Another tip, I have the black "HD motors" on this DF. After conversation with DF support I ordered a set of 4 replacement motors. They tell me that they used to use the black HD motors but found reliability problems.

These things are so simple it's impressive. Even though I don't yet understand the operations (and can't fly one worth crap), it does make a lot of sense. I can't wait to learn how to fly the thing!


All times are GMT -8. The time now is 08:11 AM.