E-Flight Power Sources Ask questions or read about power sources as they specifically relate to e-flight including Lithium-ion, Li-Poly, Nimh and Nicad battery packs.

This Should Be Simple!!!!!!!!!!

Reply

Old 01-01-2012, 04:38 PM
  #1  
slim56
Senior Member
Thread Starter
My Feedback: (4)
 
Join Date: Jun 2002
Location: Mesquite, NV
Posts: 152
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default This Should Be Simple!!!!!!!!!!

I am relatively new to electric powered flight, but I can not get the following to work.

Thunder Power 3 cell 1320mAh battery
E-flilte 20-Amp Brushless ESC
E-flite Park 400 Brushless Moter
JR 6 Channel Micro Receiver (R610UL)
Hitec HB65 Servos
JR 72mHz Transmitter

All of this equipment has been used with success in the past, in a different plane. I use the following setup and start procedure:

Throttle lead of ESC plugged into throttle channel on receiver
Transmitter turned on with throttle stick and trim lever in full OFF position
Battery is plugged into ESC

I get one beep and NOTHING works NO motor NO servo movement (servo does jump when battery is plugged in)
I have tried both a used ESC and a brand new out of the package ESC with the same result
slim56 is offline  
Reply With Quote
Old 01-15-2012, 05:04 AM
  #2  
Glacier Girl
My Feedback: (4)
 
Glacier Girl's Avatar
 
Join Date: Jul 2004
Location: Lakeland, FL
Posts: 7,906
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: This Should Be Simple!!!!!!!!!!

Slim, those esc's are funky sometimes. Check the paperwork that came with em.
You may have to move the throttle stick after you hear the beep to WOT, hold for a moment, then back to off to arm it.

I've got a pair of the 30's that the only way they would arm was to have the throttle WOT when I plugged in the pack, then once the beep was heard, I could move the throttle to off, and then the esc's would arm.
Glacier Girl is offline  
Reply With Quote
Old 01-19-2012, 08:18 AM
  #3  
fmw
Senior Member
 
fmw's Avatar
 
Join Date: Apr 2010
Location: , IN
Posts: 125
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: This Should Be Simple!!!!!!!!!!

You may need to calibrate the ESC.  Unplug the battery.  Remove the prop.  Put the throttle full on.  Plug in the battery.  The ESC should go through some sort of beeping routine and then stop.  Move the throttle stick to off.  Now it should work normally.
fmw is offline  
Reply With Quote
Old 01-19-2012, 06:47 PM
  #4  
slim56
Senior Member
Thread Starter
My Feedback: (4)
 
Join Date: Jun 2002
Location: Mesquite, NV
Posts: 152
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: This Should Be Simple!!!!!!!!!!

Thanks guys.
slim56 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service