E-Flight Power Sources Ask questions or read about power sources as they specifically relate to e-flight including Lithium-ion, Li-Poly, Nimh and Nicad battery packs.

Defective Gens ACE Lipo Batteries

Reply

Old 11-24-2012, 03:44 PM
  #1  
CubClipper
Member
Thread Starter
 
Join Date: Apr 2003
Location: Bristol, TN
Posts: 32
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Defective Gens ACE Lipo Batteries

Fellow RCers’, are your Gens Ace LiPo batteries failing like mine and my fellow clubs member’s Gen Ace LiPo batteries are failing? We have found that over a few months storage on storage voltage or not on storage voltage Gens Ace LiPo batteries are failing. What we are seeing is that the batteries will check ok on a battery checker and will even charge and balance (though it may take more time than usual). Once you put the Gens Ace LiPo battery in your plane it will have enough power to get your plane into the air, but will cause your motor to begin surging. You may even crash your plane. All of my Gens Ace LiPo batteries have failed with limited flight time on them. My fellow club members and I have other brands of LiPo batteries with more time and flights on them and these brands are still working fine. Only our Gens Ace LiPo batteries are failing. I am getting no help from HobbyPartz.com and if I contacted the correct person, no help from Gens Ace. I would like as many of you who are experiencing premature Gens Ace LiPo battery failures to respond to this post. We will let Gens Ace and our fellow RCers' know just how serious this problem is.
CubClipper is offline  
Reply With Quote
Old 11-24-2012, 04:07 PM
  #2  
guver
Senior Member
My Feedback: (325)
 
Join Date: Mar 2003
Location: LaGrange, OH
Posts: 14,857
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries

I bought two packs of "acepow" batts very early on long before they got popular to test. They tested fine and were a good deal. The 2sx4000 pack is ok so far , but the 2sx5000 pack had one cell go 0 volts and a year later the other cell went to 0. Both packs had about 6 cycles or less on them. I wrote them off long before they even got popular.
guver is offline  
Reply With Quote
Old 01-01-2013, 11:41 AM
  #3  
OEMFlyer
Member
 
Join Date: Mar 2004
Location: Rock Falls, IL
Posts: 81
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries

I have at least one Gens Ace 2200mah 25c doing this. I have several more of various mah that I dont know about yet due to flying season being over until spring. Will keep you posted.
OEMFlyer is offline  
Reply With Quote
Old 01-07-2013, 09:27 PM
  #4  
OEMFlyer
Member
 
Join Date: Mar 2004
Location: Rock Falls, IL
Posts: 81
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries

Make that 2 2200 mhr 25c failed!
OEMFlyer is offline  
Reply With Quote
Old 01-18-2013, 01:53 AM
  #5  
siberianhusky
Senior Member
 
siberianhusky's Avatar
 
Join Date: Nov 2009
Location: Peterborough, ON, CANADA
Posts: 611
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries

Yep I had a pair die on me as well, they also don't hold their voltage under load very well, even when new. Tested by me with a datalogger the Gens ace all seemed to average 1 volt less under load compared to TP or Polyquest, Even the cheap Turnigy packs held their voltage better.
I won't buy them again, they don't hold up under the loads I put on them.
siberianhusky is offline  
Reply With Quote
Old 02-06-2013, 11:37 AM
  #6  
JeffH
My Feedback: (43)
 
Join Date: Jan 2002
Location: Carrollton, VA
Posts: 2,281
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries

i had one lose a cell while on storage in a climate controlled garage. The other is still going strong. they both put out good amps and stayed cool considering I was pushing them pretty hard after break-in. I was pulling about 90 amps at takeoff from 4S 4000 25C batteries. I might have 30 cycles since break in.
JeffH is offline  
Reply With Quote
Old 02-14-2013, 08:25 PM
  #7  
pheonixarrison
Junior Member
 
Join Date: May 2011
Location: newburgh, IN
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries



Thesebatteries have chemical inbalance within the packs. I have purchased 8 seperate 4s 4000mah packs and 4 5s packs of the same size. out of the 12 packs only 3 survive after 18 months.these batteries are great when delivered but garbage just as quickly.... any stories are welcome and i will pass them on so no one else gets burned on these low quality packs....


happy flying.



send to Pheonixarrison@yahoo.com

pheonixarrison is offline  
Reply With Quote
Old 04-06-2013, 01:30 PM
  #8  
Flying_Amp
Junior Member
 
Join Date: Sep 2011
Location: Aviemore, UNITED KINGDOM
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Defective Gens ACE Lipo Batteries



Hi

This is exactly what myself and a few friends using Gens Ace found with their packs last year, never abused always storage charged if not being used for longer than a week, and brought down with 3.7-3.8v per cell on 3's 2200 mah. Mine were even charged at no more than 1c, all failed within the year.

Nobody would believe us last year....

Flying_Amp is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service