E-Flight Power Sources Ask questions or read about power sources as they specifically relate to e-flight including Lithium-ion, Li-Poly, Nimh and Nicad battery packs.

Is this cell dead in a tunigy lipo back?

Reply

Old 09-12-2010, 09:22 PM
  #1  
nonstoprc
Thread Starter
My Feedback: (90)
 
nonstoprc's Avatar
 
Join Date: Sep 2003
Location: Central, TX
Posts: 2,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Is this cell dead in a tunigy lipo back?

I have a brand new turnigy 5000mah 5 cell pack that can not be fast charged by the celPro charger. The problem is with one cell whose voltage increases pretty slowly during charging. In fact the celPro charger switches to the slow charging mode. In that mode, the rate of charging is dam slow, almost at about 300mah per hour.


My question is whether the cell is dead. What is the best way to repair the pack?

Thx.
nonstoprc is offline  
Reply With Quote
Old 09-13-2010, 08:49 AM
  #2  
Walt Thyng
My Feedback: (9)
 
Join Date: Jul 2002
Location: St. Charles, IL
Posts: 1,855
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Is this cell dead in a tunigy lipo back?

Maybe, but can you isolate and charge the cell in question? If so try two or three cycles and see what happens. Keep an eye on it though, it could blow.
WT
Walt Thyng is offline  
Reply With Quote
Old 09-19-2010, 01:08 PM
  #3  
nonstoprc
Thread Starter
My Feedback: (90)
 
nonstoprc's Avatar
 
Join Date: Sep 2003
Location: Central, TX
Posts: 2,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Is this cell dead in a tunigy lipo back?

Tried the idea of charging the pack only with cellPro 10s. Looks like the charger charges it fast and fully charge the pack. Will fly with pack today.
nonstoprc is offline  
Reply With Quote
Old 09-19-2010, 04:19 PM
  #4  
patnchris
Senior Member
 
patnchris's Avatar
 
Join Date: Jul 2006
Location: Gurnee, IL
Posts: 1,516
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Is this cell dead in a tunigy lipo back?

I had a pack or two that had a bad solder joint on one of the leads to the balance tap.
patnchris is offline  
Reply With Quote
Old 09-20-2010, 10:25 PM
  #5  
nonstoprc
Thread Starter
My Feedback: (90)
 
nonstoprc's Avatar
 
Join Date: Sep 2003
Location: Central, TX
Posts: 2,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Is this cell dead in a tunigy lipo back?

Flew the plan with the pack and did not notice anything bad. Before recharging, the charger showed normal voltage drop for the cell in question (same as others). The pack was charged to full in fast charging mode.

It looks like the cell probably was low before shipping and thus requires a good charge.
nonstoprc is offline  
Reply With Quote
Old 11-05-2010, 06:04 PM
  #6  
oliveDrab
 
oliveDrab's Avatar
 
Join Date: Feb 2005
Location: Georgetown, KY
Posts: 818
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Is this cell dead in a tunigy lipo back?

Are you using 5S or 10S Turnigy batteries? If so, how's it working out?
oliveDrab is offline  
Reply With Quote
Old 11-05-2010, 08:25 PM
  #7  
nonstoprc
Thread Starter
My Feedback: (90)
 
nonstoprc's Avatar
 
Join Date: Sep 2003
Location: Central, TX
Posts: 2,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Is this cell dead in a tunigy lipo back?

It is a 5cell pack. I did not find problem since.
nonstoprc is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service