Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

Thread: MCX2 Problem


  1. #1

    Join Date
    Feb 2009
    Location
    Woodland, CA
    Posts
    6
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    MCX2 Problem

    Hello,
    Im having a problem with my MCX2 heli....I charged it up this morning and was preparing for a quick flight. When I took off, I noticed That I have no forward and reverse flight..In fact,
    There is no noise or anything coming from the servo's...All I can do is hover, and bank left and right... Any ideas on the part(s) i need to replace?

    Thanks
    Jeff

  2. #2

    Join Date
    Nov 2004
    Location
    Baker City, OR
    Posts
    19
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: MCX2 Problem

    I just had the same thing happen to me the other day. Found out I was bound up with the battery or the canopy because when I moved things around it started working again. Hope that works. Otherwise a new servo, which I would not try to replace, But it can be done . Or a new brick. Hope it does not come to that. Good luck.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 12:56 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.