E-Flite Helicopters Discuss the line of E-Flite mini and micro helis including the Blade CP, CP Pro, Blade CX, etc

MCX2 Problem

Reply
Old 12-26-2010, 05:49 PM
  #1
gonepostal069
Thread Starter
 
Join Date: Feb 2009
Location: Woodland, CA
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default MCX2 Problem

Hello,
Im having a problem with my MCX2 heli....I charged it up this morning and was preparing for a quick flight. When I took off, I noticed That I have no forward and reverse flight..In fact,
There is no noise or anything coming from the servo's...All I can do is hover, and bank left and right... Any ideas on the part(s) i need to replace?

Thanks
Jeff
gonepostal069 is offline  
Reply With Quote
Old 12-26-2010, 09:33 PM
  #2
jcubby
 
Join Date: Nov 2004
Location: Baker City, OR
Posts: 19
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: MCX2 Problem

I just had the same thing happen to me the other day. Found out I was bound up with the battery or the canopy because when I moved things around it started working again. Hope that works. Otherwise a new servo, which I would not try to replace, But it can be done . Or a new brick. Hope it does not come to that. Good luck.
jcubby is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:02 AM.