Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4

  1. #1
    GravityTester's Avatar
    Join Date
    Sep 2003
    Location
    Sabetha , KS
    Posts
    131
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Problem with Blade 120

    I bought a used Blade 120 (first mistake.) I bought brand new batteries for it. However, It struggles to fly at all. It acts like it is tied to the ground. If I get it to lift off the ground at all it is uncontrollable. I have replaced the main blades but that didn't change anything. Any guesses on what could be wrong with it?
    Thanks for the help.
    As a wise man once said.... oh well

  2. #2

    Join Date
    Sep 2010
    Location
    Cassville, WI
    Posts
    13
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Problem with Blade 120

    Are you charging the batteries all the way, if you are using the celectra charger the light has to blink from one end to the other, the reason I ask is because i made that mistake.

  3. #3
    GravityTester's Avatar
    Join Date
    Sep 2003
    Location
    Sabetha , KS
    Posts
    131
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Problem with Blade 120

    Yep I am making sure they are fully charged.
    As a wise man once said.... oh well

  4. #4

    Join Date
    Dec 2006
    Location
    Perrysburg, OH
    Posts
    91
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Problem with Blade 120

    You have given us very little to work with, battery would be my first thought, check to see if 4.2 volts. Have you flown a heli before? Not meant to be offensive just not sure if you are doing it correctly. Did you do a preflight check to be sure servos are working and swash is level when powered up? Have you let the gyro stabalize before trying to fly?
    What radio are you using? More info is needed to help steer you in the right direction...

    Airshot


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 09:08 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.