Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

  1. #1

    Join Date
    Jun 2012
    Location
    CoramNew York
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    BLADE MCPX No POWER!!!! NEED HELP !!!!

    I have my mcpx and I completely lost vertical thrust. I tried increasing pitch, a new 3in1, new motors (tail and main), new main gear, I don't know what I could've done or what happened to do this. I checked all mechanical components. Nothing is bent or broken. I feels like after about 10 seconds in the air the battery is starting to die. Full stick just to hover. I thought it was the batteries first so I got a batch of new ones. All different brands and no change. What do I do now? Could it be one of the servos?????? Please help me I don't know where else to turn to. Thanks!!!!

  2. #2

    RE: BLADE MCPX No POWER!!!! NEED HELP !!!!



    I doubt its a servo, but could be your radio settings as getting positive pitch requires the movement of all 3 cyclic servos...not just one.

    I would check the programming of your radio if you are using a DX6i or higher. If you are using the stock transmitter...I dont know what to tell you as I have never flown my mcpx on the stock DX4e. But maybe a switch is in the wrong position...like Hi-Lo rates?

    Someone with more info may chime in to offer more suggestions IF you are using the stock DX4e.

    SpeedDemon
    ATVAlliance.Com

  3. #3

    Join Date
    Jun 2012
    Location
    CoramNew York
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE MCPX No POWER!!!! NEED HELP !!!!

    I am using a dx6i. I thought that might have been it too. I checked the settings 4 or 5 times. But thanks for the suggestion.

  4. #4

    Join Date
    Jun 2012
    Location
    CoramNew York
    Posts
    20
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE MCPX No POWER!!!! NEED HELP !!!!

    Oh. All the servos and links and all the mechanical/electrical parts Of the heli are visibly good as previously stated.

  5. #5

    Join Date
    May 2006
    Location
    Greenwood, IN
    Posts
    5,237
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE MCPX No POWER!!!! NEED HELP !!!!

    Make sure that the main gear is engaged properly and it's not slipping.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 05:58 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.