Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 21 of 21

  1. #1

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    green light turns red on 4 in 1... help please

    Hi guys, im brand new to this hobby and recently picked up a cx2. Already I have a problem and need any advice that can be given.
    The problem is during flight the green light on my 4 in 1 turns red at mid to full throtle and i loose altitude.

    This happens with fully charged batteries approx 2 mins into flight, sometimes less, actually almost right away at full throtle.

    Does anyone know why its doing this or how it can be fixed?

    Thanks for your help.

  2. #2

    Join Date
    May 2007
    Location
    Las Vegas, NV
    Posts
    278
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    I believe you may have issues with your battery.

    That light is indicating that your battery level is dropping.

    Does your charger give you any error lights when charging? i would take it back to the hobby shop and see about replacement, or contact Horizon Hobby Distro (parent company for Eflite) and let them know of the issue.

    I have had quite a few bad battery's EFLB0990 from them included in the CX2 package. They always replace ours no problem, they should do the same for you.

    hope this helps
    \"Remember this IS a hobby\" - only 40% driving
    This is Savage Country, if you listen closely, you can hear the Revo overheat...

    Owner My RC Supply

  3. #3

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    thanks for the quick response mrrcsupply.

    I have had the cx2 approx 3 weeks, have 2 stock batteries and no charging errors on either pack.
    i followed all the charging instructions.

    the light on the cx2 4 in 1 started going red last night. tried it again today with boths packs. each pack fully charged the light turned from green to red immediately on throttle up past half throttle.

    I did call horizon, the tech said it might be a faulty or damaged esc and thre is no warrranty since warranty only covers if unit was damaged out of the box. once it has been flown the warranty is void.

    will take to my lhs to get batteries tested. i hope th eesc isnt fried.. that could get expensive.


  4. #4

    Join Date
    Oct 2006
    Location
    kunkletown, PA
    Posts
    725
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please


    ORIGINAL: dilettante

    thanks for the quick response mrrcsupply.

    I have had the cx2 approx 3 weeks, have 2 stock batteries and no charging errors on either pack.
    i followed all the charging instructions.

    the light on the cx2 4 in 1 started going red last night. tried it again today with boths packs. each pack fully charged the light turned from green to red immediately on throttle up past half throttle.

    I did call horizon, the tech said it might be a faulty or damaged esc and thre is no warrranty since warranty only covers if unit was damaged out of the box. once it has been flown the warranty is void.

    will take to my lhs to get batteries tested. i hope th eesc isnt fried.. that could get expensive.

    i have the same issue[:@]
    92% of teens have switched to rap music if you are part of the other 8% put this in your sig.

  5. #5

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    did you determine the cause and solution as yet?

  6. #6

    Join Date
    Oct 2006
    Location
    kunkletown, PA
    Posts
    725
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please


    ORIGINAL: dilettante

    did you determine the cause and solution as yet?
    no not yet sorry, replaced the motors with no luck and going to buy some batt packs with my upgrades
    92% of teens have switched to rap music if you are part of the other 8% put this in your sig.

  7. #7

    Join Date
    Mar 2007
    Location
    Friendswood, TX
    Posts
    646
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    I dont think that red light means anything except your at full throttle. My dads BCX has always done it and everyone elses does it at full throttle, I'm pretty sure it just indicates that you are in fact at full throttle. I think you may have a different issue if your losing altitude at full throttle.
    Scott

  8. #8
    bzinfinity's Avatar
    Join Date
    Oct 2006
    Location
    Savannah, GA
    Posts
    872
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    Thats gonna be the 4-n-1.

    About a year ago we went through this same thing when the CX2 first came out with my friend's heli. We put my 4-n-1 on it and it was back to normal.

    With a full pack, if you just can't climb, and you've checked the blades, I can almost guarantee you it's the 4-n-1.
    Doing my part to bailout HobbyTown and HorizonHobby in general.

  9. #9

    Join Date
    Mar 2007
    Location
    Friendswood, TX
    Posts
    646
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    mine wouldnt climb at all, two packs and still no lift, replaced almost everything except the 4 in 1 and guess what the problem was?

    the screws to secure the microheli cnc lower head were too tight and were pinching the inner shaft. This thing has been sidelined for a month or more trying to figure out why I had no lift and all it was were the screws, backed off one half turn and lock-tight into place and it's as good as new.....
    Scott

  10. #10

    Join Date
    Oct 2006
    Location
    kunkletown, PA
    Posts
    725
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    replaced the 4in1 already....it gets lift but not much
    92% of teens have switched to rap music if you are part of the other 8% put this in your sig.

  11. #11

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    i'l check the shafts and the battery charge and the 4 in 1
    hope its an easy fix

    thanks guys

  12. #12
    Balance's Avatar
    Join Date
    May 2007
    Location
    Indianapols, IN
    Posts
    264
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please



    4 in 1 turns to red when the output of the device is at full current draw.



    Loosing altitude is the problem...not the light changing from green to red.

    If you have Power (battery), and new motors. Then either the 4 in 1 is not providing enough
    power to the motors, or it is providing enough power.....and something else is binding and dragging the system down.






    Edited : To fix my bad attitude. [X(]
    As long as you don\'t judge someone as lame, then you can learn from them also.

  13. #13

    Join Date
    Apr 2002
    Location
    Rogers, MN
    Posts
    161
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    Just repeating the previous post,...The red light is perfectly normal. I had the same question a few weeks ago with my 3-in-1

    http://www.rcuniverse.com/forum/m_6128971/tm.htm


    Also, the altitude loss does not sound normal,... I agree with what ^^^ said

    -Taking off is optional, landing is mandatory!

  14. #14

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    ok so brand new battery, throttle trim at zero and throtle stick mid poit ,light turns red. from mid point to full trottle, no gain in motor speeds. no lift, no nothing.

    If the red light means she getting all she can geh, why is she getting all she can get at only half trottle?

    are my motors fried?

  15. #15
    Balance's Avatar
    Join Date
    May 2007
    Location
    Indianapols, IN
    Posts
    264
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    It is possible that the motors are fried, but I doubt they would both go out at the same time.

    You will have to do some trouble shooting.

    You could be loosing lift because of binding or bad shaft bearings or gears.
    That is the cheapest thing to try first.

    Then you need to know if your batteries are fully charged, and or if the
    charger is working. Check the voltage of your battery. If it is close to 4.2volts
    per cell or 8.4v total then it is probably ok.

    If that is ok, then one or both of your servo's could be sucking the current out of
    your 4 in 1 and there ins't enough voltage left for the motors.


    DO THIS AT YOUR OWN RISK>
    If you have enough confidence and you aren't afraid of crashing. You could
    power up like you normally do, then after the gyro sets (green light) then you
    can unplug your servos (make sure you don't move the arms after it centers up)
    throttle up and see if you can get enough lift.
    Remember, you won't have any forward/backward or slide left and right controls.
    <DO THIS AT YOUR OWN RISK

    If you can eliminate these things, then your 4 in 1 is not functioning correctly
    (which a couple of people have already suggested).

    Or if you want to try 2 motors for $22 and that don't work you will have $59 dollars to pay
    for the 4 in 1 and have some spare motors.


    Good Luck !
    As long as you don\'t judge someone as lame, then you can learn from them also.

  16. #16

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    Thanks balance,

    Where can i get 2 motors for 22$?

  17. #17
    Balance's Avatar
    Join Date
    May 2007
    Location
    Indianapols, IN
    Posts
    264
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please


    ORIGINAL: dilettante

    Thanks balance,

    Where can i get 2 motors for 22$?
    That should be going "street" price. That is what they get for them at my LHS and I think you can get them from
    Horizon Hobby for the same price..... $10.99 each.

    And there is a difference if you didn't know. One has the pinion mounted low on the shaft, the other has
    the pinion mounted high on the shaft. Plus the motor leads are reversed.

    As long as you don\'t judge someone as lame, then you can learn from them also.

  18. #18

    Join Date
    May 2007
    Location
    CA
    Posts
    175
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    make sure nothing is bent and nothing is binding or causing friction

    so here's some simple checklist that you can do...

    flybar bent/weight unbalanced
    upper locking collar installed wrong direction
    lower step washer installed wrong/missing
    inner or outer shaft slightly bent
    screw/set screw holding lower blade holder hitting inner shaft causing friction
    bearings bad/dirty causing excessive friction
    check swashplace sleeve bearing for friction
    motor wires not gripping the pins on 4n1 and its loose and check motor wires i found on mine only on strand of wire holding so had to resolder
    battery wire connector not making good contact to battery causing high resistance
    etc..


    let us know what you find out check/recheck before you spend any more..

  19. #19

    Join Date
    Jul 2007
    Location
    richmond hill, ON, CANADA
    Posts
    15
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    thanks for all your help guys, the batteries were not holding a full charge therefore not enough out and causing the problem. relatively easy fix.


  20. #20

    Join Date
    Oct 2006
    Location
    lexington, KY
    Posts
    38
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    NOTE: You can damage LI-Po batteries, if you over discharge them. May cause potential FIRE!

  21. #21
    calvino's Avatar
    Join Date
    Apr 2007
    Location
    Thousand Oaks, CA
    Posts
    8,958
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: green light turns red on 4 in 1... help please

    I have been running into this prob also with my CX, got it off EBAY, to make a long and [sm=sleeping.gif] story short, christmas gift gone bad. With my heli it will run, then the motors will cut out for about 1/2 a second to 2 seconds ([sm=48_48.gif]), also the red light goes on at any time, since I fly indoors, I only use about 1/2 throttle. Seems like the motors are the culprut, that just stinks that you prety much made a new CX. hope things go better for you. calvin
    Axial AX10, \"Irene\" with custom chassis, Thunder Tiger ST-1 [not working]


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 11:45 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.