Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 15 of 15

  1. #1
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    After months of anticipation waiting for this heli, they finally arrived in Perth hobby stores..

    So today I bought the BNFversion for use with my DX6i - I also have an MSR which has over 300 accident free flights.

    Well, after trimming it for a beautiful hands free hover on the first flight, I then had a 2nd and 3rd flight that were perfect - I was enjoying it, it felt like the MSR just more inertia and looks great flying around the house.

    I was getting around7 minutes flight timeper battery charge

    It is very stable, and controllable.

    On the 4th flight, about 2 mins into the flight the helicopter started spinning uncontrollably so I reduced power and it settled reasonably softly on carpet with no damage.

    The Tail motor has failed. - Very disappointing after less than 25 minutes total flying fime.. It is BRAND NEW.

    Here is a Youtube video of the failed tail motor...

    www.youtube.com/watch

    Hopefully this is just bad luck and is not going to be a common problem with these helis...

    ..... frakkin cylons...

  2. #2

    Join Date
    Apr 2010
    Location
    , NY
    Posts
    1,108
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    ive experienced similar things before, try pushing the cap on the back of the motor in, even if you dont feel it move in push it in anyways, then try again. for some strange reason the caps on the motors seem to come loose frequently. i think that they are just buying really cheap motors to keep production costs down. but try that and let us know what happens.

  3. #3
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    Thanks.. Tried it.. no difference - its cool, I'll take it back to the store for an exchange tomorrow
    ..... frakkin cylons...

  4. #4

    Join Date
    Apr 2010
    Location
    , NY
    Posts
    1,108
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    might be a good idea to look around online and find a higher quality motor for the tail. its happened to me a few times now

  5. #5
    wattman's Avatar
    Join Date
    Jun 2004
    Location
    Chandler, IN
    Posts
    115
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    A question to ROB2160

    Owning two of these 120SR helis myself , and both bound to Spektrums DX6i transmitters , and reading your post in horror at a failure so soon ...........................made me want to ask a question ?

    Did you biind / program your 120 SR to your DX6i as a airplane , or as a HELI ?

    ????

  6. #6
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    Hi Wattman,

    I have it bound as an aircraft

    When I first got the MSR I had it bound as a Heli, but then I read somewhere (can't for the life of me remember where) that it should be bound as an aircraft - I did that for the MSR and it is perfect, 300 plus flights and going strong..

    So I just did the same for the 120 SR.

    The Good news is I took it back to the hobby shop today, they replaced the tail motor under warranty and I have now had 7 flights on it.. All is working perfectly...!!

    I also bought a few spare batteries and a spare tail motor $15.. I love flying this thing..
    ..... frakkin cylons...

  7. #7

    Join Date
    Jun 2010
    Location
    Houston, TX
    Posts
    52
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    is it fastt?

  8. #8

    Join Date
    Sep 2008
    Location
    Benin City, Edo StateEdu State, NIGERIA
    Posts
    131
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    The new Blade mSR replacement tail motors have a different cap on than the originals. Iplace a piece of shrink tubing over the cap with a little piece protruding. The caps do not come off then. Try it with the larger motor????????

    A note of warning though...... when you replace a rear rotor blade make sure you hold the cap with one finger securely. The cap popped off when the motor axle moved and pushed it off.
    E-Flite Blade 400 3D, Blade MSR, the (P)ESKY Lama never worked and gave the Kestrel to my Son.

  9. #9
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    I have only flown it around the house so have not had a chance to see how fast it is.

    I will take it to work next week (I'm a real pilot) and fly it in our Hangar 60meters x 60meters with a 30 meter ceiling - Most of the time the hangar is empty - Perfect for flying helis... I'll let you know how fast it goes then..
    ..... frakkin cylons...

  10. #10
    wattman's Avatar
    Join Date
    Jun 2004
    Location
    Chandler, IN
    Posts
    115
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    I am so glad for you that your new heli is working again , Ihave only been able to buy ONE additional battery ............................so far .

    And I am so happy with the 120SR , stepping outside to fly in the side yard , even with some wind blowing , much better than my coaxs by a lot .


  11. #11
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    Thanks Man,

    I"m loving it also.. did about 12 flights today.. each one 6 minutes It really isjust a BIG MSR but looks so cool.. I can't wait to get the RED canopy and tail..

    I was lucky with the batteries.. happened to be in the only shop in Perth that stocked them... 4 batteries is enough to fly continuously.. (I have 2 additional lipo chargers)

    I'll post some video soon of it flying around the house..

    ..... frakkin cylons...

  12. #12
    wattman's Avatar
    Join Date
    Jun 2004
    Location
    Chandler, IN
    Posts
    115
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    It seems so long chargeing on the supplied charger , so I looked at my E-Flite EFLC 505 which I use a lot , and I had never noticed that they charge 1-5 cell lipos , so , with this new 500 mah battery and a JST connector , I set the charger for .9 amps and selected the correct votage , and , now I am recharged in about a half hour after a 7 min flight .
    The 120SR manual states that the battery can be recharged at 1 amp , so I charged at .9 , comfortable for me with only three batts so far .
    And went out and flew both in the side yard a while , great helis .

  13. #13
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight

    Yes, I agree, the supplied charger takes up to an hour.. even on 0.7amp charge

    I have 3 of these (TREX Enecharger)

    www.discounthobbies.com.au/catalog/product_info.php

    They are awesome, show percentage of charge and come with supplied connectors for all types

    Using these 3 chargers setat 0.8amp (takes about 25 mins to fully charge the 120SR Battery after a flight of 6 minutes)

    With 4 Batteries I can fly continuously (over 40 flights now - I've stopped counting - New tail motor is solid as a rock!)

    I love this heli and am going to set up the advance swashplante settings today...

    ..... frakkin cylons...

  14. #14
    ridgewalker's Avatar
    Join Date
    Jan 2007
    Location
    On the go..
    Posts
    482
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight


    ORIGINAL: diabolic-mind

    ive experienced similar things before, try pushing the cap on the back of the motor in, even if you dont feel it move in push it in anyways, then try again. for some strange reason the caps on the motors seem to come loose frequently. i think that they are just buying really cheap motors to keep production costs down. but try that and let us know what happens.

    These tail motors are a bit larger than the msr's.
    And they have a protective cage like structure around it.

    Was the tail motor hot when it failed?Did you measure the temp with a temp gun?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Us55364.jpg 
Views:	16 
Size:	42.7 KB 
ID:	1484552  
    Wheely King,Stampede XL-5,Stampede 4x4,T-Maxx,Revo3.3,jato2.5,T Rex 450,SR 120,SR,mSR

  15. #15
    Rob2160's Avatar
    Join Date
    Jun 2010
    Location
    Sydney, AUSTRALIA
    Posts
    3,997
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: BLADE 120 SR - Tail motor failed on my first day - On the 4th Flight


    ORIGINAL: ridgewalker


    These tail motors are a bit larger than the msr's.
    And they have a protective cage like structure around it.

    Was the tail motor hot when it failed?Did you measure the temp with a temp gun?

    Hi, No I didn't measure the temperature when it failed. I now beleive it was just a dud motor - when I flew the heli with the 2nd tail motor installed it was far more responsive and is rock steady in heading hold.

    I now have over 50 flights on the 120SR and it is going strong.
    ..... frakkin cylons...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 02:40 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.