Electric General Discussion General Discussion forum about rc electric related aircraft, accessories, flight, tips, etc.

Hyperion ZS 4035-12 with ATLAS 90 amp OPTO ESC

Reply
Old 09-09-2012, 06:52 PM
  #1
stealthdragonb
Thread Starter
 
Join Date: Feb 2012
Location: Melbourne, AUSTRALIA
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Hyperion ZS 4035-12 with ATLAS 90 amp OPTO ESC

Hi All I am using a Hyperion ZS 4035-12 motor with a Hyperion Atlas 90 amp OPTO esc with 8S LiPo. Previously I was using a turnigy 100 amp superbrain esc and was achieving a current draw of 60 amps with a 15x10 APC E Prop. However now with the exact same setup but with a ATLAS 90 amps OPTO esc rated up to 12S I can only achieve 40 amps current draw which is really effecting performance particularly rate of climb. I have got the default settings set in the esc with LVC set to 24.5 volts and now have changed Timing from automatic to 20deg and have increased current draw to 47amps which is still short of 60 amps previously achieved. Increasing the timing further causes sudden braking of the motor etc meaning the timing is not suitable if i use 25 or 30 deg. Does anyone know why this ESC is causing this problem, what other settings could I change to achieve a higher current draw then the current 47 amps.
I look forward to any assistance.
stealthdragonb is offline  
Reply With Quote
Old 09-11-2012, 01:11 AM
  #2
stealthdragonb
Thread Starter
 
Join Date: Feb 2012
Location: Melbourne, AUSTRALIA
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Hyperion ZS 4035-12 with ATLAS 90 amp OPTO ESC

I would appreciate anyones helpful advice...
stealthdragonb is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:04 PM.