Electric Training If you are new to electric learn more about them here or ask questions.

LiPo's Not Balancing - Do I Need New?

Reply

Old 01-13-2013, 10:03 AM
  #1  
apwachholz
Thread Starter
 
apwachholz's Avatar
 
Join Date: Oct 2007
Location: Silver Spring
Posts: 413
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default LiPo's Not Balancing - Do I Need New?

Hey All -
Been in electric flight for quite a while but, I'm still a newb' when it comes to lipo pack management and the like. I have an issue that I'm seeking some insight on. I've got two (2) ThunderPower 3-cell LiPo batteries (2600 mAh, 11.1v) that seem to be having an issue balancing. I've had them for 2+ years but not a ton of flights on them (probably less then 35 flights each). I've charged / discharged during storage and do my best to keep them "fresh". The issue I'm having is this:
I plug my balancer into the packs and they never seem to stop blinking / balancing. Even after a solid 16 hours, they're still balancing the cells. I use the Astro Flight Blinky as my balancer and a Great Planes Triton Jr. to charge my packs. Any insights? Thanks!
apwachholz is offline  
Reply With Quote
Old 01-13-2013, 11:22 AM
  #2  
guver
Senior Member
My Feedback: (325)
 
Join Date: Mar 2003
Location: LaGrange, OH
Posts: 14,857
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

The blinky is one of the slowest (lowest current) balancers there are and has no volt reading. It's hard to tell what the state of balance is without a volt reading on each cell , but eventually it "should" balance them perfectly.

If I had those packs I'd check the individual cell volt readings 3 times.

First as soon as I rx them, second after the charge (they should all be exactly equal and about 4.1-4.2 volts) and then finally after the flight to give an idea of cell capacity match.

Without these readings and without having the packs it is anybody's guess , but my best two guesses are that the packs are starting to degrade OR the blinky is on the blink.

You got other packs that are just fine? on the same equipment? May I also suggest a cheap 50 watt charger or a digital balancer for your T-J.
guver is offline  
Reply With Quote
Old 01-14-2013, 09:31 AM
  #3  
BarracudaHockey
My Feedback: (11)
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 23,237
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

I had an Outrage pack that took a day plus to get it balanced. Either leave the blinky plugged in till it goes out, or check some voltages.
BarracudaHockey is offline  
Reply With Quote
Old 01-14-2013, 10:11 AM
  #4  
flyinwalenda
My Feedback: (5)
 
flyinwalenda's Avatar
 
Join Date: Oct 2009
Location: Northeast, PA
Posts: 3,975
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

It could be one cell is starting to go south. I have some old TP 2100 3 cells and a few of them started taking longer to balance. I have a better charger/balancer and right away the display showed one cell was off. Those still continue to work OK and still take a long time to balance and eventually will be retired.
As stated, if you are going to stay with electrics get a decent 50w charger. It's the next step-up charger with a display, good balance circuit , and preset options to charge and maintain the packs.
Here are a few choices:
www.valuehobby.com/power-systems/chargers.html (first three)

www.leaderhobby.com/product.asp

www.venom-group.com/Venom-Pro-Charger-w-Power-Supply-US.html

flyinwalenda is offline  
Reply With Quote
Old 01-14-2013, 12:16 PM
  #5  
apwachholz
Thread Starter
 
apwachholz's Avatar
 
Join Date: Oct 2007
Location: Silver Spring
Posts: 413
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

@guver
I've been successfully charging all my lipo's with the same gear for years. I have a few other 2/3 cell packs that are doing just fine. but, I wonder if I just need to upgrade the gear altogether. It would save me in the long run.
@Barracuda
Yup, doing that now. I'm hoping to see no blinking lights when I get home this evening. Fingers X'd.
@flyinwalenda
Wow, I had no idea chargers were so cheap. The ones I was being pointed to before were well north of the $100 mark. This helps a lot especially since I'm realizing I need to make an investment in better gear for both my Rx and Tx batteries.

Soooooo, next question.... what, if any, are comparable LiPo's to ThunderPower? I've used them for years (and they're great) but, I'm sure there are cheaper comparable quality out there. Or is there?
apwachholz is offline  
Reply With Quote
Old 01-14-2013, 02:41 PM
  #6  
flyinwalenda
My Feedback: (5)
 
flyinwalenda's Avatar
 
Join Date: Oct 2009
Location: Northeast, PA
Posts: 3,975
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

Forgot to mention if you don't have a problem with used equipment you can look for an older Cellpro 4 charger. I have a few of these and they are a simple to use lipo charger and they do a great job of charging, storing, and maintaining lipo packs. You can usually pick them up for around $25-35.00 and they will only charge 2,3 and 4 cell lipo packs.



I have used Gens Ace lipos from Hobbypartz and G-Force lipos from Value Hobby. Both are very good in my opinion and when I order more it will be the G-Force from Value Hobby.
flyinwalenda is offline  
Reply With Quote
Old 01-14-2013, 08:48 PM
  #7  
blvdbuzzard
 
Join Date: Jun 2002
Location: high deserts, CA
Posts: 3,701
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

I have (4) of these and they have been good for me.

http://www.hobbypartz.com/60p-dyc-1004.html

Same charger with a laptop power supply inside the aluminum case.

http://www.hobbypartz.com/60p-dyc-10...rger-blue.html

Buzz.
blvdbuzzard is offline  
Reply With Quote
Old 01-15-2013, 10:12 AM
  #8  
apwachholz
Thread Starter
 
apwachholz's Avatar
 
Join Date: Oct 2007
Location: Silver Spring
Posts: 413
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: LiPo's Not Balancing - Do I Need New?

@all
Thanks for the advice and assistance!It looks like my batteries are going out since we're still blinking. I tried to let it sit to balance, then charged it (with the balancer connected), and am now letting it sit again, and we're still blinking. Bummer. Based on some of the LiPo costs you are all sending my way it might be in my best interests to re-invest in some new LiPo's. I just have to be careful on physical size because my current LiPo's fit perfectly into my Great Planes Siren so unfortunately, size IS an issue for the replacement packs. I'll figure it out regardless. OH, and thanks for the heads up on the chargers - that's on the to-do/wish list now.
As far as an at-the-field voltage checker, does anyone have recommendations? I've heard something as simple as the Integy C23212 LiPo Voltage Checker/Warning Buzzer works well. Thoughts?
apwachholz is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service