Go Back  RCU Forums > RC Helicopters > Electric RC Helis > Esky Helicopters
Reload this Page >

Belt CP V2 lifts off then lands at maximum throttle...

Esky Helicopters Discuss the line of Esky electric helis in here including the Honey Bee, Lama, Belt CP, etc

Belt CP V2 lifts off then lands at maximum throttle...

Reply

Old 01-27-2010, 12:34 AM
  #1  
sorka
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Merced, CA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Belt CP V2 lifts off then lands at maximum throttle...

Got new Belt CP V2. Charged battery. Attempted to check tracking, but motor wouldn't turn over. Only klinked and jerked. Checked belt tension which seemed fine and not too tight. However, I loosened it anyways to the point where you can push the belt in where you check the tension all the way to the other side so the inner belt teeth are touch the inner belt teeth on the other side.

At this point, it would turn over, but only at about 80% throttle. Anything before that just results in klinks and jerks.

Items checked:

Battery Voltage 12.6 volts.
Pitch +9 degrees in normal mode throttle all the way up trim all the way down with motor disconnected.
Tracking. Minor adjustment and it was perfect.
Swash plate level.

Rotor assembly turns easily but I don't have another one just like it to compare.

Also, when I power up and bind, most of the time there are no beeps yet the controll does bind and the controls work. Sometimes I get one beep. Occasionlly I get two. And rarely, only twice, I got 3 beeps a high, low, and high beep.

When I spool up, it klinks and jerks until I hit about 80% throttle and then it violiently spins up rotating the entire heli in the oposite direciton about 180 degrees. I can somwhat mitigate this by anticipating it as it jumps and lower the throttle to about 30%.

At this point, it takes about 80% throttle to lift off and 100% to get it above 3 or 4 feet where it escapes ground effects. However, at this point, even with 100% throttle, it just settles right back down the ground.


By comparison, I flew a new Eagle 50 the next day and it is a rocket. Takes off at about 30% throttle. Much higher RPM than the Belt was.

At this point, the only thing I can think is that either the ESC or motor is bad. The fact that I rarely get the 3 beeps might be a clue.

However, a meter shows 0.5 Ohms between any 2 of the 3 wires, so it doesn't seem to be a damaged coil.

The ESC shows 32 K Ohms between any 3 wires.
sorka is offline  
Reply With Quote
Old 01-27-2010, 08:58 AM
  #2  
icjefferys
Junior Member
 
Join Date: Nov 2005
Location: Towson, MD
Posts: 26
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

From my 1 week so far of Belt CP experience, the beeps only come when the ESC is hooked up, so no or not enough beeps may indicate a bad ESC connection or a bad ESC. I think you can discount belt tightness as a cause. I don't know anything about Ohms!
icjefferys is offline  
Reply With Quote
Old 01-27-2010, 09:14 AM
  #3  
barak1001
Senior Member
 
Join Date: Feb 2009
Location: Hanceville, AL
Posts: 474
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

It's sounds like one of the wires on your ESC has a bad solder joint or a break in the wire.
barak1001 is offline  
Reply With Quote
Old 01-27-2010, 12:25 PM
  #4  
Disney1
 
Disney1's Avatar
 
Join Date: Nov 2007
Location: Orlando, FL
Posts: 1,499
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

It could be a defective ESC the Esky ESC is notorious for catching fire in mid flight.

Poof Roasted Belt CP

This is what I use: https://www.ushobbysupply.com/produc...roducts_id=425
Disney1 is offline  
Reply With Quote
Old 01-27-2010, 01:47 PM
  #5  
sorka
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Merced, CA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

Xheli has RMAed the motor and the ESC. I removed the 4 screws that hold the motor plate in but can't get the darn thing out. I don't want to force it.

Anyone know the proper procedure for prying it out?
sorka is offline  
Reply With Quote
Old 01-31-2010, 07:58 PM
  #6  
choppersrule
Senior Member
 
Join Date: May 2006
Location: Greenwood, IN
Posts: 5,237
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

Sorka,

I don't have a Belt CP, however, some of the 450 size helis, their motor mount has two small tabs, that slip into the frame, one on each side. You may have to loosen or even remove some of the frame screws in the motor mount area, to get the motor mount removed.

Dave
ORIGINAL: sorka

Xheli has RMAed the motor and the ESC. I removed the 4 screws that hold the motor plate in but can't get the darn thing out. I don't want to force it.

Anyone know the proper procedure for prying it out?
choppersrule is offline  
Reply With Quote
Old 01-31-2010, 08:04 PM
  #7  
sorka
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Merced, CA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

Actually, just gently pulling on the halves seperated about a mm and the whole thing just slid out.

Turns out it was the ESC. When I had the motor out, I decided to see what it would do when not driving rotor assembly. Again, it took about 80%throttle to get it spinning. Up to that point, the motor would klink. Once it started spinning it would alternate between really high RPM, really low RPM, and something inbetween where it jerked violently. At this point the ESC smoked, popped, and then caught fire.
sorka is offline  
Reply With Quote
Old 01-31-2010, 08:13 PM
  #8  
choppersrule
Senior Member
 
Join Date: May 2006
Location: Greenwood, IN
Posts: 5,237
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

Sorka,
Glad ya got the motor mount removed. Sorry about the ESC catching fire, on the plus side it will be replace by Xheli and it didn't happen in flight where a lot more damage may have occurred.
Dave
choppersrule is offline  
Reply With Quote
Old 01-31-2010, 08:42 PM
  #9  
Disney1
 
Disney1's Avatar
 
Join Date: Nov 2007
Location: Orlando, FL
Posts: 1,499
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

I think I said this earlier.
Poof Fried Heli.
Normal for the Esky ESC
Your replacement will probably also be a Esky ESC same fire hazard.
Disney1 is offline  
Reply With Quote
Old 02-01-2010, 05:57 PM
  #10  
46u
Senior Member
My Feedback: (3)
 
46u's Avatar
 
Join Date: Jan 2005
Location: Macon, GA
Posts: 22,095
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

First thing I did with my V1 was replace the ESC before I ever put power to it do to all I read about them. I could not even get $5 for my stock one on eBay.[X(] I am running the Hobby Wing 30amp.
46u is offline  
Reply With Quote
Old 02-01-2010, 06:44 PM
  #11  
Kelownan
Senior Member
My Feedback: (1)
 
Join Date: Feb 2008
Location: Nelson, NEW ZEALAND
Posts: 306
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

man that sounds alot like the issues i had with a brand new brushless motor for my King2 it would make sounds like an old dialup modem. and i had a 30amp tower pro esc onboard.

Mike at USHobby supply replaced the motor and my problems went away.

so yeah if you have the money a castle creations or hobbywing ESC is good, i have also tried out the Storm30amp ESC.
(the one that comes with the Storm450 at "helipal" i think)

its 3times cooler running than my tower pro and has way more features, the price is also a winner. its worth checking out.
Kelownan is offline  
Reply With Quote
Old 02-02-2010, 04:20 AM
  #12  
Navy_1
Senior Member
 
Navy_1's Avatar
 
Join Date: Dec 2007
Location: Jacksonville, Fl
Posts: 230
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Belt CP V2 lifts off then lands at maximum throttle...

i use the DYS 30A it runs my great. the ESC is a big issue

https://www.ushobbysupply.com/produc...oducts_id=1014




Belt-CP V1 - DYS-30A ESC - Telebee V2 DX7
Navy_1 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service