Exceed RC Support - Helicopter Discuss all Helicopter Support for items purchased or will be purchasing at Exceed RC.

zero throttle but blades are still spinning...

Reply
Old 03-29-2008, 04:21 PM
  #1
rftusa2008
Thread Starter
 
Join Date: Mar 2008
Location: pinole, CA
Posts: 136
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default zero throttle but blades are still spinning...

Trim #2 is way down already. Turning trim # 2 up will increas the speed at zero throttle. Can anyone let me know what's wrong. On the transmitter that came with the heli, the throttle zero setting is resting between 1st and 2nd notch level. It cannot go down any further. Thanks for any help.
rftusa2008 is offline  
Reply With Quote
Old 04-02-2008, 05:44 PM
  #2
yadac123
 
Join Date: Sep 2005
Location: , CA
Posts: 1,484
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: zero throttle but blades are still spinning...

sorry I don't understand your question. what's your heli?

Andy
yadac123 is offline  
Reply With Quote
Old 01-23-2013, 09:51 AM
  #3
charlie61
 
Join Date: Jan 2013
Location: westlake, LA
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: zero throttle but blades are still spinning...

same issue falcon40v2 2.4 . as soon as i plug the battery in main blade starts spinning. tx iis set to zero throttle. yes i did have a crash an snaped a main blade. should i change the motor(esc is mounted on the motor)  or would it be in my receiver. thanks
charlie61 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:39 PM.