Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 9 of 9

  1. #1

    Join Date
    May 2008
    Location
    Fayetteville, GA
    Posts
    17
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Need help with tail rotor

    I'm new to the raptor g2 but have flown fixed pitch for training in the past. I got my g2 last week and have been reading several post about the tail rotor/rudder servo, etc..
    I was able to over come several issues by adjusting the dip switches on the back of the tx to Andy's suggestion and adjusting the gyro sensitivity using dip switch 12.
    Now here's my current issue, the tail rotor servo glitches/moves (not sure how to explain) with no input from the tx. You can hear it continuously working. Even when trying to hover, the tail makes short left/right glitchy movements.

    Any suggestions?

    Thanks

  2. #2

    Join Date
    Sep 2005
    Location
    , CA
    Posts
    1,484
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    is the tail servo hot to and warm to the touch? your servo might be stripped internally. Put another servo to the gyro and check and see if you can get the same problem.

    Andy
    Andy - Official Exceed RC Support Forum Host

  3. #3

    Join Date
    May 2008
    Location
    Fayetteville, GA
    Posts
    17
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    Thanks for replying Andy. No heat on the servo. I experience the glitchy noise and tail movement all the time except when the TX is off. This is a new heli, is this issue common? I'll need to get a replacement servo.

    Thanks for the advice.

  4. #4

    Join Date
    May 2008
    Location
    Fayetteville, GA
    Posts
    17
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    It seems that my problem is the gyro and not the servo. I disconnected the cables from the gyro and rx (right ctrl stick), swapped servos and the problem was now with swash plate control. The tail rotor servo was fine. Swapped them back and the problem reoccurred. Could the gyro problem be sensitivity? I noticed holding it in my hand and turning the tail left and right activates tail rotor movement. But when at rest I can still hear the servo and see it making very short movements. I'm hoping sensitivity adjustments can help. Can anyone respond with the correct settings?

    Again, Thanks for the help!


    Great forum.



  5. #5

    Join Date
    Sep 2005
    Location
    , CA
    Posts
    1,484
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    ok while the tail servo is twitching is the red light on gyro solid red?

    Andy
    Andy - Official Exceed RC Support Forum Host

  6. #6

    Join Date
    May 2008
    Location
    Fayetteville, GA
    Posts
    17
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    Hi Andy, the gyro comes on with the initialization and then goes off after about 6 second. At this point you can hear the twitching of the servo.

  7. #7

    Join Date
    Sep 2005
    Location
    , CA
    Posts
    1,484
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    if the light goes off please put the gyro back to HH mode. put dip #12 ON and put left dial to 3 oclock.

    Andy
    Andy - Official Exceed RC Support Forum Host

  8. #8

    Join Date
    Jan 2009
    Location
    CARRET, VA
    Posts
    1
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    I HAVE THE EXCEED G2 AND THE TAIL ROTTER WONT ROTATE POSITION SO THAT I CAN LIFT IT TO FLY IT.ITS SPINNING FINE AND I CANT FIND ANYTHING THAT COULD CAUSE THE PROBLEM.I HAVE NEVER FLOWN IT YET JUST GOT IT. IT DID MAKE A LOW NOISE IN THE SERVO ONCE BUT IT STOPPED.ARE THERE ANY ADJUSTMENTS THAT I CAN MAKE OR ANYWHERE I CAN TAKE IT TO B LOOKED AT? OR SHOULD I JUST TRY TO FIND A NEW SERVO?

  9. #9

    Join Date
    Sep 2005
    Location
    , CA
    Posts
    1,484
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Need help with tail rotor

    check your belt and make sure the tension on it is good.

    Andy
    Andy - Official Exceed RC Support Forum Host


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:18 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.