Exceed RC Support - Helicopter Discuss all Helicopter Support for items purchased or will be purchasing at Exceed RC.

Spinning Issue

Reply
Old 08-13-2009, 09:28 PM
  #1
jjcrane
Thread Starter
 
Join Date: Jul 2009
Location: , NY
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Spinning Issue

My Exceed RCG2 now doesn't appear to have enough tail rotor speed.

It will spin up, but Idon't think it spins fast enough. The heli spins before even taking off, and Inotice the tail blades slow down when Iwind up the motor.

If Imanually move either the tail rotor or the main rotor the corresponding blade will sping just fine. But if Ihold the main rotor Ican spin the tail rotor pretty easily (little resistance). I'm thinking either my belt or the gear for the belt is stripped. What's the easiest way to get at the gear?I took apart the tail part and that gear looks fine. What kit has the gear replacement? 50H08-26 Gear Set?

Thanks for any help.





jjcrane is offline  
Reply With Quote
Old 08-14-2009, 04:48 PM
  #2
yadac123
 
Join Date: Sep 2005
Location: , CA
Posts: 1,484
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

You are on the right track on this one. To check if 50H08-26 Gear Set is bad, simply hold the tail rotor tight with right hand and try to spin the main gear clockwise with left hand. Is there a locked? There should be a lock because your tail rotor is held tight with right hand. If there is no lock then please replace 50H08-26 Gear Set.

To replace this is easy if you have someone to help you. Remove all screw on the frame from the tail boom area up to the center. The you can kindly split the frame half way and have someone hold on to it. You reach in and quickly change the gear. Make sure the belt orientation doesn't change.

Andy
yadac123 is offline  
Reply With Quote
Old 08-15-2009, 03:40 PM
  #3
jjcrane
Thread Starter
 
Join Date: Jul 2009
Location: , NY
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

Helpful, thanks!
jjcrane is offline  
Reply With Quote
Old 08-19-2009, 02:24 PM
  #4
yadac123
 
Join Date: Sep 2005
Location: , CA
Posts: 1,484
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

NP

Andy
yadac123 is offline  
Reply With Quote
Old 08-22-2009, 05:33 PM
  #5
jjcrane
Thread Starter
 
Join Date: Jul 2009
Location: , NY
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

Yadac-

So Irepaced the gear set ok.... now i've noticed my control is inverted.... when i move the left stick right the front of the heli moves left..... i've also noticed that i have less control over the tail - it moves around a lot more.

Suggestions?
jjcrane is offline  
Reply With Quote
Old 08-27-2009, 11:52 AM
  #6
yadac123
 
Join Date: Sep 2005
Location: , CA
Posts: 1,484
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

Yea you have installed the tail servo int he wrong direction. Remove it and turn it 180 degree and reinstall it.

Andy
yadac123 is offline  
Reply With Quote
Old 08-28-2009, 07:48 AM
  #7
jjcrane
Thread Starter
 
Join Date: Jul 2009
Location: , NY
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

Thanks,

No idea how Imessed up the servo, as Inever removed or altered it from the tailboom. So Ireadjusted the servo arm so that it throws in the other direction. Now the arm points down instead of up. The heli flies fine again, but there seems to be a little more stress on the cable ... not enough to cause any problems Ithink.


I tried to figure out how Icould keep the arm orientation pointing up and have it throw in the other direction, and after a few beers gave up and just flipped it.

Thanks Andy!
jjcrane is offline  
Reply With Quote
Old 09-04-2009, 11:55 AM
  #8
yadac123
 
Join Date: Sep 2005
Location: , CA
Posts: 1,484
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Spinning Issue

no problem.

Andy
yadac123 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:31 AM.