Extreme Speed Prop Planes Discuss the need for speed with fast prop planes (Screamin Demon, Diamond Dust, Shrikes or any REAL sound breakin'''' plane)

Neddles settings on West 50 engine?

Reply

Old 09-19-2004, 10:53 PM
  #1  
Isaac F
Senior Member
Thread Starter
 
Isaac F's Avatar
 
Join Date: Dec 2001
Location: Panama Republic. of Panama , PANAMA
Posts: 387
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Neddles settings on West 50 engine?

Guys, I am on my second MagnumR with West 50 engine. First one got FUBAR[]

Using 10% fuel my main neddle is around 1 turn, the low neddle is around 2 3/4 turns.
The engine is idleling perfect, transition to hi is perfect.................My problem is that when I close the throttle barrel to shut off the engine, is does not want to turn off[&o]

The O ring under the carburator is compresed very tight between the carburator and the engine.
all the head and back cover screws are tight, so I dont know what else to do.

I have 3 other Webras 50GT Speed and I have adjust the low neddle and those engines are performing OK.

My first West 50 engine was adjusted the same way and perfome AWESOME.

One thing that I think is strange is that all my webras 50 low needle was 2 turns set from factory and I just close 1/4 to adjust the transition from low to hi. Do the west 50 low neddles is 3 turns from factory????

Another thing that I found is that the low neddle screw on this second west 50 is very soft to move. I check it and the vibration does not move the set up but could it be possible that the engine is getting air thru that low neddle screw????? I was thinking to take it out and put some teflon tape around the low neddle screw.......... What you think???

This engine is almost NEW. Less than a gallon[X(]

THX,

Isaac
Isaac F is offline  
Reply With Quote
Old 09-20-2004, 01:30 PM
  #2  
siclick33
 
Join Date: Dec 2003
Location: York, UNITED KINGDOM
Posts: 3,707
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Neddles settings on West 50 engine?

If you haven't seen it already, have a look at this thread

http://www.rcuniverse.com/forum/Magn...2109920/tm.htm

The engine not cutting is normal. I can't help as I've left the low needle at the factory setting and haven't had a chance to play with it much.
siclick33 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service