Forum questions or problems Post any questions about how to use the forum or any bugs/problems you may be having in this forum.

hpi savage xl throttle problems

Reply

Old 09-10-2013, 04:44 PM
  #1  
sirtanner
Junior Member
Thread Starter
 
Join Date: Sep 2013
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default hpi savage xl throttle problems

Hello,
Recently I got a used hpi savage xl with a k5.9 engine. The prior owner told me that he did every thing needed i.e. breaking the motor in. I ran about a tank worth of fuel through it and I started to notice a problem. When I hit the throttle on the transmitter the truck would not immediately speed up, when I noticed this I took the shell off and checked the servo. The servo it self would pause before it would extend. However when I would apply the brake the servo wouldn't lag the steering servo also did not seem to have any problems, so I don't think that the batteries in either the transmitter or the receiver. Another thing that seems to be a problem is that occasionally the truck's motor would just stop for no reason, is this just a normal problem or is it something I'm doing or what?

Thank you for your suggestions/responses!


Last edited by sirtanner; 09-10-2013 at 06:29 PM.
sirtanner is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service