RCU Forums

RCU Forums (http://www.rcuniverse.com/forum/)
-   Futaba Radios Direct support forum (http://www.rcuniverse.com/forum/futaba-radios-direct-support-forum-125/)
-   -   12FG failed v1.6 firmware update (http://www.rcuniverse.com/forum/futaba-radios-direct-support-forum-125/7736346-12fg-failed-v1-6-firmware-update.html)

davebnz 07-16-2008 04:37 AM

12FG failed v1.6 firmware update
 
Hi guys,

I recently upgraded my 12FG from v1.3 to v1.5 of the firmware, all worked fine, no problem.

Last week I noticed v1.6 out, so went about the same procedure (as listed in the read me notes that came with it) to upgrade to this release.

After 10min or so, the progress bar on the 12FG display during the update had moved around 1/4 of the way across, after an hour, no further progress. Here I'm thinking it has crashed/hung. What to do ? Oh and yes the battery was fully charged prior to the upgrade attempt, naturally.

Powered off and now will not power up. Display has nothing. No lights (T6 and T5), no beeps. I suspect we now have a radio with no OS and no way to recover from this?

So with out it operating in a user sense, is it possible to perform a factory reset to defaults to bring back to life (like is there a v1 in hardware that is not over written with updates to fall back to ) ?

Or is there a way to invoke a forced software update other than going through the menus (since these are not accessible)

Is there a hard reset to factory defaults, something that will bring this back to life ?

Or am I packing this up for a visit to a repair centre ? I'd rather not given geographically, I'm a long way from any Futaba service centre that would have the abilty to flash this unit in a means not available to us end users.


I thought having a radio that small bugs and some incremental updates for improvements was a great idea, now I'm not so sure.

Any advice or thoughts greatly appreciated :-)

Many thanks


David


skorp_jon 07-16-2008 06:36 PM

RE: 12FG failed v1.6 firmware update
 
It happened exactly the same to me. My 12FG failed to update from 1.3 to 1.5 . I have send it to futaba service. And after 2 weeks i got it back.
They flashed it for free.

Bax 07-17-2008 02:09 PM

RE: 12FG failed v1.6 firmware update
 
If you can get a memory card with the previous software on it, flip the update switch in the transmitter to the update position, and then power it on, you should be able to get it to go, unless there's a problem in the power supply section of the transmitter. That would require you to send it to your regional service center.

davebnz 07-18-2008 06:36 AM

RE: 12FG failed v1.6 firmware update
 
Thank you Bill for the info :-)

To answer your questions. No, I have no way to format another card (no one else around here with a 12FG), so I am unable to try this.

Appears to be a very limited number of these failures in the field from flashing a firmware update gone wrong, so not really a design flaw or bug we hope ! If it helps, the brand of SD card used was a SanDisk 512MB, that has, and still is, working fine in a camera.

So question here - if the firmware is not loaded or corrupted within the TX, as what appears it be in this case (power is in there, as the LED on the FASST module flashes for a short period), and you have a card with a firmware image on it, will the TX try an automatic reload without any user intervention other than flicking the switch for upload mode ? The TX has this level of recovery smarts ?

Just a grumble I have - a design flaw especially in situations like this. The down side of Futaba using a proprietary format for the media card rather than say FAT16 or FAT32 (like all the digi camera's do). Also means you need a Windoze PC, instantly cutting off people that use a version of Win not supported, Linux users and all the Mac OS X people, just to facilitate moving the file to the card using the supplied special application. Also means Futaba have to keep that application up to date and working with all the variations of Win etc. Development cost better put into the radio :-)

Cheers

David

lesterpk 07-18-2008 10:09 PM

RE: 12FG failed v1.6 firmware update
 
Dave, I'm in NZ too and have an early version 12FG with 1.1 software. If you can point me to somewhere I can download say 1.3 or so I can send you a card with it on.
Les.

davebnz 07-19-2008 04:56 AM

RE: 12FG failed v1.6 firmware update
 
Hi Lester,

A life saver ! Thank you, this is what makes the people in this hobby so special and these forums so good.

I've sent you an email with my details, and v1.5 location.

Let's give this a go, be interesting to see if a failed upload can be recovered in the field.

Many thanks

David

davebnz 07-22-2008 06:13 AM

RE: 12FG failed v1.6 firmware update
 
Hi Bill

Was fortunate enough to have Les send me a card with v1.5 on it ready, tried what you suggested, powers on with the T5 and T6 LEDs on solid. No change, nothing. Left it like this for 30min (nothing on display so no option to choose for Update yes or no). Power off, flicked switch off update mode, powered on, nothing.

Looks like a trip around the world for my 12FG just to get flashed. Crazy.



All times are GMT -8. The time now is 03:37 PM.