Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Page 3 of 3 FirstFirst 123
Results 51 to 55 of 55

  1. #51
    Lifer's Avatar
    Join Date
    Aug 2008
    Location
    Kansas City, MO
    Posts
    2,499
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCG 20cc question...

    You will like the TF P-47! Good flyer, and good landing qualities. I did shim the rear retract mounts for a grass runway. About 3/32nds fixed any nose-over issues. With a DLE 20 and a Xoar 16x8, it really moves fast.
    AMA #77967/CD/LM

  2. #52

    Join Date
    Nov 2002
    Location
    Lahaina, HI
    Posts
    1,536
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCG 20cc question...

    Hi Guys...
    I have an update on my RGC 20 powered Ugly Stick.

    Now with over 55 flights, I had a DuBro anti-vibration engine mount brake. It was the right hand side that broke and it broke while in the air. Out of nowhere, my engine would not idle properly...and even at full down trim on Tx, it would still run. So I landed and using a engine kill with my Tx, got the engine stopped.

    I took a look at the model, and the only issue was a cracked right side engine mount...and with the model engine moving forward...changed the idle on this model.

    I was puzzled at why it cracked and broke, for I've used three other DuBro anti vibration engine mounts on three other engines...without any problems. It cracked at the aft engine mounting hole, on the right side...only. So I had only one mount holding the engine on the airframe...lucky me it didn't come loose altogether.

    I contacted Tower Hobbies, and they informed me that I needed to contact DuBro directly...and I did. I sent DuBro several pictures of the crack, on and off the model. They called me the day after they received the e-mail, and sent me a new right side anti vibration 1.20 size engine mount, with all bushings and inserts. I received the parts one week after their phone call...and I finished the instilation today.

    Thank you DuBro.

    Now...what could have created the failure....? I've used these engine mounts for years and I never had one crack...not even with a complete wipe-out. Soooo...when I reinstalled the new engine mount...I made sure I over drilled the holes .01 so the engine mounting screws would not bind. After installing the engine mounting screws, the main fire wall mounting screws would not line up well on the lower right side. So I loosened up the right side engine mounting screws, lined up the fire wall mounting screws-got it to go in and then secured all hardware. I feel I have a small bind on the right side aft engine mounting bolt. If it cracks there again, I will know what caused it to crack.

    My DLE RPM guage went south on me, so I replaced it with a new unit. I wonder what caused it to go bad...and only the last two digits would light up, with the first two going dark. Has anyone else had problems with their digital on-board electronic tacks ?

    My engine is dialed in and works like a charm.


    Soft Landings Always,
    Bobby of Maui
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Db86234.jpg 
Views:	9 
Size:	109.4 KB 
ID:	1820381   Click image for larger version. 

Name:	Us52533.jpg 
Views:	9 
Size:	99.0 KB 
ID:	1820382  
    AMA 15016
    Hellcat Brotherhood #21
    P-38 Brotherhood #51
    Say what you mean, mean what you say...and !#$& it if you can\'\'t take a joke.

  3. #53

    Join Date
    Aug 2008
    Location
    Waterford, Mi/Citrus Springs, Fl
    Posts
    2,551
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCG 20cc question...

    Thanks for the update Bob, and welcome to the vibration problems associated with gas! They'll give you new appreciation for thorough pre-flights!

    Glad you caught it prior to it becoming a bigger issue? Like one that might have been cowled in?

  4. #54
    acerc's Avatar
    Join Date
    Sep 2006
    Location
    Lithia, Fl
    Posts
    5,652
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCG 20cc question...

    I have seen several of those aluminum mount's break just like in your photo. I don't think the aluminum can stand up to the gas engine's. Just my opinion so please don't start a why they are great war.
    Robert
    Cub Brotherhood #3\\ Ryan STA Brotherhood #4
    Corsair Brotherhood #56\\ Waco Brotherhood #184

  5. #55

    RE: RCG 20cc question...

    It most likely cracked because the aluminum beam is tapered. When the bolt is tighten against the mount the head is on an angle. pulling the bolt on an angle. Like splitting wood. I would drill out the tapped holes in the engine, thendrill and tap the engine mount. Bolt the engine in from the top. This should fix the problem.
    Gregg P

    BP Hobbies


Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:03 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.