Helimax This is for all your Helimax questions and comments.

Heli-Max AXE CP burnt eboard, receiver???

Reply
Old 03-20-2012, 11:12 AM
  #1
LeoGig
Thread Starter
 
Join Date: Jun 2010
Location: Tionesta, PA
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Heli-Max AXE CP burnt eboard, receiver???

Hi all. Newbie here with a question. I picked up a Helimax Axe CPhmx used recently (pretty cheap). It ran good at first untill I decided to upgrade to a lipo battery (I was born with a bad case of tinkeritis). Anyways, I didn't realize that I had soldered the battery plug on backwards, and when I plugged the battery in I fried the E-board. :0( So I have since gotten another eboard, and now it blinks green and then turns a solid green, but I get no response at all from the TX. I'm wondering if I might have also fried the receiver, or if there is something else wrong. Any help would be greatly appreciated.
Thanks in advanced

Leo
LeoGig is offline  
Reply With Quote
Old 08-28-2014, 06:50 PM
  #2
dav2slave
 
Join Date: Aug 2014
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

i bought a new e-board and cant hook up to transmitter
dav2slave is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:54 PM.