Helimax This is for all your Helimax questions and comments.

100 CP Rudder input cuases heli to Drift

Reply
Old 02-14-2013, 02:20 PM
  #1
android44
Thread Starter
 
Join Date: Dec 2005
Location: avon, OH
Posts: 43
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default 100 CP Rudder input cuases heli to Drift

Hi,
I have a couple week old 100CP. I am using a Futab 9C to control it.

It hovers great, but I notice when I give rudder input, the heli drifts pretty agressivly off axis. depending on the direction of the rudder input, the drift is either forward or backwards. And its not just a slow drift, it almost puts it in forward or backward flight.

This drift is making it difficult to do anything but hover.

I have tried multiple gyro gain settings (20, 30, 40, 50% etc....) but it did not help.

I called Helimax, and they could not pin point the problem but are going to try replacing the board.

Has anyone else out there had this issue? If so, was it the board or was there another fix?

Any input would be greatly appreciated.

Thanks,
Mike
android44 is offline  
Reply With Quote
Old 04-25-2014, 05:41 PM
  #2
beltlover
 
Join Date: Apr 2014
Posts: 7
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I have a AXE CP also and its all over the place..cant hover it or fly it,Ive read a lot of these had bad boards right from helimax..I have not called them yet but thats my next step,Iam going to put a spektrum 6 channel receiver in it and try to find settings for my DX8...Can I ask what setting are you using? Im a noob so I need toned down settings to start with...THANKS!
beltlover is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:13 AM.