Helimax This is for all your Helimax questions and comments.

Binding issue ?

Reply
Old 10-25-2014, 05:34 PM
  #1
jackripped
Thread Starter
 
Join Date: Oct 2010
Location: mackay, AUSTRALIA
Posts: 110
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Binding issue ?

Hi bought a Heli-max Transmitter separate to the Blackhawk chopper, the receiver in the chopper is a RX604FBL, SLT or SCT on the sticker, the transmitter and chopper/receiver are all brand new, I have followed the basic binding instructions in the manual that came with the chopper, as the radio did not come with a manual.
The transmitter is a Heli-max TX6024.
When I follow the instructions, and hold the bind button down for 3 seconds, the light never goes solid red, like its supposed to.
I am new to 2.4 radios and expensive choppers and I have no idea why this wont bind ?

Anyone got any clues ?
jackripped is offline  
Reply With Quote
Old 10-28-2014, 07:20 PM
  #2
jackripped
Thread Starter
 
Join Date: Oct 2010
Location: mackay, AUSTRALIA
Posts: 110
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

So theres no radio experts on this forum at all ?

Anybody ?
jackripped is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:53 AM.