Helimax This is for all your Helimax questions and comments.

Problems with HELI-MAX AXE 2.4 ghz

Reply
Old 09-27-2015, 10:03 AM
  #1
blueeyes
Thread Starter
 
Join Date: Dec 2005
Location: Navarre, FL
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Unhappy Problems with HELI-MAX AXE 2.4 ghz

I bought this helo new back in March. After only a month I was having problems when trying to hover. After hovering for a minute or so it would start spinning (left) out of control. I called Hobby services and explained my problem to them and they said it sounded like the e-board and sent me a new one. This worked good for a about a month or so and it started doing the same thing. They sent me another e-board and after installing it the same problem continued. So I called them again and this time I sent the helo to them to see if maybe they could find something I might have overlooked. They told me they checked out my helo and the only thing they could come up with was that they suspected the tail motor must be bad. They said this motor is no longer available but they offered me a trade in for another model helimax. I said no as I have a ton of spare parts for this one and it flies good when everything works right. Just send it back to me and I will get another motor which I did. This still hasn't solved my problem. So if there is anyone out there that may have some info to solve this problem I would appreciate hearing from you.
blueeyes is offline  
Reply With Quote
Old 05-05-2017, 09:50 AM
  #2
Milhertime
 
Join Date: Apr 2004
Location: Avon, CO
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I had trouble with mine when the tail rotor motor wire became unattached from the main terminal of the tail rotor motor. Not really a big deal, I just soldered it back on. Luckily, I was just hovering when the wire came off, and not so far from the ground. The heli spun in circles since there was no tail rotor, and I just landed pretty quickly. It did scare me a bit, but just as a precaution, I did solder the other wire that did not come off, thinking preemptively for the next incident. Haven't really flown it for a long while. I think I might try to sell it. How did your's work out after some time. Looks like you were looking for some feedback a while ago...
Milhertime is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:44 AM.