Helimax This is for all your Helimax questions and comments.

AXE EZ will not climb

Reply

Old 12-12-2009, 05:11 PM
  #1  
pcexhaust
Junior Member
Thread Starter
 
Join Date: Dec 2009
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default AXE EZ will not climb

All,

I want to get into RC helicopters so Ibought one off of Ebay . I have experience with RC trucks so Ifigured Icould fix whatever was wrong from that experience. I looked through this forum and read that those who had issues with their AXE climbing replaced their motors. Ireplaced both motors with these VTX-018. I installed both of them and the heli still doesn't climb it only barely hovers. Note to others, the shaft on these motors are much to short to really replace the back motor without the gear just bearly hanging on.Anyhow...

I've messed with the trim by moving it six turns each direction and that doesn't help it climb. I measured the voltage on the back motor when only it is at full throttle and get 6.32 volts. When both motors are at full throttle, the back motor reads 5.2 volts.

I am using the same LiPo that came with the Ebay package. It reads slightly over 8 volts when not under a load. I have a new battery coming, but I'm not sure if the battery is the problem.

Does anyone have any suggestions on what Ican do to troubleshoot why it won't climb?

Sincerely,

Pcexhaust
pcexhaust is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service