HPI Monster Truck Forum Talk about HPI monster trucks here. The infamous Savage 21, SS, .25 or any other HPI MT. You can optionally discuss HPI in our general MT discussion forum if you prefer.

SAVAGE X / THROTTLE STUCK

Reply
Old 01-09-2012, 07:55 AM
  #1
NITRO FEVER
Thread Starter
 
Join Date: Jan 2012
Location: Linden , CA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default SAVAGE X / THROTTLE STUCK



Well Friday I recived the NEW Savage X so Saturday I unbox it and begine the engine break in just like the book says 1st 2 tanks let idle on stand and I slightly varied tghrottle rpms at time, well the 3rd tank time came and I put body on and just started cruising it around figure eights and such up and down a few mounds etc. then all of a sudden its like it it lost power and stopped but engine was still running it was about 20' from me so I started walking to it and as I am the engine starts racing rpm's but not really going anywhere by the time I start to grab it the throttle is now pinned wide open it seems and engine just racing but truck wheels were hardly turning I was kind of panicing at this time I got my hand under the body and pinched fuel line and got it shut off, then after taking body off I notice the spur gear is absolutely melted gone and the clutch bell is just clanging around like it is loose and if I turn with my finger it sloppy and not even staying centered, Im very new to Nitro so has anyone heard of anything like this, what could of went wrong...I need help and advise Do you think the motor is ok after being pinned wide open like that. Dont know where to start????????
NITRO FEVER is offline  
Reply With Quote
Old 01-09-2012, 08:04 AM
  #2
steed2-inactive
 
Join Date: Oct 2008
Location: pefferlaw, ON, CANADA
Posts: 1,536
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SAVAGE X / THROTTLE STUCK

is the clutch bell not staying centered on the crankshaft, if so the clutch bell bearings have failed (should have two bearings in there). is the engine mount to plate tight?. it sounds like the engine mount is loose, which also explains the wide open throttle. as the engine vibrated away from the spur gear, the throttle pivot (being mounted to the chassis) pulled the engines carb slide open. explain this to hpi, they will send you a new spur, but for now just go down to your local hobby store and grab one. their about 3 dollars. and go over every screw. I am putting money on that engine mount to plate being loose-scott
steed2-inactive is offline  
Reply With Quote
Old 01-09-2012, 08:05 AM
  #3
steed2-inactive
 
Join Date: Oct 2008
Location: pefferlaw, ON, CANADA
Posts: 1,536
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SAVAGE X / THROTTLE STUCK

oh , and your engine will be fine, the f4.6 is boss!!
steed2-inactive is offline  
Reply With Quote
Old 01-09-2012, 08:21 AM
  #4
NITRO FEVER
Thread Starter
 
Join Date: Jan 2012
Location: Linden , CA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SAVAGE X / THROTTLE STUCK

Thanks for the response so quick, Ihave sent a email to HPII have not got a response yet If I dont get something soon I will call them as well. As far as the motor mount it seemed tight to the chassis and looking from the bottom side all the screw t hat hold the motor in the chassis seem to be square in alignment, but with the bell just basically dangling on the crank shaft anda smooth spur gear there is no way to check the distance if it was set properly, but your theory certainly sounds legimate but the motor felt very tight and it also has a return spring that goes to the opposite site of throttle wich I thought would help keep that slide shut if not on the gas. But finding why it stuck open is a big concern as to prevent from happing again once gear and clutch bell are replaced....
NITRO FEVER is offline  
Reply With Quote
Old 01-09-2012, 08:40 AM
  #5
steed2-inactive
 
Join Date: Oct 2008
Location: pefferlaw, ON, CANADA
Posts: 1,536
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: SAVAGE X / THROTTLE STUCK

the return spring helps but if the engine moves, the servo with stay centered and pull the slide open. this is niether here nor there though if the engine is tight and hasnt moved. can you pull the engine and take some pics of your clutch bell. must be faulty bearings as there is no way they would be "worn" out, after 2 tanks. but this still doesnt explain the engine reving up by itself.
steed2-inactive is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:00 PM.