HPI Monster Truck Forum Talk about HPI monster trucks here. The infamous Savage 21, SS, .25 or any other HPI MT. You can optionally discuss HPI in our general MT discussion forum if you prefer.

Savage X 4.6 running temp?

Reply
Old 02-24-2012, 10:57 AM
  #1
jcmiller05
Thread Starter
 
Join Date: Feb 2007
Location: Knightdale, NC
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Savage X 4.6 running temp?

Hey guys,

I am a noob to nitro but raced electric for many years.

I have a new Savage X 4.6 and have broken it in properly. I have now run about 12 tanks of fuel through it and it seems to always run at about 280-290 degrees. I have the HSN riched out to the point that with a full tank, it barely wants to shift into second gear. It leans out a bit at half tank and looks to be running perfectly with a great smoke trail. It has plenty of power at this point too.

I am just worried that running it at this temp will shorten the life of the engine. Does anyone else have this problem? How long does a typical engine last as far as tanks of fuel?

Also, while I am here, does anyone have any good recommendations for servos? My throttle servo went out already at tank number 9 and they are sending me a new one. In the mean time I just bought a $20 off brand one from my LHS. I would like to go ahead and replace the steering servo too since I have read that they tend to go out quickly as well.

Thanks in advance for any advise.

Jason
jcmiller05 is offline  
Reply With Quote
Old 02-24-2012, 01:00 PM
  #2
209mark123
 
Join Date: Dec 2010
Location: Mariposa, CA
Posts: 232
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Savage X 4.6 running temp?

Some might say thats to hot but Ihave the same truck and it always ran around those temps especially if it was one grass. Iwouldnt let it get any hotter but Iwould say thats ok. Iran my truck at those temps and the engine is still running storng.
209mark123 is offline  
Reply With Quote
Old 02-24-2012, 04:12 PM
  #3
Argess
 
Argess's Avatar
 
Join Date: Jan 2006
Location: Pleasantville, NS, CANADA
Posts: 2,346
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Savage X 4.6 running temp?

Quote:
ORIGINAL: 209mark123

Some might say thats to hot but I have the same truck and it always ran around those temps especially if it was one grass. I wouldnt let it get any hotter but I would say thats ok. I ran my truck at those temps and the engine is still running storng.
I agree. I usually get around 280 degF while running on grass. No problems with that temperature. Now if you get that while running on pavement, then that's another story.
Argess is offline  
Reply With Quote
Old 02-25-2012, 12:39 PM
  #4
thef@st1
 
Join Date: Mar 2009
Location: mindoro, WI
Posts: 159
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Savage X 4.6 running temp?

might have an air leak. use some high temp sealent and seal up that engine good. should run better. also might have a bad piece of fuel line.
thef@st1 is offline  
Reply With Quote
Old 02-25-2012, 09:10 PM
  #5
Ziggmiester
 
Join Date: Aug 2005
Location: Liverpool, NY
Posts: 510
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Savage X 4.6 running temp?

Nothing too bad with 280. I've always tried to aim for 240 myself as a general basher. It's a bit hot. I would try to find a guide on sealing the engine up. My engine needed sealing very shortly after break in and it solved the problem for years. The engine not being sealed properly also could be the problem you're having not shifting into second gear.

-Mike
Ziggmiester is offline  
Reply With Quote
Old 03-07-2012, 09:56 AM
  #6
automan54
 
Join Date: Oct 2007
Location: Nokesville, VA
Posts: 11
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Savage X 4.6 running temp?

I have the same engine and they all run on the hot side. The best thing to do as get some Peratex Ultra Black RTV , remove the back plate and carb, replace the "O" rings and add a little RTV around the base of the carb and put it back in , also remove the pinch bolt that hold the carb in place and add some RTV in the bolt hole and put it back. Do the same with the back plate. After an hour or so to let the RTV cure, put a little dish soap and water mix around the base of the carb, front crank shaft bearing and back plate, put you finger over the carb and blow into the exhaust port with the piston down. You should have no bubbles, if you do add more RTV or in the case of the front bearing, REPLACE it. After doing this the my engine and retuning it , it had more power and the temp went down to around 240.
Good Luck!
automan54 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:37 AM.