HPI Monster Truck Forum Talk about HPI monster trucks here. The infamous Savage 21, SS, .25 or any other HPI MT. You can optionally discuss HPI in our general MT discussion forum if you prefer.

Problem with a battery

Reply
Old 02-27-2012, 09:46 PM
  #1
209mark123
Thread Starter
 
Join Date: Dec 2010
Location: Mariposa, CA
Posts: 232
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Problem with a battery

Irecently purchased a new savage flux HPalong with two venom 5000mah 50 c batteries. First couple of packs it went great now when Iwent to charge one of them my charger told me something was wrong and Inotcied one of the wires going into the balancing plug has came loose at the battery end of it. These were both brand new batteries no idea how this could have happened. Anybody ever had this happen before? They say they offer a one year warranty on all their batteries think they will fix this, Ihave never had to deal with them before so Im not sure what to expect. Waiting back on a email for them right now might just call them tommorow.
209mark123 is offline  
Reply With Quote
Old 03-10-2012, 11:54 PM
  #2
moezer
 
Join Date: Oct 2010
Location: , AB, CANADA
Posts: 350
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Problem with a battery

take it back to ur hobby shop store and see if they will exchange it for you
moezer is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:59 PM.