HPI Monster Truck Forum Talk about HPI monster trucks here. The infamous Savage 21, SS, .25 or any other HPI MT. You can optionally discuss HPI in our general MT discussion forum if you prefer.

Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

Reply
Old 10-10-2012, 08:05 AM
  #1
stimpytheman
Thread Starter
 
Join Date: Oct 2012
Location: Flat rock, MI
Posts: 7
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

Hello everyone ... Newbie here with a HPI savage x4.6 ... Question... Problem is that when I'm running my truck up and down the street it will run fine and then will rev up when I hit the throttle and not go anywhere but will eventually kick back in and catch and start going again .... Pretty much similar to that of a slipping transmission in a regular car. I thought it may be the clutch shoes and when I took off the clutch bell to check , they looked like they were worn down a bit so I changed them, made no difference. Please help ... Not sure what else this could be ... Thanks for any help in advance
stimpytheman is offline  
Reply With Quote
Old 10-10-2012, 05:40 PM
  #2
stimpytheman
Thread Starter
 
Join Date: Oct 2012
Location: Flat rock, MI
Posts: 7
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

anybody have any ideas?? please help...this is driving me nuts.... thanks in adance
stimpytheman is offline  
Reply With Quote
Old 10-11-2012, 12:29 AM
  #3
Bash-m-up
 
Bash-m-up's Avatar
 
Join Date: Oct 2005
Location: Georgtown, KY
Posts: 931
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

Does the engine rev up eractically with the truck going no where? Have you been able to see the gears spinning while it revs like this while the truck sets still? It almost sounds like the truck is running lean and then once it cools or catches up it is able to go again, almost like a fuel starved engine would. Just curious.
Bash-m-up is offline  
Reply With Quote
Old 10-11-2012, 07:51 AM
  #4
stimpytheman
Thread Starter
 
Join Date: Oct 2012
Location: Flat rock, MI
Posts: 7
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

Yeah it does rev up erratically sometimes but only if I hit the throttle ... Then it will stick at wide open throttle and I will have to pinch the fuel line to turn it off... Other times I will rev it a couple times when it's moving just to make it hop a little and it wi rev up but not go anywhere like a trans slipping in a car... Not sure if it's lean because at running temp the motor is only running at about 220 degrees and if it were really lean wouldn't it be over heating? Thanks for any help in advance
stimpytheman is offline  
Reply With Quote
Old 10-11-2012, 03:37 PM
  #5
racingfan48
 
Join Date: Jul 2012
Location: Omaha, NE
Posts: 28
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

http://extremercmods.com/content/tuning-popup.html

try this website, I used it for my truck an worked great. Make really small adjustments on the needles. If the needles are too lean it will cause the engine to be erratic. Also check the clutch inside the tranny make sure none of the set screws came loose and are spinning on the shaft 
racingfan48 is offline  
Reply With Quote
Old 10-11-2012, 05:27 PM
  #6
AIRSAVAGE
 
AIRSAVAGE's Avatar
 
Join Date: Aug 2005
Location: Cary, NC
Posts: 171
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

I just got my Savage X 4.6 about 3 weeks ago and had a problem on my fourth break in tank. It would rev up but wouldn't move. And, it didn't work anymore at all. So, this might be different than the issue you're having but it's worth telling you. Ultimatly what I found was the collet the fly wheel sits on ground itself into the flywheel. It wasn't able to grip the shaft anymore and shifted everything (including the clutch shoes) forward. It shreaded the springs. So, I called HPI and they sent a new collet, fly wheel, clutch shoes and springs. I put the new parts on and it's been working fine.
AIRSAVAGE is offline  
Reply With Quote
Old 10-11-2012, 05:32 PM
  #7
-SomeGuy-
 
-SomeGuy-'s Avatar
 
Join Date: Nov 2005
Location: Montreal, QC, CANADA
Posts: 3,738
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

10$ says its the tranny. I cant think of any other part that would affect the truck in this way. I had a 3 speed that blew the 3rd gear, it would drive fine at lower speed but once it hit a high speed it would rev up while slowing down. Can you post a video? that would help us help you.
-SomeGuy- is offline  
Reply With Quote
Old 10-18-2012, 07:26 AM
  #8
qaz393
 
Join Date: Jun 2005
Location: Markham, ON, CANADA
Posts: 390
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie here..plz help. Savage x4.6 revs up with throttle but doesnt move,like slipping clutch in car

check slipper clutch as well?
qaz393 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:34 PM.