HPI Monster Truck Forum Talk about HPI monster trucks here. The infamous Savage 21, SS, .25 or any other HPI MT. You can optionally discuss HPI in our general MT discussion forum if you prefer.

savage is not starting

Reply
Old 05-15-2007, 06:18 PM
  #1
chris15
Thread Starter
 
Join Date: Jan 2007
Location: sault ste marie, MI
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default savage is not starting

okay so im starting my savage 25 and nothing not even a pop i pumped the lines andthere was gas geting to the and later on i herd a clicking noise kind of i dont know if it was it trying to start but there was a lot of gas splattering out of the carb.


help please thanks,
chris15 is offline  
Reply With Quote
Old 05-15-2007, 06:34 PM
  #2
Vigilante212
 
Vigilante212's Avatar
 
Join Date: Sep 2006
Location: Menasha, WI
Posts: 2,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

Thats kind of vague. It could be alot of things. If you have a rotostart it could be the one way bearing. It could be a bad seal in your carb. It could be a broken con rod or lose of compression. Or it could just be flooded or have a bad glow plug.
Vigilante212 is offline  
Reply With Quote
Old 05-15-2007, 07:13 PM
  #3
chris15
Thread Starter
 
Join Date: Jan 2007
Location: sault ste marie, MI
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

i checked everything except the compression if thats the proplem how do i fix it
chris15 is offline  
Reply With Quote
Old 05-15-2007, 07:30 PM
  #4
Vigilante212
 
Vigilante212's Avatar
 
Join Date: Sep 2006
Location: Menasha, WI
Posts: 2,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

If you have no compression your engine is shot and needs a new piston and sleeve. Or a new engine.

Take the engine out and take the back plate off to see if there s any damage inside or any loose bits. Next take the cooling head off and chec for damage to the top of the piston or scoring along the sleeve. Post pictures if you can.
Vigilante212 is offline  
Reply With Quote
Old 05-15-2007, 08:24 PM
  #5
chris15
Thread Starter
 
Join Date: Jan 2007
Location: sault ste marie, MI
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

one way goes one way and the sleve is absoulutly clean
this is my first tank of different fuel though i went from odonnall 20% to dynamite blue thunder race formula 20% could that be the problem
chris15 is offline  
Reply With Quote
Old 05-15-2007, 08:27 PM
  #6
aer-wubby
 
aer-wubby's Avatar
 
Join Date: Jul 2006
Location: , IL
Posts: 2,902
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

I heard Blue Thunder is crap..
aer-wubby is offline  
Reply With Quote
Old 05-15-2007, 08:31 PM
  #7
burnchassis3
 
burnchassis3's Avatar
 
Join Date: Feb 2006
Location: Cincinnati, OH
Posts: 983
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

I been running blue thunder for about 5 gallons.
I have nothing bad to say.
30%
CS
burnchassis3 is offline  
Reply With Quote
Old 05-15-2007, 08:33 PM
  #8
chris15
Thread Starter
 
Join Date: Jan 2007
Location: sault ste marie, MI
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

why is that
chris15 is offline  
Reply With Quote
Old 05-15-2007, 09:23 PM
  #9
fxrs
 
fxrs's Avatar
 
Join Date: Dec 2004
Location: tabernacle, NJ
Posts: 722
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

Are you sure glow plug is good?

Attached Thumbnails
Click image for larger version

Name:	Tr50322.jpg
Views:	4
Size:	175.9 KB
ID:	685374  
fxrs is offline  
Reply With Quote
Old 05-16-2007, 06:32 AM
  #10
chris15
Thread Starter
 
Join Date: Jan 2007
Location: sault ste marie, MI
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: savage is not starting

ijust put a new one in when i started it. whats the best plug for a svage engine?
chris15 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:36 PM.