RCU Forums

RCU Forums (http://www.rcuniverse.com/forum/)
-   HPI Monster Truck Forum (http://www.rcuniverse.com/forum/hpi-monster-truck-forum-250/)
-   -   Savage Carb Issue - VIDEO (http://www.rcuniverse.com/forum/hpi-monster-truck-forum-250/11231909-savage-carb-issue-video.html)

xDIRTYSOUTHx 09-17-2012 07:46 PM

Savage Carb Issue - VIDEO
 
Hello all. I was in the middle of breaking in my Savage X and all of a sudden the truck would not respond very well to throttle. I was in the middle of tuning and getting great performance as I adjusted the HSN but then the truck got really slow. I checked all the links and servos and everything looked fine. I just took the carb out and see that the slide will only open about 1/4 to 1/2 of the way. It feels like something hard is keeping it from opening all the way and not debris or something.

Anyone had this issue and what should I do to find out what's keeping the carb from opening all the way? I've never had to do any major carb work so any advice will be great.

Here's a short clip showing the carb. It will close very smooth like normal but when it gets about 1/4 of the way open it stops and cant be forced open any further.

http://s52.photobucket.com/albums/g3...=VIDEO0069.mp4<br type="_moz" />

xDIRTYSOUTHx 09-17-2012 08:36 PM

RE: Savage Carb Issue - VIDEO
 
took the carb apart and seems there is a pretty big piece of metal shaving lodged in the side of the side where the idle screw is located. I'm going to try and file it down. No idea how or why it's like that but it's clearly not suppose to be like that.


All times are GMT -8. The time now is 11:19 AM.