If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 5 of 5

  1. #1

    Help the greenhorn!

    Basically I recently recieved an HPI MT2 truggy from my brother in law for free. Also has a big pile of parts and bodies and everything I could want minus new upgrades.
    He recieved it(along with 8+ other vehicles) from a friend who could no longer do it, so this Trug has already been upgraded to some extent.

    What Im confused about for THIS post(this thread will probably have many more questions added later..) is at the front end.. I got a copy of the manual and instead of the wheel having an axle, then a dogbone, then a differential shaft to complete the train for each wheel.. but this has like a u-joint with a dogbone style end on it, and it seems like somethings missing.
    im a very handy person and have not dug around deep enough like i should have for a hobby like this.. but cmon, help me out. lol

    lets refer to pics..

    So... please slather me in info about this.

    also... i couldnt find anything on this. *** is this thing? The black arm thing with the hole in it. it swings back and forth and is obviously a mount for something, but what that is eludes me.

    thank yall for any and all info you can give me. i wanna get this thing cleaned up and back in order and go shmob it already.

  2. #2
    Okay, so the axles are CVDs. I've dug all over the web but I still can't find out why the dogbone doesn't connect.

    Help? Anyone? Take 30 seconds to drop some knowledge?

  3. #3
    Moderator Foxy's Avatar
    Join Date
    Mar 2005
    Kingston UK, but living in Athens, GREECE
    Can you take a pic of the problem, I'm not exactly clear what's happening from the description.
    Down with the crew known to pump up the bass...
    We rock the joint at a cool, steady pace.
    RCU Community Moderator

  4. #4
    aspeed's Avatar
    Join Date
    Jul 2011
    Ruthven, ON, CANADA
    The holes in the front might be for a sway bar which may or may not be needed or wanted. Not that I am knowledgeable on these things.

  5. #5
    whee-sconsin basher's Avatar
    Join Date
    Oct 2013
    Southern Wisconsin
    My Gallery
    My Models
    My Feedback

    Here's a starting point. Not sure why the cvds don't reach unless they are the wrong part#, but I think the shocks in place of the turnbuckles are partly to blame.
    The plastic part I think is the hanger for the oem exhaust.
    Last edited by whee-sconsin basher; 10-15-2013 at 11:27 AM. Reason: Forgot stuff


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
RCU Reviews
All times are GMT -6. The time now is 01:34 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.