HPI Racing HPI Racing forum. Discuss all HPI Racing products here.

HPi Rush evo clutch gone?

Reply

Old 08-31-2017, 06:32 AM
  #1  
RussianEvo
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default HPi Rush evo clutch gone?

Hello all,

I know there's a few posts on rush evos and all but I don't know where to start..
I got a rush evo a decent amount of years ago and remember thinking it was broke, I came across it again a few days ago, ordered a new air filter and glow plugs with an igniter. I couldn't get it started so took the engine off along with the fuel tank to inspect it.. I tried taking the clutch bell off but it won't come off? It just spins and the engine chokes.. This is my main problem as I don't know wherever to order a new clutch? I put the engine back in and got it running! It ran for 10 seconds then cut out. Started again and ran for around 20 seconds, this gave me a little time to try give it some throttle.. it didn't do anything at all, wheels didn't move nothing?

You can see the clutch bell is shaking but that's it. Tried getting it started again and no joy..

There's no fuel going from the tank into the carb.. pushing the prime button gets it halfway up the tube, then back down..

Any help would be great, would love to get this thing back up and running! New hobby for me haha!
Thanks
Russ
RussianEvo is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service