Ikarus Aerofly flight simulators Get the answers to your technical questions about Ikarus' Aerofly flight simulators here in their official support forum

AFPD crashing when opening certain models

Reply
Old 05-22-2011, 12:40 AM
  #1
chipbutty
Thread Starter
 
Join Date: Jul 2008
Location: , UNITED KINGDOM
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default AFPD crashing when opening certain models

I have an iMac and recently bought AFPD for the Mac. Mac is running OS X 10.6.7, 2.66Ghz Intel Core 2 Duo, 4GB RAM, NVIDIA GeForce 9400. When I open some models they crash AFPD forcing it to close. Yesterday I had the problem when opening the Logo 500 and Gazaur Mars helis. So I decided to uninstall AFPD and resinstall it. This seemed to work fine and I could now fly the Logo and Mars again. Then the Eagle heli, which previously worked fine, does the same thing and forces AFPD to crash. A reinstall only seems to help temporarily. My guess is that by the end of the day I will have more models doing the same thing, that's the general pattern until I reinstall AFPD again. I haven't tinkered or altered any of these models. I also have the latest patch for the Mac installed. Can anyone help please? It's driving me insane!

tm.log file


tm: Library Version 4.2d, Copyright (C) 1998-2009, IPACS
tm: http://www.ipacs.de
openal: init structs
openal: init (default=Built-in Output) (0:Built-in Output) (using default device) (version=1.1) (1.1) (Built-in Output) (Built-in Output) ok
tmsystem: mac os version=10.67
loading font v2 texture/fontuni.tff=(2048x2048) (h=16) (nc=65536) (split=1) ok
tmgl: loading mouse texture/mouse.tmt=ok
tmprogram: AeroFly Professional Deluxe Version 1.11.07.31, Copyright (C) 1998-2009 IPACS
loading configfile config/main.mcf=ok
loading player configfile config/player1.mcf=ok
loading player configfile config/player2.mcf=ok
openal: register sound sound/beep.wav=(0, rd=100.00) ok
openal: register sound sound/balloon.wav=(1, rd=100.00) ok
openal: register sound sound/crash.wav=(2, rd=100.00) ok
openal: register sound sound/splash.wav=(3, rd=100.00) ok
openal: register sound sound/glider.wav=(4, rd=2.00) ok
openal: register sound sound/glider2.wav=(5, rd=2.00) ok
openal: register sound sound/glider.wav=(already registered)(6, rd=5.00) ok
openal: register sound sound/glider2.wav=(already registered)(7, rd=5.00) ok
openal: register sound sound/glider.wav=(already registered)(8, rd=2.00) ok
openal: register sound sound/glider2.wav=(already registered)(9, rd=2.00) ok
openal: register sound sound/glider.wav=(already registered)(10, rd=5.00) ok
openal: register sound sound/glider2.wav=(already registered)(11, rd=5.00) ok
afdesign: init ok
gl: vendor=NVIDIA Corporation, renderer=NVIDIA GeForce 9400 OpenGL Engine, version=2.1 NVIDIA-1.6.26
gl: (viewport=8192x8192) (texturesize=2048) (stencil=8)
gl: extensions=GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_vertex_blend GL_ARB_window_pos GL_ARB_shader_objects GL_ARB_vertex_shader GL_ARB_shading_language_100 GL_EXT_multi_draw_arrays GL_EXT_clip_volume_hint GL_EXT_rescale_normal GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_geometry_shader4 GL_EXT_transform_feedback GL_APPLE_client_storage GL_APPLE_specular_vector GL_APPLE_transform_hint GL_APPLE_packed_pixels GL_APPLE_fence GL_APPLE_vertex_array_object GL_APPLE_vertex_program_evaluators GL_APPLE_element_array GL_APPLE_flush_render GL_APPLE_aux_depth_stencil GL_NV_texgen_reflection GL_NV_light_max_exponent GL_IBM_rasterpos_clip GL_SGIS_generate_mipmap GL_ARB_imaging GL_ARB_point_parameters GL_ARB_texture_env_crossbar GL_ARB_texture_border_clamp GL_ARB_multitexture GL_ARB_texture_env_add GL_ARB_texture_cube_map GL_ARB_texture_env_dot3 GL_ARB_multisample GL_ARB_texture_env_combine GL_ARB_texture_compression GL_ARB_texture_mirrored_repeat GL_ARB_shadow GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_occlusion_query GL_ARB_point_sprite GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ARB_pixel_buffer_object GL_ARB_draw_buffers GL_ARB_shader_texture_lod GL_ARB_color_buffer_float GL_ARB_half_float_vertex GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_ARB_framebuffer_object GL_EXT_compiled_vertex_array GL_EXT_draw_buffers2 GL_EXT_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_texture_rectangle GL_ARB_texture_rectangle GL_EXT_texture_env_add GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_lod_bias GL_EXT_abgr GL_EXT_bgra GL_EXT_stencil_wrap GL_EXT_texture_filter_anisotropic GL_EXT_secondary_color GL_EXT_blend_func_separate GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_compression_dxt1 GL_EXT_texture_sRGB GL_EXT_blend_equation_separate GL_EXT_texture_mirror_clamp GL_EXT_packed_depth_stencil GL_EXT_bindable_uniform GL_EXT_texture_integer GL_EXT_gpu_shader4 GL_EXT_framebuffer_sRGB GL_EXT_provoking_vertex GL_APPLE_flush_buffer_range GL_APPLE_ycbcr_422 GL_APPLE_rgb_422 GL_APPLE_vertex_array_range GL_APPLE_texture_range GL_APPLE_float_pixels GL_ATI_texture_float GL_ARB_texture_float GL_ARB_half_float_pixel GL_APPLE_pixel_buffer GL_APPLE_object_purgeable GL_NV_point_sprite GL_NV_blend_square GL_NV_fog_distance GL_NV_depth_clamp GL_NV_multisample_filter_hint GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NV_conditional_render GL_ATI_texture_mirror_once GL_ATI_texture_env_combine3 GL_ATI_separate_stencil GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_EXT_texture_array GL_EXT_vertex_array_bgra GL_ARB_instanced_arrays GL_ARB_depth_buffer_float GL_EXT_packed_float GL_EXT_texture_shared_exponent
gl: extensions=(anisotropic filter of 16.00) (compressed texture) (cubemaps) (shader) (framebuffer)

framebuffer object created (1024, 1024)
framebuffer object created (256, 256)
tminput: searching for input devices...(3)
tmsystem: searching usb interface (0,0) 0=radiointerface
tmsystem: searching dummy usb interface (0) 1=unable to open interface device
tmsystem: searching dummy usb interface (0) 1=unable to open joystick device
tminput: 1 devices found
license (A040-6EE8907B.lic): entries=49
sim: loading scenery scenery/us-lincoln-sky-knights.geo...
sim: 1 objects 0 dynobjects
sim: start position (3ds) multi pano 1 (not for helicopter)
sim: start position (3ds) multi pano 2 (not for helicopter)
sim: start position (3ds) multi pano 3 (not for helicopter)
sim: start position (3ds) multi pano 4 (not for airplanes)
sim: start position (3ds) multi pano 5 (not for airplanes)
sim: start position (3ds) multi pano 6 (not for airplanes)
sim: start position (3ds) multi pano 7 (not for airplanes)
sim: load texture grid 12x12 (pano=0) (compress=1) named us-lincoln-sky-knights/us-lincoln-sky-knights=(3.750x5.000) (12x12) (8x4)
sim: photo pos(0)=0.0100 -0.0020 1.6000
sim: sphere 3ds params(0)=0.0000 0.0000 -66.1010
sim: sphere 3ds offset(0)=0.0000 0.0000 -20.0000
sim: loading ground object scenery/us-lincoln-sky-knights/us-lincoln-sky-knights.obj=ok
sim: loading time=2649382 mus
sim: 1 photo scenes
tmcollision: 63618 triangles using 8143104 bytes
tmcollision: omin=(-4648.1,-4701.5,-44.8) omax=(4634.1,4529.8,665.8) octmin=(10.0,10.0,10.0)
tmcollision: otnodes=2745 otendnodes=1373 otdepth=27 otlistareas=1621386
tmcollision: otnmaxareas=2993 otnavgareas=70 otnminsize=(9.065,9.015,5.551)
tmcollision: otareas=97459 mem=8532940
tmcollision: 2745 octrees, using 417240 bytes
tmcollision: total mem=8950180 bytes
tmcollision: time=0.43s
tmcolldynamic: no dynamic objects or triangles
sim: loading aircraft 1 logo500...
tmdairfoil: loading flat ok
openal: register sound sound/blade1.wav=(12, rd=2.57) ok
openal: register sound sound/logo500.wav=(13, rd=2.57) ok
generating shadow 0=radius=1.17 bbmin=(-0.89 -0.89 -0.18) bbmax=(0.89 0.89 0.21)
sim: creating blurr=Rotor
sim: creating blurr=TailRotor
loading input device calibration config/radio0.tmc=ok
tmsystem: calibrating radio deviations= 0 3 6 9 -16 25 (timer=24959) -36 4) 88 (91176F84)
license: tml file 'afpd-a040.tml' = A040 0000 0000 0000 'AeroFly Professional Deluxe Platinum Edition' 'A040-6EE8907B.lic' (activated=1)
openal: loading sound/beep.wav= ok 0 22050.00
openal: loading sound/balloon.wav= ok 1 22050.00
openal: loading sound/crash.wav= ok 2 22050.00
openal: loading sound/splash.wav= ok 3 22050.00
openal: loading sound/glider.wav= ok 4 22050.00
openal: loading sound/glider2.wav= ok 5 22050.00
openal: loading sound/glider.wav= ok 6 22050.00
openal: loading sound/glider2.wav= ok 7 22050.00
openal: loading sound/glider.wav= ok 8 22050.00
openal: loading sound/glider2.wav= ok 9 22050.00
openal: loading sound/glider.wav= ok 10 22050.00
openal: loading sound/glider2.wav= ok 11 22050.00
openal: loading sound/blade1.wav= ok 12 22050.00
openal: loading sound/logo500.wav= ok 13 22050.00
sim: switching to simulation mode...
tmdynamics: simulation started
sim: aircraft=(0.00,-5.00,0.43), viewer=(-0.00,-0.01,1.60)
sim: 2985 memory blocks using 25523922 bytes
saving configfile config/main.mcf=ok
saving player configfile config/player1.mcf=ok
tmdynamics: simulation stopped
tmgl: loading geometry aircraft/eagle/eagle.obj= fail(-3)
openal: register sound sound/eagle-idle.wav=(12, rd=3.45) ok
openal: register sound sound/eagle-hoov.wav=(13, rd=3.45) ok
openal: register sound sound/eagle-3d.wav=(14, rd=3.45) ok
chipbutty is offline  
Reply With Quote
Old 05-23-2011, 03:22 PM
  #2
rajul
 
rajul's Avatar
 
Join Date: Jun 2002
Location: Missouri City, TX
Posts: 8,145
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: AFPD crashing when opening certain models

chip, are you using an iMac or a Mac Book Pro?
rajul is offline  
Reply With Quote
Old 07-02-2011, 08:42 AM
  #3
chipbutty
Thread Starter
 
Join Date: Jul 2008
Location: , UNITED KINGDOM
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: AFPD crashing when opening certain models

Apologies for not getting back sooner. Small matter of a new born baby coming along! I'm using an iMac. The strange thing is I've not had the issue for some weeks now. Each time this happened I simply copied the model folder from the install disc over the offending model. This worked. Fingers crossed. Mind you I wouldn't mind knowing what the issue is/was.

Quote:
ORIGINAL: rajul

chip, are you using an iMac or a Mac Book Pro?
chipbutty is offline  
Reply With Quote
Old 07-05-2011, 04:04 AM
  #4
rajul
 
rajul's Avatar
 
Join Date: Jun 2002
Location: Missouri City, TX
Posts: 8,145
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: AFPD crashing when opening certain models

Sure sounds strange but glad it's OK for now.
rajul is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:43 AM.