Jet Central Turbines - Artes Jet Jet Central Turbines formerly the Artes Jet forum

Slow Kero start on Cheetah

Reply

Old 03-27-2011, 04:17 AM
  #1  
luv2flyrc
Thread Starter
My Feedback: (6)
 
luv2flyrc's Avatar
 
Join Date: Jan 2002
Location: Mississauga, ON, CANADA
Posts: 1,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Slow Kero start on Cheetah

Hi Eric, as a follow-up to my post in the other thread, here's some info on my Cheetah:

It starts up but, it takes a long time to do it, the start process can take over 2 minutes. Where it hangs is in the "pre heat" stage at 8000rpm. I've successfully test run it 3 times now and the last time it hung at that stage for about a minute, the previous times it was a good 2 minutes in Pre heat.

I believe the starting temp in Pre heat was 70d C, I'll have to run it again to get the Pw for you. In the GSU the Pump Pw ignition K = 40. In the pre heat stage the temp starts to climb very, very slowly while the RPM is maintained at 8000 but, eventually the temps get to where they need to be ( I can't recall what temp that is off hand) and it starts normally.


As a side note, not sure if it's related, my first 3 attempts to start it were unsuccessful. I received the "start bad" error as in attempt #1, the starter didn't engage, although, the burner lit and the pump was pumping starting fuel in . In attempts #2 and 3, the starter engaged but only got up to 2200 rpm. It did not seem to be a problem with the starter as the starter would run freely in the cooling mode.

I put it down to the cold temps ( it's around the freezing mark here) playing havoc with the battery although the battery was fully charged. I brought the battery inside to warm it, re-charged it and the next 3 starts were the ones that worked but, were slow in the Pre heat stage.

Any thoughts on it?



Regards,

Mike
luv2flyrc is offline  
Reply With Quote
Old 03-27-2011, 08:29 AM
  #2  
powerjets
 
Join Date: May 2006
Location: burlington, ON, CANADA
Posts: 458
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Mike,
My Rabbit starts way easier when outside temps are just a little warmer...over +5 C will make a big difference.
Hans
powerjets is offline  
Reply With Quote
Old 03-27-2011, 08:33 AM
  #3  
luv2flyrc
Thread Starter
My Feedback: (6)
 
luv2flyrc's Avatar
 
Join Date: Jan 2002
Location: Mississauga, ON, CANADA
Posts: 1,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Thanks Hans,

Eric, just a further heads up, I just tried to start it again now to get some readings for you and I had 2 failed starts both reading "start bad" as the starter failed to develop enough rpm. It got to about 2200rpm. Now with subsequent attempts , the starter will not run at all. Not during the start process or if I run the cooling mode or test mode.

It is cold out side but, surely should run in these temps regardless.

Any ideas?

Mike
luv2flyrc is offline  
Reply With Quote
Old 03-27-2011, 09:14 AM
  #4  
powerjets
 
Join Date: May 2006
Location: burlington, ON, CANADA
Posts: 458
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Mike, the starter leads have a bullet connection in the middle, these can be a little loose sometime, should check.
Hans
powerjets is offline  
Reply With Quote
Old 03-27-2011, 09:35 AM
  #5  
luv2flyrc
Thread Starter
My Feedback: (6)
 
luv2flyrc's Avatar
 
Join Date: Jan 2002
Location: Mississauga, ON, CANADA
Posts: 1,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Thanks Hans,

I've just checked them, everything is connected but, the starter is definitely dead. The engine's now inside and at room temps but starter still won't spin. I suspect something was up with the starter from the beginning , as stated in my first post, on my first start attempt it didn't run, 2nd and 3rd attempts, it ran but only achieved 2200 to 2400 rpm and the starts failed. Then I had 3 successful starts but, they took a very long time (ie. several minutes to start). So, now i'm guessing they probably took that long because the starter wasn't right or the fact that they took so long burned out the starter. Either way, the starter's dead.

I'll have to see when Eric responds if there's something else I can do or whether it needs to go back to him. He's in Florida, with any luck he's out flying and that's why I haven't heard back yet

Mike
luv2flyrc is offline  
Reply With Quote
Old 03-27-2011, 10:43 AM
  #6  
noahb
My Feedback: (67)
 
Join Date: Jan 2002
Location: Carlsbad, NM
Posts: 1,304
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Get in touch with Eric. You most likely have a bad starter. A weak starter will struggle to get the rpm up.
noahb is offline  
Reply With Quote
Old 03-27-2011, 10:44 AM
  #7  
noahb
My Feedback: (67)
 
Join Date: Jan 2002
Location: Carlsbad, NM
Posts: 1,304
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

If your starter is bad (most likely) Eric will send you one (if it's under warranty thru him) and that will get you going again.
noahb is offline  
Reply With Quote
Old 03-27-2011, 10:58 AM
  #8  
BluFox
My Feedback: (10)
 
Join Date: Jan 2002
Location: North Port, FL
Posts: 1,107
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Mike:

"Start Bad" is for three reasons only: 1. You have no temp reading. . 2. you have no rpm reading and. . 3 the turbine failed to reach the programmed rpm for ramp.

First, I would check the ECU battery. . .fully charged ? Second, menu up to the second screen (voltage, puls/rpm is listed) and leave on this screen - then initiate start. Observe the battery performance.

Second, menu up to the "Start - INFO - Radio - Run " screen. Enter the info section, menu up to the test starter test. . .then test starter.

After eliminating all other possibilities, email me your address so I can ship you a replacement starter Monday. You should have it by Wednesdayl I do apologize for the issue.

Regards,
Eric
BluFox is offline  
Reply With Quote
Old 03-27-2011, 11:26 AM
  #9  
luv2flyrc
Thread Starter
My Feedback: (6)
 
luv2flyrc's Avatar
 
Join Date: Jan 2002
Location: Mississauga, ON, CANADA
Posts: 1,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Thanks Eric!

I sent an email to you at jetartessales@aol.com

Regards,

Mike
luv2flyrc is offline  
Reply With Quote
Old 04-07-2011, 03:53 PM
  #10  
luv2flyrc
Thread Starter
My Feedback: (6)
 
luv2flyrc's Avatar
 
Join Date: Jan 2002
Location: Mississauga, ON, CANADA
Posts: 1,655
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Slow Kero start on Cheetah

Eric,

I got my engine back today. thanks to you and Chuck Storrie for getting it turned around so fast. It starts up real smooth and quick now.

Regards,

Mike
luv2flyrc is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service